Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: How to stop the System Tray (Unity) to stop "auto hiding"?

  1. #1
    Join Date
    Mar 2012
    Beans
    8

    How to stop the System Tray (Unity) to stop "auto hiding"?

    Hi All,

    I am not sure if I am posting in the "right" place - as this is my first post at the Ubuntu forums - please let me know if it would be better suited in another area.

    I have noticed on my Ubuntu 11 install that the Unity System Tray - which I can only guess is the "equivalent" to the Windows Taskbar - keeps "hiding" whenever apps are dragged over it, or alternatively whenever app windows are made to cover the area that it occupies.

    I would like to stop this "scrolling" / "hiding" behaviour! Ideally I want the System Tray to stay exactly where it is, on the left hand side of my screen, and I don't want it going anywhere under any circumstances.

    Any suggestions on how to achieve this will be greatly appreciated.

    Kind Regards,

    iDudetu

  2. #2
    Join Date
    Nov 2009
    Location
    Los Angeles
    Beans
    383
    Distro
    Ubuntu

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    If you install Compiz Config Settings Manager from the Ubuntu Software Center, you'll find in it a section called "Unity Plugin" - there you'll find settings to adjust the behavior of the Launcher.

  3. #3
    Join Date
    Jun 2010
    Location
    London, England
    Beans
    7,493
    Distro
    Ubuntu Development Release

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    By the way. That "Dodge windows" behavior has been removed in 12.04. And already people are complaining. They say they wanted it. You don't. Other do. That is life.

    Also in 12.04 you can switch off or on the Launcher autohide behavior in the Appearance utility in System Settings. You will not need to install Compiz Config Settings Manager (CCSM) to do that.

    Regards.
    It is a machine. It is more stupid than we are. It will not stop us from doing stupid things.
    Ubuntu user #33,200. Linux user #530,530


  4. #4
    Join Date
    Nov 2009
    Location
    Los Angeles
    Beans
    383
    Distro
    Ubuntu

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    Quote Originally Posted by grahammechanical View Post
    By the way. That "Dodge windows" behavior has been removed in 12.04. And already people are complaining. They say they wanted it. You don't. Other do. That is life.
    I don't understand why they couldn't just change the default but leave Dodge available as an option. While I prefer a persistent Launcher myself, Dodge was a truly innovative solution not found in any other OS, and it seems a great many people have come to love it.

    Also in 12.04 you can switch off or on the Launcher autohide behavior in the Appearance utility in System Settings. You will not need to install Compiz Config Settings Manager (CCSM) to do that.
    Unfortunately, while the CCSM Unity plugin currently provides four options for Launcher behavior, the new Settings panel in 12.04 provides only two (show or auto-hide).

    Worse, nearly all of the other settings in CSSM's Unity Plugin aren't in the new Settings panel at all, requiring users to use CCSM to adjust those behaviors (or anomalies, depending on one's view of them <g>).

    Ironically, this decision to go with unusually sparse options comes at the very time some members of the team would like to ditch CCSM altogether, thus requiring CCSM be maintained.

    I can understand not porting everything CCSM does to the Settings panel, or even all of the options in its Unity plugin.

    But as it is, 12.04 accomplishes something that to the best of my knowledge has never been achieved by any other distro: they have fewer options available to the user to adjust appearance than even Mac OS.

  5. #5
    Join Date
    Mar 2012
    Beans
    8

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    Hi Everyone,

    Thanks very much for your kind responses.

    Regards

    iDudetu

  6. #6
    Join Date
    Mar 2012
    Beans
    8

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    Hi Everyone,

    I tried the Compiz..., but it didn't change the behaviour of the System Tray as I had expected. I tried every different setting, and sure enough the tray still "disappeared" off screen, only to return when I moused over the very left edge of the screen!

    To reiterate I just want to "glue" the System Tray in place so that it behaves like the default Windows Taskbar - in so far as it does not "hide" under any conditions.

    What an annoying feature! But what it super annoying is that you can't right click on the tray, as you can in Windows, and dictate behaviour in a logical way.

    For all those who like the tray to hide - I challenge you to do some work on your computer, because I am the hair and you are the tortoise - there is no way to be productive on a workstation with the tray hiding all the time!

    Is it possible to configure this - or is it "bye bye" Ubuntu for another 5 years?

    Kind Regards,

    iDudetu

  7. #7
    Join Date
    Mar 2012
    Beans
    8

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    Final clarification - please see this YouTube video (available in 720p)

    Video of Unity Plug-in Settings having Zero effect on the System Tray!

  8. #8
    Join Date
    Oct 2008
    Beans
    3,509

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    Are you in the ubuntu-2d session?
    In the terminal
    Code:
    echo $DESKTOP_SESSION
    Log out and choose the "ubuntu" session and login.
    Gnome-Classic-Menu.png


    Run
    Code:
    echo $DESKTOP_SESSION
    If it still shows ubuntu-2d
    your gfx card may not have the drivers installed or cannot run compiz and
    you are being dropped back to the 2d session.

    Post the output of...
    Code:
    /usr/lib/nux/unity_support_test -p
    eg
    glen@Oneiric:~$ /usr/lib/nux/unity_support_test -p
    OpenGL vendor string: NVIDIA Corporation
    OpenGL renderer string: GeForce 9400 GT/PCI/SSE2/3DNOW!
    OpenGL version string: 3.3.0 NVIDIA 280.13

    Not software rendered: yes
    Not blacklisted: yes
    GLX fbconfig: yes
    GLX texture from pixmap: yes
    GL npot or rect textures: yes
    GL vertex program: yes
    GL fragment program: yes
    GL vertex buffer object: yes
    GL framebuffer object: yes
    GL version is 1.4+: yes

    Unity 3D supported: yes

    If you are only able to log in to the ubuntu-2d session
    run this command to set the launcher as never hide.
    Code:
    gsettings set com.canonical.Unity2d.Launcher hide-mode 0
    To set back to default
    Code:
    gsettings reset com.canonical.Unity2d.Launcher hide-mode

    P.S If you do get into the "ubuntu" session running compiz
    use this to set the launcher to never hide...
    Code:
    gconftool-2 --type int --set "/apps/compiz-1/plugins/unityshell/screen0/options/launcher_hide_mode" 0
    Last edited by stinkeye; March 13th, 2012 at 02:50 PM.

  9. #9
    Join Date
    Mar 2012
    Beans
    8

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    Hi Stinkeye,

    I ran this code
    Code:
    gsettings set com.canonical.Unity2d.Launcher hide-mode 0
    and all is good.

    I forgot to mention in my original post that I am running Ubuntu in VMware Workstation - which probably explains everything!

    Here is the output from this code
    Code:
    /usr/lib/nux/unity_support_test -p
    :

    HTML Code:
    rocker@ubuntu:~$ echo $DESKTOP_SESSION
    ubuntu-2d
    rocker@ubuntu:~$ /usr/lib/nux/unity_support_test -p
    OpenGL vendor string:   Mesa Project
    OpenGL renderer string: Software Rasterizer
    OpenGL version string:  2.1 Mesa 7.11
    
    Not software rendered:    no
    Not blacklisted:          yes
    GLX fbconfig:             yes
    GLX texture from pixmap:  no
    GL npot or rect textures: yes
    GL vertex program:        yes
    GL fragment program:      yes
    GL vertex buffer object:  yes
    GL framebuffer object:    yes
    GL version is 1.4+:       yes
    
    Unity 3D supported:       no
    Thanks very much for your assistance - and I dig you're signature mate (pass the vegemite, LOL).

    Cheers

    iDudetu

  10. #10
    Join Date
    Mar 2012
    Beans
    8

    Re: How to stop the System Tray (Unity) to stop "auto hiding"?

    Hi All,

    I am now able to keep the "system tray" over other windows - however unlike in Windows the applications are now going behind the system tray!

    I would like the app windows to never go behind the system tray, and respect the system tray as a boundary, similar to how the display area boundaries are respected.

    Here is a link which clarifies what I am seeing:



    Kind Regards,

    iDudetu

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •