Results 1 to 5 of 5

Thread: Firefox won't display CJK text any more...

  1. #1
    Join Date
    Nov 2007
    Location
    Chicago, IL, USA
    Beans
    111
    Distro
    Kubuntu 12.04 Precise Pangolin

    Firefox won't display CJK text any more...

    When I first installed Oneiric, Firefox worked well. As I was trying to clean up my distro - removing unnecessary programs and files - I apparently got carried away and removed some files that FF needs to properly display Chinese, Japanese, and Korean (CJK) text.

    The good news is that since I don't know any of these languages, I'm not losing any information I might otherwise have. The bad news is that those boxes with the numbers in them look ugly; I'd rather see the attractive Asian characters.

    Does anyone know what files I need to replace? Or, can anyone kindly direct me to somewhere I can find this information? I don't even know how to Google it (what search terms to use)...

    BTW: I've already tried modifying the "View | Character Encodings" options in Firefox, but those are fine. As far as I can tell, I'm missing the actual CJK font files. There are dozens of these (84 in synaptic). I really don't want to have to install them all, just to get FF back to normal.

  2. #2
    Join Date
    Feb 2012
    Location
    el_GR
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Firefox won't display CJK text any more...

    Hi ,
    I don't care about Japanese or Chinese language too , but those little boxes with numbering are annoying .
    Install this font and you will be ok.
    Code:
    sudo apt-get install ttf-wqy-microhei

  3. #3
    Join Date
    Nov 2007
    Location
    Chicago, IL, USA
    Beans
    111
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Firefox won't display CJK text any more...

    Thanks for the idea, NikTh. I appreciate it...

  4. #4
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: Firefox won't display CJK text any more...

    You could also try to rename your ~/.fonts.conf file in case there are (now-stale) font references in there that muck things up. They shouldn't, but hey. Just make sure to go into the Font section of System Settings afterwards and make sure your settings are correct.

    (KDE saves its own font/color/etc settings in ~/.kde/share/config/kdeglobals but also updates said .conf file -- which other non-KDE applications rely upon -- to mirror the basic antialiasing/hinting settings you setup.)

    FWIW I use (and explicitly specify) Kochi Mincho and Kochi Gothic for CJK characters, mostly because they have non-antialiased bitmaps for font sizes 8 and below. I find that antialiased vertex fonts of such characters just become blurry messes at those sizes. ;/
    ...

  5. #5
    Join Date
    Nov 2007
    Location
    Chicago, IL, USA
    Beans
    111
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Firefox won't display CJK text any more...

    Zorael, I appreciate this information. Thank you.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •