Page 30 of 38 FirstFirst ... 202829303132 ... LastLast
Results 291 to 300 of 372

Thread: Install Google Earth

  1. #291
    Join Date
    Jun 2008
    Beans
    109
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Install Google Earth

    Same problem as either normal user or root:

    Code:
    ./googleearth-bin: relocation error: /usr/lib32/i686/cmov/libssl.so.0.9.8: symbol BIO_test_flags, version OPENSSL_0.9.8 not defined in file libcrypto.so.0.9.8 with link time reference

  2. #292
    Join Date
    Mar 2007
    Beans
    82
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Install Google Earth

    Quote Originally Posted by Yfrwlf View Post
    Same prob here, on 64-bit, even with all the 32-bit libs that are installed after installing Flash (so maybe some 32-bit libs are missing?), I get the same error when I try to run GE5:
    Code:
    ./googleearth-bin: relocation error: /usr/lib32/i686/cmov/libssl.so.0.9.8: symbol BIO_test_flags, version OPENSSL_0.9.8 not defined in file libcrypto.so.0.9.8 with link time reference
    did you try to hide libcrypto.so.0.9.8 by moving it to a different name? cf the link I posted earlier and I think someone else mentioned it too. That's what solved the problem for me.

    edit: I meant libssl.so.0.9.8 actually (I think). I'm sorry it looks like the link I posted earlier doesn't work anymore and I cannot find it again... basically the command was just mv libssl.so.0.9.8 libssl.so.0.9.8.bak and it solved the problem (on a 64-bit)
    Last edited by kalyp; March 5th, 2009 at 03:31 AM.

  3. #293
    Join Date
    Oct 2007
    Beans
    4

    Re: Install Google Earth

    Quote Originally Posted by CalderCoalson View Post
    Same problem as either normal user or root:

    Code:
    ./googleearth-bin: relocation error: /usr/lib32/i686/cmov/libssl.so.0.9.8: symbol BIO_test_flags, version OPENSSL_0.9.8 not defined in file libcrypto.so.0.9.8 with link time reference
    this is what I did on debian lenny stable amd64

    Code:
    sudo mv /usr/lib32/i686/cmov/libssl.so.0.9.8 /usr/lib32/i686/cmov/libssl.so.0.9.8_backup
    Code:
     sudo mv -v /emul/ia32-linux/usr/lib/libssl.so.0.9.8 /emul/ia32-linux/usr/lib/libssl.so.0.9.8_backup
    I hope it can works fine for ubuntu, too.

    enjoy

  4. #294
    Join Date
    Apr 2007
    Location
    UK
    Beans
    189
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Install Google Earth

    Thanks! Was looking for a download location, and .bin file format makes it really easy to install.
    -KVarley
    -Proud member of the Linux Foundation

  5. #295
    Join Date
    Jun 2008
    Beans
    109
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Install Google Earth

    Smoqer, after following your advice GE will stay open until I actually click something, at which point it dies with the following error:
    Code:
    ./googleearth-bin: relocation error: /usr/lib32/libssl.so.0.9.8: symbol BIO_test_flags, version OPENSSL_0.9.8 not defined in file libcrypto.so.0.9.8 with link time reference

  6. #296
    Join Date
    Oct 2007
    Beans
    4

    Re: Install Google Earth

    Quote Originally Posted by CalderCoalson View Post
    Smoqer, after following your advice GE will stay open until I actually click something, at which point it dies with the following error:
    Code:
    ./googleearth-bin: relocation error: /usr/lib32/libssl.so.0.9.8: symbol BIO_test_flags, version OPENSSL_0.9.8 not defined in file libcrypto.so.0.9.8 with link time reference
    probably something is different between debian and ubuntu. however, try to rename that library (if you have a 64 bit system, of course)

    Code:
    sudo mv -v /usr/lib32/libssl.so.0.9.8 /usr/lib32/libssl.so.0.9.8_backup
    if you experience any problem with other 32 bit softwares, just rename the library with the old name (without "_backup")

    otherwise, you can thing that some bug affects ubuntu.


    edit: it seems that /usr/lib32/libssl.so.0.9.8 is created every boot. at this moment the only solution I found is renaming it every time. If you previously renamed the library, you probably need to delete the backup, then rename the library. or you can make an easy script

    Code:
    #! /bin/bash
    sudo rm -vf /usr/lib32/libssl.so.0.9.8_backup
    sudo mv -v /usr/lib32/libssl.so.0.9.8 /usr/lib32/libssl.so.0.9.8_backup
    googleearth
    exit 0
    it's not "elegant", but it should work
    Last edited by smoqer; March 5th, 2009 at 09:30 PM.

  7. #297
    Join Date
    Mar 2009
    Beans
    2

    Re: Install Google Earth (solution)

    Hi guys,
    I just found a simpler way: remove the libcrypto that comes with Google Earth and let it use the system one.

    Assumy google earth is installed under /opt/google-earth, this works for me:

    Code:
    sudo rm /opt/google-earth/libcrypto.so.0.9.8
    To be on the safe side, you may want to move/rename it instead:

    Code:
    sudo mv /opt/google-earth/libcrypto.so.0.9.8 /opt/google-earth/libcrypto.so.0.9.8-backup
    Hope this helps,
    .Andrea

  8. #298
    Join Date
    Oct 2007
    Beans
    4

    Re: Install Google Earth (solution)

    Quote Originally Posted by fwyzard View Post
    Hi guys,
    I just found a simpler way: remove the libcrypto that comes with Google Earth and let it use the system one.

    Assumy google earth is installed under /opt/google-earth, this works for me:

    Code:
    sudo rm /opt/google-earth/libcrypto.so.0.9.8
    To be on the safe side, you may want to move/rename it instead:

    Code:
    sudo mv /opt/google-earth/libcrypto.so.0.9.8 /opt/google-earth/libcrypto.so.0.9.8-backup
    Hope this helps,
    .Andrea
    I haven't /opt/google-earth on my system, maybe cause I used goolgeearth-package to build the deb package. So, this solution is not good for me

  9. #299
    Join Date
    Jul 2007
    Location
    Bezerkely, Californicate
    Beans
    57
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Install Google Earth (solution)

    That worked perfectly for me. I just downloaded version 5 from Google and installed it to my /home/user/ directory. If you remove or rename the libcrypto file like fwyzard recommends it works fine.

  10. #300
    Join Date
    Sep 2008
    Beans
    1

    Unhappy Re: Install Google Earth

    Quote Originally Posted by lastrite View Post
    The linux version of google earth has just been released so heres how to get it!

    1. Open up a terminal (Applications > Accessories > Terminal)
    2. Type in the following:

    Code:
    wget http://dl.google.com/earth/GE4/GoogleEarthLinux.bin
    sh GoogleEarthLinux.bin
    The rest of the install is self explanatory, have fun!
    THE LINK NOT FOUND ... Message says :-

    --2009-03-25 12:23:16-- http://dl.google.com/earth/GE4/GoogleEarthLinux.bin
    Resolving dl.google.com... 72.14.203.93, 72.14.203.136, 72.14.203.190, ...
    Connecting to dl.google.com|72.14.203.93|:80... connected.
    HTTP request sent, awaiting response... 404 Not Found
    2009-03-25 12:23:17 ERROR 404: Not Found.

Page 30 of 38 FirstFirst ... 202829303132 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •