Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

  1. #1

    How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    I have tried all day long to install Gimp 2.8 from source using this gimp-2.8.0-RC1.tar.bz2 file.
    Luckily I did this in a virtual pc and not on my host system, because that system is completely toast now.
    There were so many dependencies to solve that at the end I marked something like ATK for removal which almost completely erased everything.

    Has anyone come across a step by step guide on How to install that source file yet? If so, please share.

    Thanks!
    Linux into the classroom NOW!
    http://www.taiwan-taipei.com

  2. #2
    Join Date
    Jul 2007
    Location
    Magic City of the Plains
    Beans
    Hidden!
    Distro
    Kubuntu Development Release

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    Moved to Packaging and Compiling Programs.

  3. #3
    Join Date
    Nov 2009
    Beans
    3,225

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    I thought I would have a go ....

    Got it from here - http://www.gimpusers.com/downloads/5...c1-source-code

    There is a INSTALL

    Document in the release ..... although I too followed it and get stuck at GLIB

    this is a 12.04 Kubuntu install and why it thinks there are 2 versions of GLIB
    I do not know ..... ( but I do know both are greater than what is needed )

    Yet it does not let me continue .....

    Not a lot of help I know - but I would like to point this out to the devs as to me
    this should not happen and it also should allow me to carry on using the latest
    version ....... BABL went in fine pkg-config went in fine .... Initltool went in fine

    root@keith-Aspire-7730ZG:/# find / -name glib-2.0
    /usr/include/glib-2.0
    /usr/local/include/glib-2.0
    /usr/local/lib/i386-linux-gnu/glib-2.0
    /usr/local/share/glib-2.0
    /usr/lib/i386-linux-gnu/glib-2.0
    /usr/share/glib-2.0
    Then we stopped ..... is there an easy way to point this to the correct one
    I have come across this before and not known how to resolve the double
    version issue .....

    checking for fsync... yes
    checking for BABL... yes
    checking for pkg-config... (cached) /usr/bin/pkg-config
    checking pkg-config is at least version 0.16... yes
    checking for GLIB - version >= 2.28.0...
    *** 'pkg-config --modversion glib-2.0' returned 2.31.17, but GLIB (2.32.0)
    *** was found! If pkg-config was correct, then it is best
    *** to remove the old version of GLib. You may also be able to fix the error
    *** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
    *** /etc/ld.so.conf. Make sure you have run ldconfig if that is
    *** required on your system.
    *** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
    *** to point to the correct configuration files
    no
    configure: error:
    *** GLIB 2.28.0 or better is required. The latest version of
    *** GLIB is always available from ftp://ftp.gtk.org/.
    keith@keith-Aspire-7730ZG:~/Downloads/gegl$ echo LD_LIBRARY_PATH
    LD_LIBRARY_PATH
    keith@keith-Aspire-7730ZG:~/Downloads/gegl$ echo $LD_LIBRARY_PATH

    keith@keith-Aspire-7730ZG:~/Downloads/gegl$


    The install document has these requirements in it PLUS - MUCH MORE INFORMATION TOO

    PLEASE READ IT AS IT COULD BREAK THINGS IF YOU INSTALL IT AND IT GOES WRONG

    WHEN INSTALLING FROM SOURCE FILES THERE IS NO EASY RETURN JOURNEY


    1. You need to have installed a recent version of pkg-config available
    from http://www.freedesktop.org/software/pkgconfig/. done ///

    2. You need intltool (at least 0.40.1, but preferably a newer version).
    Intltool can be downloaded from
    http://ftp.gnome.org/pub/gnome/sources/intltool/. done ///

    3. You need to have GEGL version 0.2.0 or newer and babl version
    0.1.10 or newer. You can get them from http://gegl.org/ or clone
    them from the GNOME git repository:

    git://git.gnome.org/babl
    git://git.gnome.org/gegl

    4. You need to have installed GTK+ version 2.24.10 or newer.
    GIMP also need a recent versions of GLib (>= 2.30.2), GDK-Pixbuf
    (>= 2.24.1), and Pango (>= 1.29.4). Sources for these can be grabbed
    from ftp://ftp.gtk.org/.

    5. We use cairo >= 1.10.2, which is hosted at
    http://www.cairographics.org/.

    6. We require PangoCairo, a Pango backend using Cairo. Make sure you
    have Cairo, FreeType2 and fontconfig installed before you compile
    Pango. GIMP depends on freetype2 being newer than version 2.1.7
    and fontconfig 2.2.0 or newer. Older versions are known to have
    bugs that seriously affect the stability of GIMP.

    7. We use dbus-glib if available. Grab it from
    http://dbus.freedesktop.org/releases/dbus-glib/

    8. Access of remote files is implemented in the URI plug-in. There
    are several possible implementations for this. The implementation
    used is determined when you configure GIMP. By default the
    GIO/GVfs backend is used. If you don't have GVfs support on your
    target platform, you should pass the '--without-gvfs' option to
    configure. The configure script will then try to detect another
    method for accessing remote files.

    9. You may want to install other third party libraries or programs
    that are needed for some of the available plug-ins. We recommend
    to check that the following libraries are installed: lcms,
    libpng, libjpeg, libpoppler, libtiff, webkit, libmng, librsvg,
    libwmf, libz, libbzip2, libgs (Ghostscript), libaa and libjasper.

    10. The Python extension requires Python development headers to be
    present. You will also need PyGTK and the respective development
    headers.

    11. Configure GIMP by running the `configure' script. You may want
    to pass some options to it, see below.

    12. Build GIMP by running `make'. The use of GNU make is recommended.
    If you need to tweak the build to make it work with other flavours
    of make, we'd appreciate if you'd send us a patch with the changes.

    13. Install GIMP by running `make install'. In order to avoid clashes
    with other versions of GIMP, we install a binary called gimp-2.8.
    By default there's also a link created so that you can type 'gimp'
    to start gimp-2.8.

    Please make sure you don't have any old GTK+-2.x, jpeg, etc. libraries
    lying around on your system, otherwise configure may fail to find the
    new ones.
    Last edited by 23dornot23d; April 5th, 2012 at 02:04 AM.

  4. #4
    Join Date
    Jun 2007
    Beans
    13,780

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    Only have 12.04 so only in regards to that. (only earlier ubuntu release you'd need to get a higher libglib I believe

    Pretty easy, 12.04 provides all that's needed except gegl & babl versions required.
    (acquiring build-deps here - http://ubuntuforums.org/showpost.php...9&postcount=21
    So you'd build both of those then gimp-2.8 (or wait for a ppa to do

    Here's a page that lays out the basic's to build to /opt, I did a varition of that type of build, did use /opt
    (have a local build of 2.7.5 in /usr/local, so /opt worked best, plus didn't want the new gegl & babl to interfere

    http://www.gimpusers.com/tutorials/c...imp-for-ubuntu

    Here's the full listing of commands I used, start to finish in the same terminal (you must use the same terminal or if not then rerun the export commands before resuming

    Do note -
    gegl will build with avformat support if the headers are installed. I had a local static build of a recent git FFmpeg. It built off of that without incident but there was a runtime issue
    So I temp removed my local FFmpeg package & used the 12.04 libavcodec-dev, libavformat-dev

    Also -
    I used checkinstall to install all, mainly because I dump my 12.04 installs weekly & I can, with care, re-use the .debs.
    Also the gimp source compiled is large, almost 1/2 GB, so I can remove after moving the .deb out, or keep & clean
    Will post the commands I used, there is some leeway there, I didn't use --defaults so commands are longer, wanted it to stop at the package config screen to review

    ( if using checkinstall & want to have the repo or 2.7.X installed then make sure the package name is not gimp, I used gimp2

    You should review the results of the ./autogen.sh & or ./configure to make sure all that's wanted to be enabled is before running a make.

    The are various ways to run & add the .desktop, ect. The binary is gimp-2.8

    One could also look for snapshots of gegl & babl instead of a git clone - fine today, you never know down the road.., if so a ./configure ... usually will suffice instead of a ./autogen.sh ...

    If desired you can build in /tmp like in link
    Code:
    mkdir gimp_build && cd gimp_build
    
    export PATH=/opt/gimp-2.8/bin:$PATH
    export PKG_CONFIG_PATH=/opt/gimp-2.8/lib/pkgconfig
    export LD_LIBRARY_PATH=/opt/gimp-2.8/lib
    
    git clone git://git.gnome.org/babl
    cd babl
    ./autogen.sh --prefix=/opt/gimp-2.8
    make
    
    
    sudo make install
    
    or
    
    sudo checkinstall --pkgname=babl --pkgversion=0.1.10 --backup=no --deldoc=yes \
    --fstrans=no --backup=no --deldoc=yes --deldesc=yes --delspec=yes --default
    cd ..
    git clone git://git.gnome.org/gegl
    cd gegl
    ./autogen.sh --prefix=/opt/gimp-2.8
    
    # if dep packages are added after the above use this till correct
    ./configure  --prefix=/opt/gimp-2.8  
    make
    
    
    sudo make install
    
    or 
    
    sudo checkinstall --pkgname=gegl --pkgversion=0.2 --backup=no --deldoc=yes \
    --fstrans=no --backup=no --deldoc=yes --deldesc=yes --delspec=yes --default
    
    cd ..
    cd gimp-2.8.0  # I unpacked the gimp-2.8 tar into the gimp_build
    ./configure --prefix=/opt/gimp-2.8
    make
    
    
    sudo make install 
    
    or
    
    sudo checkinstall --backup=no --deldoc=yes --fstrans=no --backup=no --deldoc=yes \
    --deldesc=yes --delspec=yes --pkgname=gimp2 --pkgversion=2.8.0-rc1 \
    --provides gimp-2.8.0 --default


    For a .desktop I used ~/... like
    Code:
    gedit ~/.local/share/applications/gimp2.desktop
    Code:
    [Desktop Entry]
    Version=1.0
    Type=Application
    Name=Gimp 2.8
    Comment=Create images and edit photographs
    Exec=/opt/gimp-2.8/bin/gimp-2.8 %U
    TryExec=/opt/gimp-2.8/bin/gimp-2.8
    Icon=gimp
    Terminal=false
    Categories=Graphics;2DGraphics;RasterGraphics;GTK;
    X-GNOME-Bugzilla-Bugzilla=GNOME
    X-GNOME-Bugzilla-Product=GIMP
    X-GNOME-Bugzilla-Component=General
    X-GNOME-Bugzilla-Version=2.8.0-RC1
    X-GNOME-Bugzilla-OtherBinaries=gimp-2.8
    MimeType=application/postscript;application/pdf;image/bmp;image/g3fax;image/gif;image/x-fits;image/pcx;image/x-portable-anymap;image/x-portable-bitmap;image/x-portable-graymap;image/x-portable-pixmap;image/x-psd;image/x-sgi;image/x-tga;image/x-xbitmap;image/x-xwindowdump;image/x-xcf;image/x-compressed-xcf;image/x-gimp-gbr;image/x-gimp-pat;image/x-gimp-gih;image/tiff;image/jpeg;image/x-psp;image/png;image/x-icon;image/x-xpixmap;image/svg+xml;application/pdf;image/x-wmf;image/jp2;image/jpeg2000;image/jpx;image/x-xcursor;
    Note - if gimp-2.6 or 2.7 isn't installed normally then full path the Icon= line, EX.
    Icon=/opt/gimp-2.8/share/icons/hicolor/48x48/apps/gimp.png
    Attached Images Attached Images
    Last edited by mc4man; May 5th, 2012 at 11:05 PM. Reason: snapshots instead of git, edited out -RC1 in comm.

  5. #5
    Join Date
    Apr 2012
    Beans
    2

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    I've tried for hours to compile this on my newly installed Ubuntu 12.04 with no luck can you just upload the .deb for Ubuntu x64?

  6. #6

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    Here I get stuck and don't know how to go on.
    With installing gimp 2.8 of course.
    cd ..
    git clone git://git.gnome.org/gegl
    cd gegl
    ./autogen.sh --prefix=/opt/gimp-2.8

    # if dep packages are added after the above use this till correct
    ./configure --prefix=/opt/gimp-2.8

    Code:
    checking for vapigen... no
    *** Check for vapigen failed.
    checking for fsync... yes
    checking for BABL... yes
    checking for pkg-config... (cached) /usr/bin/pkg-config
    checking pkg-config is at least version 0.16... yes
    checking for GLIB - version >= 2.28.0... yes (version 2.32.0)
    checking for DEP... yes
    checking for bind_textdomain_codeset... yes
    ./configure: line 17639: syntax error near unexpected token `0.40.1'
    ./configure: line 17639: `IT_PROG_INTLTOOL(0.40.1)'
    Linux into the classroom NOW!
    http://www.taiwan-taipei.com

  7. #7

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    thanks to everyone I got it up and running.

    some things I remember so far.

    as a starter

    Code:
    sudo apt-get install build-essential checkinstall
    then
    Code:
    sudo apt-get install cvs subversion git-core mercurial
    Code:
     cd /tmp
    then
    Code:
    mkdir gimp_build && cd gimp_build
    execute each line
    Code:
    export PATH=/opt/gimp-2.8/bin:$PATH
    export PKG_CONFIG_PATH=/opt/gimp-2.8/lib/pkgconfig
    export LD_LIBRARY_PATH=/opt/gimp-2.8/lib
    Code:
    git clone git://git.gnome.org/babl
    cd babl
    ./autogen.sh --prefix=/opt/gimp-2.8
    make
    sudo make install
    Code:
    sudo apt-get install libtool
    Till here then it was a lot of fixing dependencies and sorry I really forgot how it went on.
    Linux into the classroom NOW!
    http://www.taiwan-taipei.com

  8. #8
    Join Date
    Nov 2009
    Beans
    3,225

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    Good one .... type history in the terminal

    it will show all the commands you used ......

    But that is good - gives me confidence - am doing a safe-upgrade then going to try it
    again .... mine is still failing ..... new error now .....

    checking for perl... /usr/bin/perl
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for gobject-introspection... no (disabled, use --enable-introspection to enable)
    checking for vapigen... no
    *** Check for vapigen failed.
    checking for fsync... yes
    checking for BABL... yes
    ./configure: line 17133: syntax error near unexpected token `$GLIB_REQUIRED_VERSION,'
    ./configure: line 17133: `AM_PATH_GLIB_2_0($GLIB_REQUIRED_VERSION, :,'
    keith@keith-K53SV:~/tmp/gimp/gimp-2.8.0-RC1/gegl$
    Last edited by 23dornot23d; April 5th, 2012 at 06:00 PM.

  9. #9

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    I did the history command but it will confuse you even more.

    Just read after each attempt the error messages in the last 7 lines and try to find the packages that are missing.

    I rmember I had to install one through the software center and the installed synaptic to speed things up a little bit.

    You'll need python dev. Some Tiff dev etc.
    Just show us how far you get and the last terminal outputs maybe I can trace it back then.
    Linux into the classroom NOW!
    http://www.taiwan-taipei.com

  10. #10
    Join Date
    Nov 2009
    Beans
    3,225

    Re: How to install gimp-2.8.0-RC1.tar.bz2 ubuntu 10.04 or higher?

    I get this ......

    checking for vapigen... no
    *** Check for vapigen failed.
    what is vapigen ..... and where is it installed ......

    https://www.google.com/search?client...utf-8&oe=utf-8

    Ok installed vala

    now ...

    checking whether we can compile SSE code... yes
    checking for perl5... no
    checking for perl... /usr/bin/perl
    checking for pkg-config... /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0... yes
    checking for gobject-introspection... no (disabled, use --enable-introspection to enable)
    checking for vapigen... /usr/bin/vapigen
    checking for fsync... yes
    checking for BABL... yes
    ./configure: line 17133: syntax error near unexpected token `$GLIB_REQUIRED_VERSION,'
    ./configure: line 17133: `AM_PATH_GLIB_2_0($GLIB_REQUIRED_VERSION, :,'
    keith@keith-K53SV:~/tmp/gimp/gimp-2.8.0-RC1/gegl$
    a little further

    checking for pkg-config... (cached) /usr/bin/pkg-config
    checking pkg-config is at least version 0.16... yes
    checking for GLIB - version >= 2.28.0... yes (version 2.32.0)
    checking for DEP... yes
    checking for bind_textdomain_codeset... yes
    ./configure: line 17639: syntax error near unexpected token `0.40.1'
    ./configure: line 17639: `IT_PROG_INTLTOOL(0.40.1)'
    keith@keith-K53SV:~/tmp/gimp/gimp-2.8.0-RC1/gegl$
    Last edited by 23dornot23d; April 5th, 2012 at 06:15 PM.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •