Results 1 to 4 of 4

Thread: Problem mounting NTFS drive in fstab

  1. #1
    Join Date
    Oct 2008
    Location
    Norway
    Beans
    57

    Problem mounting NTFS drive in fstab

    Hi
    I have a server running Ubuntu 11.04. It has several drives, most of which are NTFS. When I try to mount these drives from fstab I always get an error message during boot: "Serious errors were found while checking the disk drive for /media/MyFolder" and I get the choices to ignore, skip or manual recovery.

    If I mount the drive with:
    Code:
    sudo mount -t ntfs-3g /dev/sdd1 /media/MyFolder
    or
    Code:
    sudo mount -t ntfs-3g UUID=###### /media/MyFolder
    It all works just fine! But if I try any of the of the following in my fstab I get the same errors during boot:
    Code:
    UUID=###### /media/MyFolder ntfs-3g rw,auto,user,fmask=0111,dmask=0000   0 1
    UUID=###### /media/MyFolder ntfs-3g defaults,user,locale=nb_NO.utf8   0 1
    UUID=###### /media/MyFolder ntfs-3g defaults   0 1

    Any ideas?

  2. #2
    Join Date
    Dec 2007
    Location
    California
    Beans
    4,912
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problem mounting NTFS drive in fstab

    Code:
    UUID=###### /media/MyFolder ntfs-3g rw,auto,user,fmask=0111,dmask=0000   0 0
    UUID=###### /media/MyFolder ntfs-3g defaults,user,locale=nb_NO.utf8   0 0
    UUID=###### /media/MyFolder ntfs-3g defaults   0 0
    Don't set ntfs disks to be checked, in fact, if it's possible, don't use ntfs. Go with a native linux format, I can't think of any reason to use ntfs on a server.
    "You can't expect to hold supreme executive power just because some watery tart lobbed a sword at you"

    "Don't let your mind wander -- it's too little to be let out alone."

  3. #3
    Join Date
    Oct 2008
    Location
    Norway
    Beans
    57

    Re: Problem mounting NTFS drive in fstab

    Quote Originally Posted by jerome1232 View Post
    Don't set ntfs disks to be checked, in fact, if it's possible, don't use ntfs. Go with a native linux format, I can't think of any reason to use ntfs on a server.
    Sweet. That did the trick for the most of the disks! Tnx... (Setting the last digit in each line to 0, that avoids the check).

    I still get an error on one of the disks: "An error occurred while mounting..." Gonna need some more research to resolve the error of that one...

    I agree! I wish it was all ext4, but it used to be a Windows 2008 R2 server...

  4. #4
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Problem mounting NTFS drive in fstab

    Because Linux cannot do the file check for NTFS on every 40 or 60 reboots, you get no file checks.

    But Windows NTFS still should have chkdsk run, but you have to use Windows to run those file chkdsk.

    If Linux cannot mount it then it may be saying you have to run a chkdsk from your Windows repairCD.
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •