Results 1 to 10 of 10

Thread: Nautilus ignores can_change_accels

  1. #1
    Join Date
    Jul 2009
    Beans
    255
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Nautilus ignores can_change_accels

    I'm trying to change some Nautilus accelerators, but ticking can_change_accels in gconf-editor doesn't seem to do anything for me.
    I do see
    (gconf-editor:3346): GLib-GObject-WARNING **: g_object_get_valist: property `type' of object class `GConfEditorWindow' is not readable
    in the terminal as soon as I open it, but this does not look relevant to me...

    Does it work for you?

    I'd be grateful for some help...
    Last edited by Artificial Intelligence; April 2nd, 2012 at 11:06 AM. Reason: added prefix

  2. #2
    Join Date
    Jul 2009
    Beans
    255
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Nautilus ignores can_change_accels

    *bump*

    Can someone please just verify this on their machine, so I know if it's a bug or some problem with my installation?

  3. #3
    Join Date
    Feb 2008
    Beans
    4,262
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Nautilus ignores can_change_accels

    I doubt if one person in a thousand understands what you mean by "I'm trying to change some Nautilus accelerators," Are you really running 10.10?

  4. #4
    Join Date
    Jul 2009
    Beans
    255
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Nautilus ignores can_change_accels

    Well, I'm really on Mint 12 (hence the other_os prefix), but since it's Ubuntu 11.10 underneath, I've now changed my profile to reflect it. In the end, I guess the only relevant thing is that it's Nautilus in Gnome 3 that I'm talking about (is it Nautilus 3?).
    Back to the accelerators... I honestly can't see how could someone who doesn't know what Nautilus accelerators are help me fix them, but ok. I'm talking about keyboard shortcuts in Nautilus (like ctrl+shift+N for creating a new directory). I know that ticking the /desktop/gnome/interface/can_change_accels flag in gconf-editor allows one to dynamically change them, but for some reason my Nautilus is ignoring it.
    I can't bother anyone to install gconf-editor just for this, so I just asked the way I did in hopes that someone with knowledge and tools can just see if it works for them...

    This thread suggests trying the same with dconf-editor, so I'll give that a go.

    Thanks.
    Last edited by veggen; April 2nd, 2012 at 09:55 AM.

  5. #5
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    17,619
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Nautilus ignores can_change_accels

    Moved to Other OS/Distro Talk.
    elementary OS Luna
    My Screenshot

  6. #6
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Nautilus ignores can_change_accels

    Quote Originally Posted by veggen View Post
    Well, I'm really on Mint 12 (hence the other_os prefix), but since it's Ubuntu 11.10 underneath, I've now changed my profile to reflect it. In the end, I guess the only relevant thing is that it's Nautilus in Gnome 3 that I'm talking about (is it Nautilus 3?).
    Back to the accelerators... I honestly can't see how could someone who doesn't know what Nautilus accelerators are help me fix them, but ok. I'm talking about keyboard shortcuts in Nautilus (like ctrl+shift+N for creating a new directory). I know that ticking the /desktop/gnome/interface/can_change_accels flag in gconf-editor allows one to dynamically change them, but for some reason my Nautilus is ignoring it.
    I can't bother anyone to install gconf-editor just for this, so I just asked the way I did in hopes that someone with knowledge and tools can just see if it works for them...

    This thread suggests trying the same with dconf-editor, so I'll give that a go.

    Thanks.
    For dconf, in the terminal use
    Code:
    gsettings set org.gnome.desktop.interface can-change-accels true
    It works here on 12.04 unity.

    After setting can-change-accels true, to work in nautilus I need to kill nautilus
    Code:
    nautilus -q
    and because I'm using the unity global menu, start nautilus showing the menubar (doesn't work with the global menu)
    Code:
    UBUNTU_MENUPROXY=0 nautilus
    Last edited by stinkeye; April 2nd, 2012 at 11:50 AM.

  7. #7
    Join Date
    Jul 2009
    Beans
    255
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Nautilus ignores can_change_accels

    Ha! Great! This one worked! Thanks a bunch stinkeye!

  8. #8
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Nautilus ignores can_change_accels

    Quote Originally Posted by veggen View Post
    Ha! Great! This one worked! Thanks a bunch stinkeye!
    Good.
    You may want too turn it off so you don't accidentally change shortcuts.
    Code:
    gsettings reset org.gnome.desktop.interface can-change-accels

  9. #9
    Join Date
    May 2010
    Location
    Tehran - Iran
    Beans
    198
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Re: Nautilus ignores can_change_accels

    Hi
    Is there any similar method for changing shortkeys in thunderbird too?
    os : 12.04
    thanks in advance
    We Can.

  10. #10
    Join Date
    May 2010
    Beans
    1

    Re: Nautilus ignores can_change_accels

    Another way to change keyboard accelerators in Nautilus is to use this extension. It works even with global menus.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •