Results 1 to 8 of 8

Thread: Keyboard Shortcuts going Wonky

  1. #1
    Join Date
    Nov 2011
    Beans
    48

    Unhappy Keyboard Shortcuts going Wonky

    I can't add any keyboard shortcuts...it only asks what command would be executed and doesn't allow me to input which keys would activate the shortcut. Also, the shortcuts that were there before have stopped working as far as I can tell. I can't take a screenshot with prtsc anymore, etc. Anybody have any clue? I'm running Xubuntu 11.10, installed it fresh yesterday. If there is no solution, please tell me how to backup my third-party apps, because they always tend to get deleted whenever I reinstall the OS.

    Here is a screenshot of the keyboard shortcut menu not allowing me to specify keyboard combination for the shortcut.
    Attached Images Attached Images
    Last edited by jrisreal; March 30th, 2012 at 09:44 AM.

  2. #2
    Join Date
    Nov 2011
    Beans
    48

    Re: Keyboard Shortcuts going Wonky

    Bump

  3. #3
    Join Date
    May 2009
    Location
    Courtenay, BC, Canada
    Beans
    1,661

    Re: Keyboard Shortcuts going Wonky

    if it's anything like in Gnome, you need to click on where it says 'disabled' on the right, after you tell it what it's supposed to do

    in other words, tell it the command and what not, hit the check mark button, it will return you to the list.
    click on the right side where it says 'disabled' then press the keys you want
    make sure you actually click 'disabled'

  4. #4
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    801
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Keyboard Shortcuts going Wonky

    Lets delete your shortcuts config file and see if that helps.
    First you have to logout and enter a virtual terminal (Ctrl-Alt-F1)
    Log in at the prompt then delete the config file
    Code:
    rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
    Switch back to the login manager (Ctrl-Alt-F7) and return to Xubuntu.
    Hopefully your shortcuts will have been reset to defaults.

    Cheers!
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  5. #5
    Join Date
    Mar 2012
    Beans
    776
    Distro
    Ubuntu Development Release

    Re: Keyboard Shortcuts going Wonky

    I don't know if this is the right place to put my question, but anyway.

    The keyboard shortcut for changing languages doesn't save. I modified, so i can change the language with pressing the both shift keys together, but when i restart the computer this shortcut doesn't work.

    Why my OS doesn't save the shortcut?

  6. #6
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    801
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Keyboard Shortcuts going Wonky

    Quote Originally Posted by GreatDanton View Post
    I don't know if this is the right place to put my question, but anyway.

    The keyboard shortcut for changing languages doesn't save. I modified, so i can change the language with pressing the both shift keys together, but when i restart the computer this shortcut doesn't work.

    Why my OS doesn't save the shortcut?
    This bug has been discussed many times in these forums and elsewhere.
    Basically the fix is to check 'Use system defaults' in the Xfce Settings Manager/Keyboard/Layout to prevent any conflict.
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

  7. #7
    Join Date
    Nov 2011
    Beans
    48

    Re: Keyboard Shortcuts going Wonky

    Quote Originally Posted by LewisTM View Post
    Lets delete your shortcuts config file and see if that helps.
    First you have to logout and enter a virtual terminal (Ctrl-Alt-F1)
    Log in at the prompt then delete the config file
    Code:
    rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/xfce4-keyboard-shortcuts.xml
    Switch back to the login manager (Ctrl-Alt-F7) and return to Xubuntu.
    Hopefully your shortcuts will have been reset to defaults.

    Cheers!
    !!!!! I love you man! It worked!

  8. #8
    Join Date
    Oct 2008
    Location
    Ottawa, Canada
    Beans
    801
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: Keyboard Shortcuts going Wonky

    Good stuff!
    Please mark the thread as SOLVED.
    husband@wife$ make sandwich
    Permission denied
    husband@wife$ sudo make sandwich

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •