Results 1 to 5 of 5

Thread: xrandr: Failed to get size of gamma for output default

  1. #1
    Join Date
    Mar 2012
    Beans
    Hidden!

    xrandr: Failed to get size of gamma for output default

    Currently attempting to change my resolution on my Ubuntu laptop to use just the built-in screen instead of both the built-in and attached screens (currently configured with TwinView). When I run xrandr, I get the following error:

    Code:
    $ xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 1600 x 900, current 3648 x 1152, maximum 3648 x 1152
    default connected 3648x1152+0+0 0mm x 0mm
       3648x1152      50.0* 
       1600x900_60.00   59.9
    So no output is displayed. It used to be displaying VGA0 at one point when it was working. If I try and remove the current single-screen mode and start over I get:

    Code:
    $ xrandr --rmmode 1600x900_60.00
    xrandr: Failed to get size of gamma for output default
    X Error of failed request:  BadAccess (attempt to access private resource denied)
      Major opcode of failed request:  153 (RANDR)
      Minor opcode of failed request:  17 (RRDestroyMode)
      Serial number of failed request:  19
      Current serial number in output stream:  20
    I've done some research online, but everyone says post xorg.conf and then points out something that appears to have nothing to do with my issue. So here's my xorg.conf:

    Code:
    $ cat /etc/X11/xorg.conf
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 280.13  (buildd@rothera)  Thu Aug 11 17:28:49 UTC 2011
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "LEN"
        HorizSync       47.1 - 56.5
        VertRefresh     40.0 - 60.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "Quadro FX 880M"
        Option "RegistryDwords"     "EnableBrightnessControl=1"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+252, DFP-3: nvidia-auto-select +1600+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

  2. #2
    Join Date
    Apr 2007
    Location
    /dev/random
    Beans
    3,052

    Re: xrandr: Failed to get size of gamma for output default

    Yes, for some reason randr support isn't enabled by default in the nvidia blob.

    Code:
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "RandRRotation" "true"
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+252, DFP-3: nvidia-auto-select +1600+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    It will still always complain about failing to get size of gamma etc, but at least now the randr extensions work.
    ...

  3. #3
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: xrandr: Failed to get size of gamma for output default

    RandRotation kills video overlays & causes other openGL/GLX perform penalties.
    It is not needed to just use xrandr
    - set output to an internal defined mode
    xrandr --output LVDS1 --mode "1024x768"

    but I think twinview confuses xrandr..

    The OP could just run
    nvidia-settings (from terminal or menu)
    and adjust screen setup..
    Last edited by BicyclerBoy; March 30th, 2012 at 06:26 AM.

  4. #4
    Join Date
    Mar 2012
    Beans
    Hidden!

    Re: xrandr: Failed to get size of gamma for output default

    Unfortunately, the RandRRotation option didn't fix the issue.

    Code:
    $ xrandr
    xrandr: Failed to get size of gamma for output default
    Screen 0: minimum 3648 x 1152, current 3648 x 1152, maximum 3648 x 1152
    default connected 3648x1152+0+0 (normal left inverted right) 0mm x 0mm
       3648x1152      50.0*
    Code:
    $ cat /etc/X11/xorg.conf
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 280.13  (buildd@rothera)  Thu Aug 11 17:28:49 UTC 2011
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "LEN"
        HorizSync       47.1 - 56.5
        VertRefresh     40.0 - 60.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "Quadro FX 880M"
        Option "RegistryDwords"     "EnableBrightnessControl=1"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "RandRRotation" "true"
        Option         "TwinView" "1"
        Option         "TwinViewXineramaInfoOrder" "DFP-0"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+252, DFP-3: nvidia-auto-select +1600+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    - set output to an internal defined mode
    xrandr --output LVDS1 --mode "1024x768"
    Doesn't work either. Any value I try for --output fails with the error "warning: output ____ not found; ignoring"

    but I think twinview confuses xrandr..
    I'm sure this was working for me just a week ago, if that.

    The OP could just run
    nvidia-settings (from terminal or menu)
    and adjust screen setup..
    When you say "from terminal", I assume you mean from a terminal within X, so the GUI version of nvidia-settings can load. This doesn't work always as I've had the window pop up at obscure places for me and have been unable to move it for unknown reasons (move doesn't seem to be working correctly with arrow keys with TwinView). Also, this assumes that I want to use one of the default resolutions, which isn't always the case (e.g. if I'm connecting to the console remotely using X11Vnc and want to resize the screen to fit my remote screen(s). Xrandr was doing this beautifully for me back when it was working.

    If by "terminal", you mean run nvidia-settings with command-line parameters, (so I don't have to worry about the GUI window), I so far have been unable to figure out how to get the command-line to work for my purposes, and haven't found anything online to assist with that either.

  5. #5
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,659
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: xrandr: Failed to get size of gamma for output default

    Yes an X terminal ..not a virtual console.
    I think twinview creates a virtual display name (not LVDS1 or VGA1 etc).
    I have not used twinview so hard to help..
    Suspect nVidia labels internal laptop panels as DFP-0..

    I note there is no VGA displays in your xorg.conf only DVI..

    You can reconfigure nVidia X server with:
    nvidia-xconfig --help
    nvidia-settings --help

    some things require restarts (logout/login).

    Dynamic Twinview could be an ideal setup for you.. It allows using xrandr to switch between different twinview setups. One of these can be just one screen..
    See chapter 13 of the driver readme.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •