Page 1 of 5 123 ... LastLast
Results 1 to 10 of 42

Thread: Cannot print in Precise

  1. #1
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Exclamation Cannot print in Precise

    I have really been looking forward to the release of Precise, but this may be a deal breaker for me. I need to be able to print things because I am home schooling my son.

    My printer is a Canon MP620. The driver is the one installed and set up by the script from this web site: http://rackerua.com/2011/05/mp-620-6...eral-installer

    When I try to print something, the Ubuntu print monitor changes status just like things are working just fine, but there is no activity on the printer. It ends up with a status of "Idle - Ready to print", just like the job had completed successfully. But in CUPS, I can see this error message: "/usr/lib/cups/filter/pstocanonij failed"

    I have Googled that message and I get hundreds of hits dating back several years to the present. They are for all sorts of problems. I have been unable to link any of them to my problem in order to find a solution. Some of them were accepted as bugs in Launchpad, for which fixes were made years ago.

    Anyway, this exact same setup prints just fine in Oneiric. I do not know whether it is a printer setup error by me, an incompatibility of the driver with Precise, or a bug. If it is a bug, there are many possible sources: CUPS, Ghostscript, libpng, or who knows what else.

    I have been trying to resolve this since yesterday morning. Any help will be much appreciated.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  2. #2
    Join Date
    Dec 2009
    Location
    Vermont
    Beans
    842
    Distro
    Ubuntu

    Re: Cannot print in Precise

    First, take a look at this thread.

    Second, has the printer worked in other distributions or Ubuntu versions?

    Third, file a bug report. Just do it, even if you're not sure what's causing it. This is the time to do it. Alt+f2 ubuntu-bug cups (or look in your system monitor for a PID).
    Last edited by VTPoet; March 29th, 2012 at 04:21 PM.
    Linux: You reap what you tweak.

  3. #3
    Join Date
    Sep 2011
    Location
    Pennsylvania, U.S.A.
    Beans
    1,781
    Distro
    Ubuntu Development Release

    Re: Cannot print in Precise

    I second the O.P. s observation that something has changed re printing in Precise. I have printer setups that have worked very well since at least 10.04 or before. Printers still work for me (Brothers) but previously a print job started with 5 seconds of hitting 'print'. Using Precise printing graphics like web pages it takes 45 seconds or longer for the printer to come alive. I don't see anything funky in dmesg and don't know where else to look for clues.

  4. #4
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Re: Cannot print in Precise

    Quote Originally Posted by VTPoet View Post
    Second, has the printer worked in other distributions or Ubuntu versions?
    Yes, my original post states that "this exact same setup prints just fine in Oneiric".

    Thanks for the pointer to the other thread. I will look into it. Also, if I manage to file a bug, I will post a link to it.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  5. #5
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: Cannot print in Precise

    This is from bug 856028, where a user reported the same "pstocanonij failed" message:

    This is not a bug in Ubuntu. The problem here is that a manufacturer-supplied closed-source driver was created for older Linux distributions and does not work any more with Oneiric as Oneiric ships newer libraries. The problem can only be solved by Canon, publishing open-source free-software drivers (so that they can be rebuilt for newer distributions) or at least publish LSB-based packages which are distribution-independent.
    Closing ...
    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  6. #6
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: Cannot print in Precise

    I found a CUPS error log. Here is what it says for the last print job I attempted:

    Code:
    E [29/Mar/2012:10:52:14 -0500] [Job 13] Job stopped due to filter errors; please consult the error_log file for details. D [29/Mar/2012:10:52:14 -0500] [Job 13] The following messages were recorded from 10:51:59 to 10:52:14 D [29/Mar/2012:10:52:14 -0500] [Job 13] Adding start banner page "none". D [29/Mar/2012:10:52:14 -0500] [Job 13] Queued on "Canon-MP630" by "tim". D [29/Mar/2012:10:52:14 -0500] [Job 13] Auto-typing file... D [29/Mar/2012:10:52:14 -0500] [Job 13] Request file type is application/postscript. D [29/Mar/2012:10:52:14 -0500] [Job 13] File of type application/postscript queued by "tim". D [29/Mar/2012:10:52:14 -0500] [Job 13] Adding end banner page "none". D [29/Mar/2012:10:52:14 -0500] [Job 13] job-sheets=none,none D [29/Mar/2012:10:52:14 -0500] [Job 13] argv[0]="Canon-MP630" D [29/Mar/2012:10:52:14 -0500] [Job 13] argv[1]="13" D [29/Mar/2012:10:52:14 -0500] [Job 13] argv[2]="tim" D [29/Mar/2012:10:52:14 -0500] [Job 13] argv[3]="Tennis_overhead" D [29/Mar/2012:10:52:14 -0500] [Job 13] argv[4]="1" D [29/Mar/2012:10:52:14 -0500] [Job 13] argv[5]="Duplex=None InputSlot=auto PageSize=Letter job-uuid=urn:uuid:b6996587-65a2-3e30-62e4-05942633ed99 job-originating-host-name=localhost time-at-creation=1333036319 time-at-processing=1333036319" D [29/Mar/2012:10:52:14 -0500] [Job 13] argv[6]="/var/spool/cups/d00013-001" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[0]="CUPS_CACHEDIR=/var/cache/cups" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[1]="CUPS_DATADIR=/usr/share/cups" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[2]="CUPS_DOCROOT=/usr/share/cups/doc-root" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[3]="CUPS_FONTPATH=/usr/share/cups/fonts" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[4]="CUPS_REQUESTROOT=/var/spool/cups" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[5]="CUPS_SERVERBIN=/usr/lib/cups" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[6]="CUPS_SERVERROOT=/etc/cups" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[7]="CUPS_STATEDIR=/var/run/cups" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[8]="HOME=/var/spool/cups/tmp" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[9]="PATH=/usr/lib/cups/filter:/usr/bin:/usr/sbin:/bin:/usr/bin" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[10]="SERVER_ADMIN=root@tim-Z68A-D3-B3" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[11]="SOFTWARE=CUPS/1.5.2" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[12]="TMPDIR=/var/spool/cups/tmp" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[13]="USER=root" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[14]="CUPS_SERVER=/var/run/cups/cups.sock" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[15]="CUPS_ENCRYPTION=IfRequested" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[16]="IPP_PORT=631" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[17]="CHARSET=utf-8" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[18]="LANG=en_US.UTF-8" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[19]="PPD=/etc/cups/ppd/Canon-MP630.ppd" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[20]="RIP_MAX_CACHE=128m" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[21]="CONTENT_TYPE=application/postscript" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[22]="DEVICE_URI=bjnp://192.168.1.123:8611" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[23]="PRINTER_INFO=Canon MP630" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[24]="PRINTER_LOCATION=Tommy other driver" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[25]="PRINTER=Canon-MP630" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[26]="PRINTER_STATE_REASONS=none" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[27]="CUPS_FILETYPE=document" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[28]="FINAL_CONTENT_TYPE=printer/Canon-MP630" D [29/Mar/2012:10:52:14 -0500] [Job 13] envp[29]="AUTH_I****" D [29/Mar/2012:10:52:14 -0500] [Job 13] Started filter /usr/lib/cups/filter/pstops (PID 3106) D [29/Mar/2012:10:52:14 -0500] [Job 13] Started filter /usr/lib/cups/filter/pstocanonij (PID 3107) D [29/Mar/2012:10:52:14 -0500] [Job 13] Started backend /usr/lib/cups/backend/bjnp (PID 3108) D [29/Mar/2012:10:52:14 -0500] [Job 13] Canon-MP630: error while loading shared libraries: libpopt.so.0: cannot open shared object file: No such file or directory D [29/Mar/2012:10:52:14 -0500] [Job 13] Page = 612x792; 18,14 to 594,784 D [29/Mar/2012:10:52:14 -0500] [Job 13] slow_collate=0, slow_duplex=0, slow_order=0 D [29/Mar/2012:10:52:14 -0500] [Job 13] Before copy_comments - %!PS-Adobe-3.0 D [29/Mar/2012:10:52:14 -0500] [Job 13] %!PS-Adobe-3.0 D [29/Mar/2012:10:52:14 -0500] [Job 13] %%BoundingBox: (atend) D [29/Mar/2012:10:52:14 -0500] [Job 13] %%Creator: (LibreOffice 3.5) D [29/Mar/2012:10:52:14 -0500] [Job 13] %%For: (tim) D [29/Mar/2012:10:52:14 -0500] [Job 13] %%CreationDate: (2012-03-29 10:51:59 ) D [29/Mar/2012:10:52:14 -0500] [Job 13] %%Title: (Tennis_overhead) D [29/Mar/2012:10:52:14 -0500] [Job 13] %%LanguageLevel: 3 D [29/Mar/2012:10:52:14 -0500] [Job 13] %%DocumentData: Clean7Bit D [29/Mar/2012:10:52:14 -0500] [Job 13] %%Pages: (atend) D [29/Mar/2012:10:52:14 -0500] [Job 13] %%Orientation: (atend) D [29/Mar/2012:10:52:14 -0500] [Job 13] %%PageOrder: Ascend D [29/Mar/2012:10:52:14 -0500] [Job 13] %%EndComments D [29/Mar/2012:10:52:14 -0500] [Job 13] Before copy_prolog - %%BeginProlog D [29/Mar/2012:10:52:14 -0500] [Job 13] Before copy_setup - %%BeginSetup D [29/Mar/2012:10:52:14 -0500] [Job 13] Attempting to connect to host 192.168.1.123 on port 8611 D [29/Mar/2012:10:52:14 -0500] [Job 13] STATE: +connecting-to-device D [29/Mar/2012:10:52:14 -0500] [Job 13] Before page loop - %%Page: 1 1 D [29/Mar/2012:10:52:14 -0500] [Job 13] Copying page 1... D [29/Mar/2012:10:52:14 -0500] [Job 13] pagew = 576.0, pagel = 769.3 D [29/Mar/2012:10:52:14 -0500] [Job 13] bboxx = 0, bboxy = 0, bboxw = 612, bboxl = 792 D [29/Mar/2012:10:52:14 -0500] [Job 13] PageLeft = 18.1, PageRight = 594.1 D [29/Mar/2012:10:52:14 -0500] [Job 13] PageTop = 783.5, PageBottom = 14.2 D [29/Mar/2012:10:52:14 -0500] [Job 13] PageWidth = 612.0, PageLength = 792.0 D [29/Mar/2012:10:52:14 -0500] [Job 13] Wrote 1 pages... D [29/Mar/2012:10:52:14 -0500] [Job 13] STATE: -connecting-to-device D [29/Mar/2012:10:52:14 -0500] [Job 13] Connected to 192.168.1.123... D [29/Mar/2012:10:52:14 -0500] [Job 13] Connected to 192.168.1.123:8611 (IPv4)... D [29/Mar/2012:10:52:14 -0500] [Job 13] bjnp_backendRunLoop(print_fd=0, device_fd=5 D [29/Mar/2012:10:52:14 -0500] [Job 13] Ready to print. D [29/Mar/2012:10:52:14 -0500] [Job 13] End of messages D [29/Mar/2012:10:52:14 -0500] [Job 13] printer-state=3(idle) D [29/Mar/2012:10:52:14 -0500] [Job 13] printer-state-message="Ready to print." D [29/Mar/2012:10:52:14 -0500] [Job 13] printer-state-reasons=none E [29/Mar/2012:10:52:36 -0500] SSL shutdown failed: Error in the push function.
    Tim

    PS - Sorry, the code tags are not handling that output very well.
    Last edited by ratcheer; March 29th, 2012 at 05:00 PM.
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  7. #7
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: Cannot print in Precise

    This looks like a solid clue. It came from the above CUPS error log output:

    Code:
    Canon-MP630: error while loading shared libraries: libpopt.so.0: cannot open shared object file: No such file or directory
    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  8. #8
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Post Re: Cannot print in Precise

    Here is another clue from 2009:

    http://ubuntuforums.org/showthread.php?t=1204298

    I definitely have ia32-libs-multiarch installed, but something must be wrong with the installation.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  9. #9
    Join Date
    Jun 2009
    Location
    Alabama
    Beans
    2,232

    Red face Re: Cannot print in Precise

    NEVER MIND

    This thread is moot because I gave up and reinstalled Precise to get rid of all the mess I installed to try to get the printer working. I guess I will just keep Oneiric for printing.

    Tim
    Cyberpower PC, Core i5 2500 3.3 gHz, 8GB DDR3, ATI 6770 1GB, Samsung BX 2440 LED 1080p, 1 TB SATA III, 2 TB SATA III, Siduction Linux 64-bit

  10. #10
    Join Date
    Nov 2008
    Location
    Whakatane, NZ
    Beans
    631
    Distro
    Ubuntu

    Re: Cannot print in Precise

    I hear your frustration Tim.

    However, once you have re-installed precise, I would suggest checking out the Canon website itself for the drivers of your particular printer. Canon, from my understanding, are quite Linux friendly. Download the file, double click on it and it should bring up software centre to install. Install it, then restart your puter and it should then be there when you configure (set up) your printer.

    For years I haven't been able to get my Brother to work, but it does now after following the above. Hopefully it'll work for you too.
    Windows free since '09 - never looked back!

Page 1 of 5 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •