Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Bluetooth not detected in 14.04 but did work in 12.04

  1. #1
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,663
    Distro
    Ubuntu

    Bluetooth not detected in 14.04 but did work in 12.04

    After a couple of hours googling I have given up and come here.
    I just did a fresh install of 14.04 (64bit) on to this HP 6715b laptop. As the title says the Bluetooth that worked with 12.04 is no longer detected.
    The Wifi is working OK out of the box. Any help would be much appreciated, thanks.

    Code:
    rfkill list all
    0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    1: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
    Code:
    dmesg | grep -i blue
    [   19.109723] Bluetooth: Core ver 2.17
    [   19.109761] Bluetooth: HCI device and connection manager initialized
    [   19.109831] Bluetooth: HCI socket layer initialized
    [   19.109836] Bluetooth: L2CAP socket layer initialized
    [   19.109842] Bluetooth: SCO socket layer initialized
    [   19.115687] Bluetooth: RFCOMM TTY layer initialized
    [   19.115704] Bluetooth: RFCOMM socket layer initialized
    [   19.115717] Bluetooth: RFCOMM ver 1.11
    [   19.212185] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
    [   19.212191] Bluetooth: BNEP filters: protocol multicast
    [   19.212204] Bluetooth: BNEP socket layer initialized
    [ 8485.815932] Modules linked in: michael_mic arc4 bnep rfcomm bluetooth hid_a4tech usbhid hid hp_wmi sparse_keymap pcmcia radeon snd_hda_codec_analog kvm_amd kvm snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_page_alloc snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device snd_timer lib80211_crypt_tkip joydev serio_raw snd edac_core ttm k8temp yenta_socket edac_mce_amd pcmcia_rsrc pcmcia_core drm_kms_helper wl(POX) sp5100_tco i2c_piix4 soundcore lib80211 drm i2c_algo_bit cfg80211 shpchp wmi tpm_infineon video hp_accel lis3lv02d input_polldev mac_hid parport_pc ppdev lp parport pata_acpi firewire_ohci firewire_core psmouse crc_itu_t pata_atiixp tg3 ptp pps_core ahci libahci
    Code:
    sudo lshw -C network
    [sudo] password for cr: 
      *-network               
           description: Ethernet interface
           product: NetLink BCM5787M Gigabit Ethernet PCI Express
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:10:00.0
           logical name: eth0
           version: 02
           serial: 00:1f:29:a8:71:96
           capacity: 1Gbit/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.134 firmware=sb v2.09 latency=0 link=no multicast=yes port=twisted pair
           resources: irq:44 memory:d0000000-d000ffff
      *-network
           description: Wireless interface
           product: BCM4311 802.11a/b/g
           vendor: Broadcom Corporation
           physical id: 0
           bus info: pci@0000:30:00.0
           logical name: wlan0
           version: 02
           serial: 00:21:00:4f:c3:0c
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
           configuration: broadcast=yes driver=wl0 driverversion=6.30.223.141 (r415941) ip=192.168.2.100 latency=0 multicast=yes wireless=IEEE 802.11abg
           resources: irq:18 memory:c8000000-c8003fff

  2. #2
    Join Date
    May 2014
    Beans
    1,138

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    Please post the results of
    Code:
    lsusb

  3. #3
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,663
    Distro
    Ubuntu

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    We just just got the power back on here after an outage

    Code:
    lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 002: ID 08ff:2580 AuthenTec, Inc. AES2501 Fingerprint Sensor
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 002: ID 09da:000a A4 Tech Co., Ltd Optical Mouse Opto 510D
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

  4. #4
    Join Date
    May 2014
    Beans
    1,138

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    Do you have a 12.04 ISO burned to a disk that you could get the lsusb info from? I would recommend filing a bug report at https://bugs.launchpad.net/ubuntu/+filebug as this might be very difficult to diagnose

  5. #5
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,663
    Distro
    Ubuntu

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    Quote Originally Posted by jeremy31 View Post
    Do you have a 12.04 ISO burned to a disk that you could get the lsusb info from? I would recommend filing a bug report at https://bugs.launchpad.net/ubuntu/+filebug as this might be very difficult to diagnose
    Good idea. I will make a bootable 12.04 USB stick and get back with the results.

  6. #6
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,663
    Distro
    Ubuntu

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    Firstly I must apologise for the delay in replying. All my Linux dists are kept on an external drive along with all my backups. We have had so many thunderstorms lately that I feared to plug it in

    I made a bootable 12.04.3 USB stick but there is a problem. It boots to the desktop but cannot install the Broadcom drivers because the media is read only.
    So looking at the output of lsusb just shows the same as before plus the USB stick that it is booting from.
    I have attached the tail of /var/log/jockey.log which shows the errors that occurred when I tried to install "Additional Drivers".

    Other than reverting back to 12.04 I have run out of ideas
    Attached Files Attached Files

  7. #7
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,663
    Distro
    Ubuntu

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    I trawled through some old backups and found a file called hwinfo.txt. I have snipped out the parts that mention Bluetooth.
    Maybe someone can make sense of it.

    Code:
    Snipped from hwinfo.txt
    
    -------------------------------------------------------------------------------------------------------------------
    44: udi = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial_if0_bluetooth_hci_0_rfkill_hci0_bluetooth'
      linux.hotplug_type = 2 (0x2)
      linux.subsystem = 'rfkill'
      info.capabilities = { 'killswitch' }
      info.category = 'killswitch'
      info.addons.singleton = { 'hald-addon-rfkill-killswitch' }
      killswitch.type = 'bluetooth'
      killswitch.state = 1 (0x1)
      killswitch.access_method = 'rfkill'
      killswitch.name = 'hci0'
      linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.0/usb2/2-2/2-2:1.0/bluetooth/hci0/rfkill0'
      info.parent = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial_if0_bluetooth_hci_0'
      info.udi = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial_if0_bluetooth_hci_0_rfkill_hci0_bluetooth'
      info.subsystem = 'rfkill'
      info.product = 'hci0 bluetooth Killswitch'
      info.interfaces = { 'org.freedesktop.Hal.Device.KillSwitch' }
    
      45: udi = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial_if0_bluetooth_hci_0'
      linux.hotplug_type = 2 (0x2)
      linux.subsystem = 'bluetooth'
      info.capabilities = { 'bluetooth_hci' }
      info.category = 'bluetooth_hci'
      bluetooth_hci.originating_device = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial_if0'
      bluetooth_hci.address = 0ull (0x0ull)
      info.subsystem = 'bluetooth'
      info.product = 'Bluetooth Host Controller Interface'
      linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.0/usb2/2-2/2-2:1.0/bluetooth/hci0'
      info.parent = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial_if0'
      info.udi = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial_if0_bluetooth_hci_0'
    ----------------------------------------------------------------------------------------------------------------
    
    
    linux.subsystem = 'usb'
      info.product = 'Wireless (Bluetooth + WLAN) Interface [Integrated Module]'
      info.udi = '/org/freedesktop/Hal/devices/usb_device_3f0_171d_noserial'
      info.subsystem = 'usb_device'
      usb_device.configuration_value = 1 (0x1)
      usb_device.num_configurations = 1 (0x1)
      usb_device.num_interfaces = 4 (0x4)
      info.parent = '/org/freedesktop/Hal/devices/usb_device_1d6b_1_0000_00_13_0'
      linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.0/usb2/2-2'
      usb_device.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:13.0/usb2/2-2'
      usb_device.device_class = 224 (0xe0)
      usb_device.device_subclass = 1 (0x1)
      usb_device.device_protocol = 1 (0x1)
      usb_device.vendor_id = 1008 (0x3f0)
      usb_device.product_id = 5917 (0x171d)
      usb_device.vendor = 'Hewlett-Packard'
      info.vendor = 'Hewlett-Packard'
      usb_device.device_revision_bcd = 256 (0x100)
      usb_device.max_power = 0 (0x0)
      usb_device.product = 'Wireless (Bluetooth + WLAN) Interface [Integrated Module]'
    
    ---------------------------------------------------------------------------------------------------------------------

  8. #8
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    6,027
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    Try the Broadcom-STA driver from 14.10:
    Code:
    sudo apt-get remove --purge bcmwl-kernel-source
    wget http://de.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu1_amd64.deb
    sudo dpkg -i *.deb
    Reboot and check:
    Code:
    lspci -nnk | grep -iA2 net
    dmesg | egrep '[F]irm|[B]lue'
    lsmod
    lsusb

  9. #9
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,663
    Distro
    Ubuntu

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    Quote Originally Posted by praseodym View Post
    Try the Broadcom-STA driver from 14.10:
    Code:
    sudo apt-get remove --purge bcmwl-kernel-source
    wget http://de.archive.ubuntu.com/ubuntu/pool/restricted/b/bcmwl/bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu1_amd64.deb
    sudo dpkg -i *.deb
    Reboot and check:
    Code:
    lspci -nnk | grep -iA2 net
    dmesg | egrep '[F]irm|[B]lue'
    lsmod
    lsusb
    I will try that later, I'm working on something else ATM.
    Yesterday when searching for usb_device.product_id = 5917 (0x171d) I kept finding links that mention "Dumping 150 device(s) from the Global Device List:"
    I'm not sure what that means but maybe it's the problem.
    http://www.codon.org.uk/~mjg59/tmp/lshal.txt

  10. #10
    Join Date
    Jan 2010
    Location
    Hyperborea
    Beans
    1,663
    Distro
    Ubuntu

    Re: Bluetooth not detected in 14.04 but did work in 12.04

    Sorry that I have not replied sooner, I've been a bit out of sorts lately
    I feel better now

    Code:
    sudo apt-get remove --purge bcmwl-kernel-source
    [sudo] password for coldraven: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    The following packages will be REMOVED
      bcmwl-kernel-source*
    0 to upgrade, 0 to newly install, 1 to remove and 20 not to upgrade.
    After this operation, 5,800 kB disk space will be freed.
    Do you want to continue? [Y/n] y
    (Reading database ... 232848 files and directories currently installed.)
    Removing bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) ...
    Removing all DKMS Modules
    Done.
    update-initramfs: deferring update (trigger activated)
    Purging configuration files for bcmwl-kernel-source (6.30.223.141+bdcom-0ubuntu2) ...
    update-initramfs: deferring update (trigger activated)
    Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
    update-initramfs: Generating /boot/initrd.img-3.13.0-44-generic
    Code:
     sudo dpkg -i bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu1_amd64.deb 
    Selecting previously unselected package bcmwl-kernel-source.
    (Reading database ... 232782 files and directories currently installed.)
    Preparing to unpack bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu1_amd64.deb ...
    Unpacking bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu1) ...
    Setting up bcmwl-kernel-source (6.30.223.248+bdcom-0ubuntu1) ...
    Loading new bcmwl-6.30.223.248+bdcom DKMS files...
    First Installation: checking all kernels...
    Building only for 3.13.0-44-generic
    Building for architecture x86_64
    Building initial module for 3.13.0-44-generic
    Done.
    
    wl:
    Running module version sanity check.
     - Original module
       - No original module exists within this kernel
     - Installation
       - Installing to /lib/modules/3.13.0-44-generic/updates/dkms/
    
    depmod....
    
    DKMS: install completed.
    update-initramfs: deferring update (trigger activated)
    Processing triggers for initramfs-tools (0.103ubuntu4.2) ...
    update-initramfs: Generating /boot/initrd.img-3.13.0-44-generic
    I will reboot and see if it worked.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •