Results 1 to 8 of 8

Thread: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

  1. #1
    Join Date
    Feb 2007
    Beans
    169
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    And that is ACER not ASUS,, names are too close..

    System locks solid anytime I've tried to access wi-fi. It's a new machine, works ok in Windows. I'm just running live USB. So far, it's happened every time with Ubuntu 11.10 64 and 32 bit and Linux Mint. In the 64 bit U I also get a WMI error.

    The card is detected as AR8485 and us using ath9k driver, in Mint at least.

  2. #2
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,724
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    Please show the terminal (CTRL+ALT+T) outputs of
    Code:
    lspci -nnk | grep -iA2 net
    lsmod
    dmesg | grep ath
    rfkill list
    Try to shut off the hardware encryption of this driver on-the-fly:

    Code:
    sudo modprobe -rfv ath9k
    sudo modprobe -v ath9k nohwcrypt=1
    If it works, make it permanent via

    Code:
    echo "options ath9k nohwcrypt=1" | sudo tee /etc/modprobe.d/ath9k.conf

  3. #3
    Join Date
    Feb 2007
    Beans
    169
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    I'll send the outputs of the terminal stuff in next post as I have to rig up a way to save the >output

    But for now, the 1st modprobe worked ok, on the 2nd it locked the computer, on this line.
    Code:
    insmod /lib/modules/3.0.0-12-generic/kernal/drivers/net/wireless/ath/ath9k/ath9k.ko nohwcrypt=1

  4. #4
    Join Date
    Feb 2007
    Beans
    169
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    Got it
    lscpi:
    06:00.0 Ethernet controller [0200]: Atheros Communications AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
    Subsystem: Acer Incorporated [ALI] Device [1025:0598]
    Kernel driver in use: atl1c
    --
    07:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Foxconn International, Inc. Device [105b:e047]
    Kernel driver in use: ath9k
    lsmod

    Module Size Used by
    nls_utf8 12557 1
    isofs 40253 1
    bnep 18436 2
    rfcomm 47946 0
    bluetooth 166112 10 bnep,rfcomm
    parport_pc 36962 0
    ppdev 17113 0
    dm_crypt 23199 0
    lp 17799 0
    parport 46562 3 parport_pc,ppdev,lp
    joydev 17693 0
    snd_hda_codec_conexant 62197 1
    snd_hda_codec_hdmi 32040 1
    snd_hda_intel 33390 2
    snd_hda_codec 104802 3 snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hda_ intel
    snd_hwdep 13668 1 snd_hda_codec
    snd_pcm 96755 3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
    arc4 12529 2
    ath9k 127538 0
    mac80211 310872 1 ath9k
    snd_seq_midi 13324 0
    sparse_keymap 13890 0
    snd_rawmidi 30547 1 snd_seq_midi
    snd_seq_midi_event 14899 1 snd_seq_midi
    ath9k_common 13839 1 ath9k
    uvcvideo 72711 0
    ath9k_hw 312866 2 ath9k,ath9k_common
    videodev 93004 1 uvcvideo
    snd_seq 61896 2 snd_seq_midi,snd_seq_midi_event
    v4l2_compat_ioctl32 17083 1 videodev
    ath 24067 2 ath9k,ath9k_hw
    snd_timer 29991 2 snd_pcm,snd_seq
    snd_seq_device 14540 3 snd_seq_midi,snd_rawmidi,snd_seq
    psmouse 73882 0
    cfg80211 199587 3 ath9k,mac80211,ath
    serio_raw 13166 0
    snd 68266 14 snd_hda_codec_conexant,snd_hda_codec_hdmi,snd_hda_ intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi, snd_seq,snd_timer,snd_seq_device
    sp5100_tco 13791 0
    k10temp 13166 0
    i2c_piix4 13301 0
    soundcore 12680 1 snd
    snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
    binfmt_misc 17540 1
    squashfs 36799 1
    overlayfs 28267 1
    nls_iso8859_1 12713 2
    nls_cp437 16991 2
    vfat 17585 2
    fat 61475 1 vfat
    dm_raid45 78155 0
    xor 12894 1 dm_raid45
    dm_mirror 22203 0
    dm_region_hash 20918 1 dm_mirror
    dm_log 18564 3 dm_raid45,dm_mirror,dm_region_hash
    btrfs 648895 0
    zlib_deflate 27139 1 btrfs
    libcrc32c 12644 1 btrfs
    radeon 1015995 3
    ums_realtek 13272 0
    ttm 76805 1 radeon
    drm_kms_helper 42558 1 radeon
    usb_storage 57901 4 ums_realtek
    uas 18027 0
    atl1c 41643 0
    drm 236330 5 radeon,ttm,drm_kms_helper
    ahci 26002 0
    libahci 26861 1 ahci
    i2c_algo_bit 13423 1 radeon
    wmi 19256 0
    video 19412 0
    dmseg
    [ 64.929113] ath9k 0000:07:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
    [ 64.929173] ath9k 0000:07:00.0: setting latency timer to 64
    [ 64.937219] ath: EEPROM regdomain: 0x6c
    [ 64.937225] ath: EEPROM indicates we should expect a direct regpair map
    [ 64.937234] ath: Country alpha2 being used: 00
    [ 64.937239] ath: Regpair used: 0x6c
    [ 65.075749] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
    [ 65.078730] Registered led device: ath9k-phy0
    rfkill
    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

  5. #5
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,724
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    Try the "permanent" way and reboot.

  6. #6
    Join Date
    Jan 2009
    Location
    Palo Alto, CA
    Beans
    42

    Re: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    First off, does this thread have the wrong title?? Its tagged with 9485, but the title is "AR8485" (that is 8 instead of 9). Is there an AR8485? In any case I have and 9485 simply turning off the hardware encrypt has worked wonders for me. My network performance (as seen from just general use of FF) went from spotty and slow to lightening fast and I think that the system in general is now much faster (subjective). Also, I was also able to move the network boot from first in the boot order which also leads to faster cleaner boots (especialy when ethernet is plugged in). After much searching and reading about this problem, this simple fix does the trick. To be more specific, I am on a fairly fresh 12.04 with all (as far as I can tell) recommended updates applied. As found on

    http://ubuntuforums.org/showthread.p...heros+acer+722

    I first tried these commands:

    sudo modprobe -rfv ath9k
    sudo modprobe -v ath9k nohwcrypt=1

    with functionally great results and then

    made it permanent by creating the file

    /etc/modprobe.d/ath9k.conf

    and adding this line (followed by a <cr> which i'm not sure was needed...)

    options ath9k nohwcrypt=1

    just for the record:

    rone@ronsAcerUbu:~$ lspci -nnk | grep -iA2 net
    06:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8152 v2.0 Fast Ethernet [1969:2062] (rev c1)
    Subsystem: Acer Incorporated [ALI] Device [1025:0598]
    Kernel driver in use: atl1c
    --
    07:00.0 Network controller [0280]: Atheros Communications Inc. AR9485 Wireless Network Adapter [168c:0032] (rev 01)
    Subsystem: Foxconn International, Inc. Device [105b:e047]
    Kernel driver in use: ath9k

    Let me know if you need any more info.
    Last edited by ronewolf; July 9th, 2012 at 07:40 AM. Reason: fixed a typo and removed my comment about boot order as it seems to have been only optimistic
    ______Ron

  7. #7
    Join Date
    May 2013
    Beans
    1

    Exclamation Re: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    Hi I have used the commands below to solve a wi-fi issue on my Sony Vaio with Ubuntu 12.04:

    sudo modprobe -rfv ath9k
    sudo modprobe -v ath9k nohwcrypt=1

    Abd then I create the file below

    gksudo gedit /etc/modprobe.d/ath9k.conf

    and add the line below followed by a <cr>

    options ath9k nohwcrypt=1

    However, at every system reboot the wi-fi connection is lost. I have to enter the commands "
    sudo modprobe -rfv ath9k and
    sudo modprobe -v ath9k nohwcrypt=1" again to have the wi-fi ON. I have checked that the file ath9k.conf has been created
    in the right location and it has the right contents.
    Does anybody know why the configuration I made is not being kept?

  8. #8
    Join Date
    Aug 2011
    Location
    Berlin, Germany
    Beans
    5,724
    Distro
    Ubuntu Gnome 14.04 Trusty Tahr

    Re: Wi-fi locks Asus Aspire 722 w Atheros AR8485 wi-fi

    Please check:
    Code:
    grep ath9k /etc/modprobe.d/*
    If the module is blacklisted remove it from the respective file. Otherwise force the driver being loaded at boot-up:
    Code:
    echo ath9k | sudo tee -a /etc/modules

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •