Results 1 to 10 of 12

Thread: Lenovo IdeaPad Z575 WiFi (Ralink RT3090)

Threaded View

  1. #1
    Join Date
    Mar 2010
    Location
    USA
    Beans
    92
    Distro
    Ubuntu 12.04 Precise Pangolin

    Lenovo IdeaPad Z575 WiFi (Ralink RT3090)

    Well I got my IdeaPad in the mail today and immediately opened it, formatted the entire drive, and installed Ubuntu 10.10. My first and only challenge so far has been getting the wireless to work. Each thing I've tried so far, possibly incorrectly, I've undone individually so I'm open to any troubleshooting / driver-finding advice.

    According to Lenovo's records on my serial number, the laptop in question has a Ralink RT3090 PCIe wLAN chipset. I tried installing Ralink's drivers, but after doing so the "Additional Drivers" menu told me that "rt3090sta" was activated but not currently in use. Network manager says that wireless is disabled. My laptop's LEDs say that wireless is enabled correctly.

    EDIT: It appears that I've finally found a solution; my wireless is working quite well now. See my last post for a quick-and-dirty tutorial, which I plan on editing/merging with something else, later.
    Last edited by gdea73; March 15th, 2012 at 11:27 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •