Results 1 to 3 of 3

Thread: Video pixelation on PPC

  1. #1
    Join Date
    Mar 2012
    Beans
    2

    Video pixelation on PPC

    I recently installed Ubuntu 10.04 on my PPC G4 eMac. It's way faster than Mac OS X, but video playback is pixelated. I think there is a fix for this in PowerPCFAQ, but I'm not sure if I'm doing it right.
    With 10.04 and 10.10 I turn off KMS (Kernel Mode Setting) by using the radeon.modeset=0 boot parameter (see above). If I don't do this then I have poor video playback (a strange vertical pixelation) and get low values in glxgears (you see "Software Rasterizer" written when running the command glxgears -info).
    So I need to disable KMS. Where do I insert this radeon.modeset=0 boot parameter? I'd tried inserting it in Yaboot.conf like this:
    Code:
    boot=/dev/hda2
    device=/pci@f2000000/mac-io@17/ata-4@1f000/disk@0:
    partition=3
    root=/dev/hda3
    timeout=50
    install=/usr/lib/yaboot/yaboot
    magicboot=/usr/lib/yaboot/ofboot
    enablecdboot
    
    image=/boot/vmlinux
        label=Linux
        read-only
        initrd=/boot/initrd.img
        append="radeon.modeset=0 quiet splash"
    
    image=/boot/vmlinux.old
        label=old
        read-only
        initrd=/boot/initrd.img.old
        append="quiet splash"
    and running sudo ybin -v and sudo reboot in terminal.
    Also tried: putting
    Code:
    radeon.modeset=0 video=radeonfb:1024x768-24@60
    or
    Code:
    Linux radeon.modeset=1 radeonfb:off
    or
    Code:
    video=radeonfb:off
    or
    Code:
    video=radeonfb:off radeon.modeset=0
    or
    Code:
    nomodeset
    in place of
    Code:
    radeon.modeset=0 quiet splash
    Also running
    Code:
    echo options radeon modeset=0 > /etc/modprobe.d/radeon-kms.conf
    in terminal.
    But the problem remains.

    Please help.

  2. #2
    Join Date
    Jan 2011
    Beans
    961

    Re: Video pixelation on PPC

    I think you've exhausted most options there! Your yaboot.conf looks fine. I know it is a stupid question, but are you sure you have a radeon card?

    I've been playing with lucid recently and it is the best IMHO.

    Try

    Code:
    video=offb:off radeon.modeset=0
    If you want to try with KMS on instead, use

    Code:
    video=radeonfb:off video=offb:off radeon.agpmode=-1
    When booted up use the command

    dmesg | grep drm

    If you only get a few lines of output then KMS is not on fully (even if it says it is enabled).

    That is all I know.

  3. #3
    Join Date
    Mar 2012
    Beans
    2

    Re: Video pixelation on PPC

    Thanks for the response. I'm pretty sure I have radeon, because lspci command in terminal returns Radeon 7500.
    Code:
    video=offb:off radeon.modeset=0
    didn't work.
    With
    Code:
    video=radeonfb:off video=offb:off radeon.agpmode=-1
    dmesg | grep drm command only returned a couple of lines, like you predicted.
    I'll try to install Ubuntu 12.04 when it is out.

    EDIT:
    Solved. Added
    Code:
    radeon.modeset=0
    to yaboot.conf and then used this xorg.conf file. It was possible to run non-pixelated video before using this fix, by using X11 video driver in media players or compiling the latest mplayer2 version from source, but this resulted in low frame rate playback.
    The problem was that OpenGL was using Software Rasterizer, not hardware rendering driver. glxgears previously returned ~ 300 fps and now I get ~ 4100 fps. I also tried kubuntu 12.04 live cd and Software Rasterizer was in use. Now glxinfo | grep render returns:
    Code:
    direct rendering: Yes
    OpenGL renderer string: Mesa DRI R100 (RV200 5157) 20090101 AGP 4x PowerPC/Altivec TCL
    My Xorg.conf file http://pastebin.com/6xH79RUc
    Last edited by Improntant; June 8th, 2012 at 05:51 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •