Results 1 to 1 of 1

Thread: Wired eth0 network + wireless internet connect = no mailx

  1. #1
    Join Date
    Feb 2011
    Beans
    1

    Wired eth0 network + wireless internet connect = no mailx

    Recently moved and current setup has internet connection via wifi router. Also have local network setup (3 boxes) on eth0. I have configured the local network connections to use routes only for resources on local, which allows the wifi to connect to internet.

    So far so good, except I have several monitoring scripts that use command line mail/mailx to send alerts if there is a problem, and with this network configuration, the alerts are not being sent. The scripts are verified and working and as a test I have tried to use:
    cat transfer_log | mail -s "Transfer log results for $(date '+%F')" my_email@server.com

    No success.

    Can anyone suggest a correct configuration for this to work? It seems that the mail function wants to use the eth0 connection and needs to instead use the wifi connection. Because of the physical setup in the rental house, there is not an option other than wifi for internet connect.

    Thanks for any help.
    Last edited by bmckinley; March 3rd, 2012 at 05:08 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •