Results 1 to 1 of 1

Thread: Not returning to prompt after upstart job

  1. #1
    Join Date
    Mar 2012
    Beans
    2

    Question Not returning to prompt after upstart job

    Hi all,

    having several keyboards on my desk and being used to using the Ctrl-Alt-Del combination to call up the login window of Windows XP, several times I quite unintentionally succeeded in restarting the ubuntu server I'm experimenting with

    A bit of googling revealed I should edit the /etc/inittab, but there is no such file in ubuntu 11.10 (Oneric). Further googling revealed the more ubuntu specific file /etc/event.d/control-alt-delete, which also didn't exist. But looking through /etc I discovered that the init directory contained a file named control-alt-delete.conf.

    So I edited this file to look as follows:

    Code:
    # control-alt-delete - emergency keypress handling
    #
    # This task is run whenever the Control-Alt-Delete key combination is
    # pressed, and performs a safe reboot of the machine.
    
    description "emergency keypress handling"
    author      "Scott James Remnant <scott@netsplit.com>"
    
    start on control-alt-delete
    
    # task
    # exec shutdown -r now "Control-Alt-Delete pressed"
    console output
    script
        echo "Shutdown / restart with Ctrl-Alt-Del is disabled!"
    end script
    It works fine, except for one small irritation. After output of the message "Shutdown / restart with Ctrl-Alt-Del is disabled!" it seems to hang, and the user is forced to press ENTER to return to the normal bash or login input prompt.

    Is there any way to change this behavior? Or is this the normal behavior of upstart scripts?

    Thanks.
    Last edited by ja27; March 2nd, 2012 at 04:04 PM. Reason: Added tags, icon

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •