Page 14 of 30 FirstFirst ... 4121314151624 ... LastLast
Results 131 to 140 of 291

Thread: Dell XPS 13 ultrabook compatibility

  1. #131
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Dell XPS 13 ultrabook compatibility

    How to setup mouse wheel emulation that will survive a reboot

    Step 1
    Code:
    $ sudo mkdir /etc/X11/xorg.conf.d/
    Step 2
    Code:
    $ sudo cp /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/
    Step 3
    Code:
    $ sudo gedit /etc/X11/xorg.conf.d/10-evdev.conf
    Step 4
    Edit the first "InputClass" section to look like this:

    Code:
    Section "InputClass"
            Identifier "evdev pointer catchall"
            MatchIsPointer "on"
            MatchDevicePath "/dev/input/event*"
            Driver "evdev"
            Option      "EmulateWheel"      "true"
            Option      "EmulateWheelButton"    "3"
    EndSection
    (the 2 Option lines are the new additions)

    Step 5
    Restart X11 (or your entire computer)

    Step 6
    Enjoy scrolling by holding right click and swiping.

    To undo:
    Code:
    $ sudo rm /etc/X11/xorg.conf.d/10-evdev.conf
    Last edited by tshack; May 29th, 2012 at 05:05 AM. Reason: changed gvim to gedit since everybody has it

  2. #132
    Join Date
    Jul 2008
    Beans
    6

    Re: Dell XPS 13 ultrabook compatibility

    Quote Originally Posted by tshack View Post
    How to setup mouse wheel emulation that will survive a reboot
    Thanks! The trackpad was starting to remind me of 2003 again.

    Until a proper cypress driver becomes available, your workaround is refreshing.

  3. #133

    Re: Dell XPS 13 ultrabook compatibility

    Quote Originally Posted by tshack View Post
    Notice: This method will not survive a reboot. I recommend the method in the next post instead: Found Here.


    Alright guys, it isn't much but I found a way to make the mouse a little bit more usable -- mousewheel emulation.

    Step 1 - Install GPointing Device Settings
    sudo apt-get install gpointing-device-settings

    Step 2 - Run it
    gpointing-device-settings

    You will get this:


    Checking "Use wheel emulation" and selecting "Button 3" (as shown) will allow you to scroll by swiping your finger on the touchpad while holding down the second mouse button.


    Note:
    If you would rather have middle click X11 style copy-and-paste, you can use these settings instead:


    For some reason, if both boxes are checked, you will only get scrolling. Emulated middle click will stop working.
    Oh god! Thank you very very much for this workaround. It'll be of great use until a real driver is here.
    .

  4. #134
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Dell XPS 13 ultrabook compatibility

    Palm Rejection Service - Experimental

    I have managed to put together a hack for disabling the mouse when using the keyboard. Let's call it experimental for now, although it works just fine for me (no problems yet).

    It is a system service that directly reads the keyboard event device, which I assume it is the same for you all as it is for me:
    /dev/input/event4
    (if not, the service is a bash script, so feel free to edit it).

    When keyboard activity is detected, the mouse is disabled -- when the keyboard activity stops, the mouse is re-enabled. Keyboard activity is checked for every 1 second.

    Unfortunately, the minimum delay I could manage was 1 second -- this is due to a limitation of the bash "read" command, sorry guys.

    Perhaps I can whip up something better in C if I can find the time.


    Instructions

    Step 1
    Copy the script into your /etc/init.d/ directory
    Code:
    $ sudo cp ~/Downloads/xps_touch_man.sh /etc/init.d/
    Step 2
    Remove the .sh extension (ubuntuforums.org required it, sorry)
    Code:
    $ sudo mv /etc/init.d/xps_touch_man.sh /etc/init.d/xps_touch_man
    Step 3
    Make the script executable
    Code:
    $ sudo chmod 755 /etc/init.d/xps_touch_man
    Step 4
    The root user will need to be able to access your Xsession. So, with the user you normally login as, run the following command:
    Code:
    $ xhost SI:localuser:root
    Step 5
    Start the service:
    Code:
    $ sudo service xps_touch_man start

    If all went well, you will now have some form of touchpad protection when typing. Like I said earlier, it takes 1 second for the touchpad to come back on, so it can be a little annoying (depending on what you are doing). Again, this is a limitation of bash and I apologize. Help regarding this issue is appreciated.

    Personally, I recommend just starting the service if you have a lot of typing to do and then stopping the service when you are done.

    As you may have guessed, stopping the service is just as easy as starting it:
    Code:
    $ sudo service xps_touch_man stop
    Notes
    [1] Keyboard polling delay is 1 second

    [2] Assumes keyboard on /dev/input/event4

    [3] The service generates a log file in /var/log/xps_touch_man.log

    [4] The service generates an error log in /var/log/xps_touch_man.err

    [5] Step 4 and Step 5 will have to be repeated if/when you reboot to re-enable the palm rejection. (See next post)

    Attached Files Attached Files
    Last edited by tshack; May 29th, 2012 at 11:59 PM.

  5. #135
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Dell XPS 13 ultrabook compatibility

    Here is how I have set myself up to use the xps_touch_man service.

    I appended the following to the end of my ~/.profile
    Code:
    xhost SI:localuser:root
    which will automatically give the root user permission to access your Xsession when you login.


    Then I use the attached script to simply toggle the palm rejection when I need it / don't need it / find it annoying:

    Code:
    xps_touch_toggle.sh
    If you guys from Dell, Ubuntu, or Cypress are reading this. I would love to see a real driver! Nothing would make me happier than to scrap all this and enjoy some multi-touch!
    Attached Files Attached Files

  6. #136
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Dell XPS 13 ultrabook compatibility

    Quote Originally Posted by mooselander View Post
    Thanks! The trackpad was starting to remind me of 2003 again.

    Until a proper cypress driver becomes available, your workaround is refreshing.

    Quote Originally Posted by bekirserifoglu View Post
    Oh god! Thank you very very much for this workaround. It'll be of great use until a real driver is here.
    Happy to help.

    And thank you two for taking the time to reply! Your responses are very much appreciated!

  7. #137
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Dell XPS 13 ultrabook compatibility

    How to automatically turn off Bluetooth upon login

    I nearly forgot. The other day I grew tired of manually turning off Bluetooth everytime I logged into my laptop. I hardly ever use it.

    Adding the following to the bottom of your ~/.profile will do the trick:
    Code:
    rfkill block bluetooth
    You will still have the bluetooth icon at the top of your screen and you will still be able to toggle the bluetooth radio on/off via the icon just as before. Only difference is that it won't be on by default when you login.

    Additional (potential) fix for WiFi
    Once I rebooted my machine and wifi refused to come back up. The following finally did the trick:
    Code:
    rfkill unblock wifi
    Consequently, I have also appended this to by ~/.profile just to be safe. Couldn't hurt.

  8. #138
    Join Date
    Jan 2009
    Beans
    Hidden!

    Re: Dell XPS 13 ultrabook compatibility

    Some good news.

    Barton George, of project Sputnik, hopes to receive a "completed" Touchpad driver from Cypress by the end of June:

    http://bartongeorge.net/2012/05/29/sputnik-wow/

  9. #139
    Join Date
    Apr 2012
    Beans
    23

    Re: Dell XPS 13 ultrabook compatibility

    I have been playing with boot parameters lately... I have noticed that booting with the parameter noapic does give me a smoother experience (which is weird though).

  10. #140
    Join Date
    Jun 2012
    Beans
    3

    Re: Dell XPS 13 ultrabook compatibility

    Unfortunately, the minimum delay I could manage was 1 second -- this is due to a limitation of the bash "read" command, sorry guys.
    According to "help read", arguments to the -t parameter can be fractional. An argument of "0.1" seems to work.

Page 14 of 30 FirstFirst ... 4121314151624 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •