Results 1 to 3 of 3

Thread: glxgears,fglrxinfo all segmentation fault

  1. #1
    Join Date
    Apr 2009
    Beans
    10

    glxgears,fglrxinfo all segmentation fault

    Hi all,
    Though I use ubuntu linux for long time, first time I am facing this problem,
    After some updates taken from apt ... When I write
    Code:
    $glxgears
    it gives error "Segmentation fault"
    Code:
    $fglrxinfo
    "Segmentation fault"
    Code:
    $glxinfo
    name of display: :0.0
    Segmentation fault
    I tried to check, what went wrong, many times removed fglrx etc. totally...
    Code:
    $ sudo apt-get remove --purge fglrx
    similartly i remove others like "xserver-xorg-video-ati" and "xserver-xorg-video-radeon"
    When I remove them and
    Code:
    $glxgears
    It gives.............
    Code:
    X Error of failed request:  BadRequest (invalid request code or no such operation)
      Major opcode of failed request:  135 (GLX)
      Minor opcode of failed request:  19 (X_GLXQueryServerString)
      Serial number of failed request:  16
      Current serial number in output stream:  16
    again installed all of them fresh, but nothing happened.
    Some other details what I think relevant are:
    My ubuntu is:
    Linux GHD 2.6.32-39-generic #86-Ubuntu SMP Mon Feb 13 21:50:08 UTC 2012 x86_64 GNU/Linux
    The result of command
    Code:
    lspci -nn | grep VGA
    is
    Code:
    00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller [8086:2a42] (rev 07)
    I don't want proprietary software, just want my old congiuration back what was fine.
    How can I do a clean reinstall, after removing all such graphic drivers if this is solution?
    The command
    Code:
    find /usr/lib -name libGL.so.1 -exec ls -al {} \;
    gives
    Code:
    lrwxrwxrwx 1 root root 12 2012-02-26 11:33 /usr/lib/mesa/libGL.so.1 -> libGL.so.1.2
    lrwxrwxrwx 1 root root 8 2012-02-26 11:33 /usr/lib/libGL.so.1 -> libGL.so
    lrwxrwxrwx 1 root root 12 2012-02-26 11:33 /usr/lib/fglrx/libGL.so.1 -> libGL.so.1.2

  2. #2
    Join Date
    Jun 2007
    Beans
    11,069

    Re: glxgears,fglrxinfo all segmentation fault

    Purge fglrx and do not install it again. You should not have fglrx installed for an intel GPU. Then, reinstall the proper versions of libGL and libglx:
    Code:
    sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx
    You will need to restart (at least X) for change to take effect.

  3. #3
    Join Date
    Apr 2009
    Beans
    10

    Re: glxgears,fglrxinfo all segmentation fault

    Thanks a lot
    problem solved exactly following your suggestions.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •