Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Preventing screen locking when playing full screen videos

  1. #11
    Join Date
    Oct 2011
    Location
    Canada
    Beans
    891
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Preventing screen locking when playing full screen videos

    Quote Originally Posted by jonoei97 View Post
    You could try Caffeine.

    https://launchpad.net/~caffeine-developers/+archive/ppa

    It can automatically and temporarily prevent your screen from locking when a certain application is running. You can specify all these options.
    Caffeine does NOT work properly, in 11.10 at least. I set it to automatically start when the process "firefox" starts and it even detects the firefox icon, but when I start firefox it doesn't...I don't want to set another process to start when I boot because I only need this feature occasionally and full screen flash videos never make my Windows 7 go to sleep....Only Ubuntu

    Maybe something missing in the linux version of Firefox?
    613websites.com Budget Canadian Web Design and Hosting

  2. #12
    Join Date
    Nov 2009
    Location
    Lake Wales Florida
    Beans
    607
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Preventing screen locking when playing full screen videos

    Add this to your xorg.conf file

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
    Option "NoPM" "True"
    EndSection
    AMD FX-6200 - MSI 4.1Ghz- Nvidia GTX550Ti -12/GIG - 60GB-SSD/500 Sata - 12.04 - Gnome 3

  3. #13
    Join Date
    Oct 2011
    Location
    Canada
    Beans
    891
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Preventing screen locking when playing full screen videos

    Quote Originally Posted by Bobhuber View Post
    Add this to your xorg.conf file

    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
    Option "BlankTime" "0"
    Option "StandbyTime" "0"
    Option "SuspendTime" "0"
    Option "OffTime" "0"
    Option "NoPM" "True"
    EndSection
    Mind explaining what this does exactly? From what I can tell, it would set that universally for my PC? Everything is currently working for me EXCEPT for playing flash videos within Firefox, which puts my PC to sleep when it shouldn't...That's why I am thinking it is a Firefox under Ubuntu issue (same version under Windows 7 works fine) and NOT a more general Ubuntu issue.
    613websites.com Budget Canadian Web Design and Hosting

  4. #14
    Join Date
    Nov 2009
    Location
    Lake Wales Florida
    Beans
    607
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Preventing screen locking when playing full screen videos

    Quote Originally Posted by d4m1r View Post
    Mind explaining what this does exactly? From what I can tell, it would set that universally for my PC? Everything is currently working for me EXCEPT for playing flash videos within Firefox, which puts my PC to sleep when it shouldn't...That's why I am thinking it is a Firefox under Ubuntu issue (same version under Windows 7 works fine) and NOT a more general Ubuntu issue.
    It is a universal setting for Ubuntu and has nothing to do with Windows. It's not a Firefox issue but Ubuntu and Nvidia as far as I have been able to tell. The only way I have been able to keep the computer from taking a nap due to inactivity (and I'm going back as far as Ubuntu 9.04) is to set it up in the xorg.conf no matter what I have set up in power management. In re-reading the original post it's not what the OP wanted because he wanted sleep other than full screen. I also have my box setup as a server along with the desktop which may or may not make a difference.
    AMD FX-6200 - MSI 4.1Ghz- Nvidia GTX550Ti -12/GIG - 60GB-SSD/500 Sata - 12.04 - Gnome 3

  5. #15
    Join Date
    Oct 2011
    Location
    Canada
    Beans
    891
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Preventing screen locking when playing full screen videos

    Quote Originally Posted by Bobhuber View Post
    It is a universal setting for Ubuntu and has nothing to do with Windows. It's not a Firefox issue but Ubuntu and Nvidia as far as I have been able to tell. The only way I have been able to keep the computer from taking a nap due to inactivity (and I'm going back as far as Ubuntu 9.04) is to set it up in the xorg.conf no matter what I have set up in power management. In re-reading the original post it's not what the OP wanted because he wanted sleep other than full screen. I also have my box setup as a server along with the desktop which may or may not make a difference.

    For me, my PC doesn't sleep in all other cases....Ex: playing a full screen video in VLC doesn't put it to sleep, but playing a full screen flash video from Firefox does. That's why I think it is a Firefox issue, NOT Ubuntu.
    613websites.com Budget Canadian Web Design and Hosting

  6. #16
    Join Date
    Dec 2009
    Location
    A really tall tree.
    Beans
    165
    Distro
    Ubuntu

    Re: Preventing screen locking when playing full screen videos

    I'm wondering if it's your screen saver settings?

    Main Menu > System > Preferences > Screen Saver
    Attached Images Attached Images

  7. #17
    Join Date
    Aug 2011
    Location
    Southampton
    Beans
    96
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Preventing screen locking when playing full screen videos

    Quote Originally Posted by S2UIRR3L View Post
    I'm wondering if it's your screen saver settings?
    I can't access such a menu in gnome 3 - is this available via gconf?

  8. #18
    Join Date
    Oct 2011
    Location
    Canada
    Beans
    891
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Preventing screen locking when playing full screen videos

    Quote Originally Posted by S2UIRR3L View Post
    I'm wondering if it's your screen saver settings?

    Main Menu > System > Preferences > Screen Saver
    No such screen in 11.10

    The only related screensaver/idle/lock application in settings available in 11.10 is called "Screen" and looks like this:

    Last edited by d4m1r; March 2nd, 2012 at 02:26 AM.
    613websites.com Budget Canadian Web Design and Hosting

  9. #19
    Join Date
    Dec 2009
    Location
    A really tall tree.
    Beans
    165
    Distro
    Ubuntu

    Re: Preventing screen locking when playing full screen videos

    I'm so sorry... I'm some what of a newbie to Linux and Ubuntu.
    I failed to mention that I'm using Lucid Lynx 10.04 LTS (64-bit).

    But still, I'd make sure that you have all your settings in all your
    programs tweaked so that screen saver (or power settings) are
    disabled (or set to presentation so that the monitor stays on).

    This is what I did on my computer. I have set it so that it never
    goes into screen saver mode or shuts off the monitor/hard drive.
    The only way it will ever go to sleep is if I push the power button.

    I'm very sorry that I couldn't help, but I do wish you the best!!!

  10. #20
    Join Date
    Mar 2012
    Beans
    11

    Re: Preventing screen locking when playing full screen videos

    Also having this problem. Note that original post states this is ONLY to do with watching Flash movies in full screen mode. Otherwise we don't want to have to change universal settings. I suspect an issue with Ubuntu implementation of Flash or Firefox, whereby they don't restrain the screen dimming/locking facility, as VLC does.

    Cheers to anyone who can help,
    J

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •