Page 8 of 88 FirstFirst ... 6789101858 ... LastLast
Results 71 to 80 of 875

Thread: AMD/Intel Hybrid Graphics works

  1. #71
    Join Date
    Oct 2007
    Beans
    24

    Re: AMD/Intel Hybrid Graphics works !

    After a frusturating two days trying to figure this problem out and being unable to install Catalyst because it kept detecting a previous fglrx driver when I had already removed and purged it I decided to reformat (it was a new install anyway) and start from scratch. Before even installing a driver I followed the instructions to install the sna driver and then I installed the latest catalyst and everything now works. The only thing is that I have to run Unity 2D when on the integrated chip. I can definitely live with this as long as it solves my overheating issue.

  2. #72
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    443
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Startacus View Post
    After a frusturating two days trying to figure this problem out and being unable to install Catalyst because it kept detecting a previous fglrx driver when I had already removed and purged it I decided to reformat (it was a new install anyway) and start from scratch. Before even installing a driver I followed the instructions to install the sna driver and then I installed the latest catalyst and everything now works. The only thing is that I have to run Unity 2D when on the integrated chip. I can definitely live with this as long as it solves my overheating issue.
    I have an hp dv6-6023TX with i5-2410m intel HD3000 and AMD Radeon HD 6700M Series.
    I screwed around for a looong time with the catalyst driver.
    My experience is that it is buggy and that I didn't need all that performance.
    I just wanted to get rid of the overheating and the fans running fast.
    Now I just use the intel HD3000. It runs really cool (fan just running @51celsius).
    As far as I can tell everything seem to work as it should (effects hd videos no artifacts).
    I can get about 5-6hours battery time (usually about 12-18watts consumption, the lowest I got it was 9.4watts)
    Anyway I suggest you give this a go: http://ubuntuforums.org/showthread.php?t=1917897

  3. #73
    Join Date
    Mar 2012
    Beans
    15

    Re: AMD/Intel Hybrid Graphics works !

    try post#9 in this thread:

    http://ubuntuforums.org/showthread.p...5#post11780425

    i have bastardised a script that allows you to switch between integrated and discrete, if you want to use the discrete for gaming.

    good luck

  4. #74
    Join Date
    Oct 2007
    Beans
    24

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by jonnyboysmithy View Post
    I have an hp dv6-6023TX with i5-2410m intel HD3000 and AMD Radeon HD 6700M Series.
    I screwed around for a looong time with the catalyst driver.
    My experience is that it is buggy and that I didn't need all that performance.
    I just wanted to get rid of the overheating and the fans running fast.
    Now I just use the intel HD3000. It runs really cool (fan just running @51celsius).
    As far as I can tell everything seem to work as it should (effects hd videos no artifacts).
    I can get about 5-6hours battery time (usually about 12-18watts consumption, the lowest I got it was 9.4watts)
    Anyway I suggest you give this a go: http://ubuntuforums.org/showthread.php?t=1917897
    Is there a benefit to doing this as opposed to just running the Integrated Chip with Catalyst? I really have no need for the discrete chip. Any gaming or heavy duty computing I do on my powerful desktop. I just use this laptop to develop and get a little work done.

  5. #75
    Join Date
    Dec 2011
    Beans
    19

    Re: AMD/Intel Hybrid Graphics works !

    I posted this in another thread and I don't like posting multiple times, but I hit the wrong prefix, so I don't know if it is getting the right people to see, so I thought I would post it here to see if anyone can help because it seems like I am getting somewhere. (warning wall of text inc)

    After failing to get my discreet GPU working in ubuntu 11.10 I decided to install 12.04 to see if it was working and I believe I am getting somewhere with it.

    I installed the fglrx drivers through jockey and ran
    Code:
    aticonfig  --initial -f
    However it came up with this powerXpress error:

    Code:
    PowerXpress error: Cannot stat '/usr/lib64/fglrx': No such file or directory
    Failed to initialize libglx for discrete GPU
    I however ignored this and rebooted, and rather than completely failing to boot it boots to low graphics mode (which is progress) but I cannot configure my graphics adapter and screen,

    Here are my xorg.conf and my xorg.0.log files:

    Code:
    Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Module"
    EndSection
    
    Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option        "VendorName" "ATI Proprietary Driver"
        Option        "ModelName" "Generic Autodetecting Monitor"
        Option        "DPMS" "true"
    EndSection
    
    Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
            Viewport   0 0
            Depth     24
        EndSubSection
    EndSection
    Code:
    [    15.420] 
    X.Org X Server 1.11.3
    Release Date: 2011-12-16
    [    15.420] X Protocol Version 11, Revision 0
    [    15.420] Build Operating System: Linux 2.6.24-29-server x86_64 Ubuntu
    [    15.420] Current Operating System: Linux mike-ubuntu 3.2.0-17-generic #27-Ubuntu SMP Fri Feb 24 15:37:36 UTC 2012 x86_64
    [    15.420] Kernel command line:  BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic  root=UUID=ff081b73-4bb3-4c52-8153-e789022d6a06 ro quiet splash  vt.handoff=7
    [    15.420] Build Date: 22 February 2012  03:16:54AM
    [    15.420] xorg-server 2:1.11.4-0ubuntu4 (For technical support please see http://www.ubuntu.com/support) 
    [    15.420] Current version of pixman: 0.24.4
    [    15.420]     Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [    15.420] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [    15.420] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Mar 21 20:44:20 2012
    [    15.420] (==) Using config file: "/etc/X11/xorg.conf"
    [    15.420] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [    15.421] (==) ServerLayout "aticonfig Layout"
    [    15.421] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
    [    15.421] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
    [    15.421] (**) |   |-->Device "aticonfig-Device[0]-0"
    [    15.421] (==) Automatically adding devices
    [    15.421] (==) Automatically enabling devices
    [    15.421] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [    15.421]     Entry deleted from font path.
    [    15.421] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    [    15.421]     Entry deleted from font path.
    [    15.421] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [    15.421]     Entry deleted from font path.
    [    15.421] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    [    15.421]     Entry deleted from font path.
    [    15.421] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [    15.421]     Entry deleted from font path.
    [    15.429] (WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType".
    [    15.429]     Entry deleted from font path.
    [    15.429]     (Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType").
    [    15.429] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/Type1,
        built-ins
    [    15.429] (==) ModulePath set to  "/usr/lib/x86_64-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    [    15.429] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
    [    15.429] (II) Loader magic: 0x7f40d6b22b00
    [    15.429] (II) Module ABI versions:
    [    15.429]     X.Org ANSI C Emulation: 0.4
    [    15.429]     X.Org Video Driver: 11.0
    [    15.429]     X.Org XInput driver : 16.0
    [    15.429]     X.Org Server Extension : 6.0
    [    15.431] (--) PCI:*(0:0:2:0) 8086:0046:103c:144a rev 2, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00005050/8
    [    15.431] (--) PCI: (0:1:0:0) 1002:68e0:103c:144a rev 0, Mem @  0xa0000000/268435456, 0xc4400000/131072, I/O @ 0x00004000/256, BIOS @  0x????????/131072
    [    15.431] (II) Open ACPI successful (/var/run/acpid.socket)
    [    15.431] (II) "extmod" will be loaded by default.
    [    15.431] (II) "dbe" will be loaded by default.
    [    15.431] (II) "glx" will be loaded by default.
    [    15.431] (II) "record" will be loaded by default.
    [    15.431] (II) "dri" will be loaded by default.
    [    15.431] (II) "dri2" will be loaded by default.
    [    15.431] (II) LoadModule: "extmod"
    [    15.448] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    [    15.448] (II) Module extmod: vendor="X.Org Foundation"
    [    15.448]     compiled for 1.11.3, module version = 1.0.0
    [    15.448]     Module class: X.Org Server Extension
    [    15.448]     ABI class: X.Org Server Extension, version 6.0
    [    15.448] (II) Loading extension MIT-SCREEN-SAVER
    [    15.448] (II) Loading extension XFree86-VidModeExtension
    [    15.448] (II) Loading extension XFree86-DGA
    [    15.448] (II) Loading extension DPMS
    [    15.448] (II) Loading extension XVideo
    [    15.448] (II) Loading extension XVideo-MotionCompensation
    [    15.448] (II) Loading extension X-Resource
    [    15.448] (II) LoadModule: "dbe"
    [    15.448] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    [    15.448] (II) Module dbe: vendor="X.Org Foundation"
    [    15.449]     compiled for 1.11.3, module version = 1.0.0
    [    15.449]     Module class: X.Org Server Extension
    [    15.449]     ABI class: X.Org Server Extension, version 6.0
    [    15.449] (II) Loading extension DOUBLE-BUFFER
    [    15.449] (II) LoadModule: "glx"
    [    15.449] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/extensions/libglx.so
    [    15.449] (II) Module glx: vendor="Advanced Micro Devices, Inc."
    [    15.449]     compiled for 6.9.0, module version = 1.0.0
    [    15.449] (II) Loading extension GLX
    [    15.449] (II) LoadModule: "record"
    [    15.449] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    [    15.449] (II) Module record: vendor="X.Org Foundation"
    [    15.449]     compiled for 1.11.3, module version = 1.13.0
    [    15.449]     Module class: X.Org Server Extension
    [    15.449]     ABI class: X.Org Server Extension, version 6.0
    [    15.449] (II) Loading extension RECORD
    [    15.449] (II) LoadModule: "dri"
    [    15.449] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    [    15.449] (II) Module dri: vendor="X.Org Foundation"
    [    15.449]     compiled for 1.11.3, module version = 1.0.0
    [    15.449]     ABI class: X.Org Server Extension, version 6.0
    [    15.449] (II) Loading extension XFree86-DRI
    [    15.449] (II) LoadModule: "dri2"
    [    15.450] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    [    15.450] (II) Module dri2: vendor="X.Org Foundation"
    [    15.450]     compiled for 1.11.3, module version = 1.2.0
    [    15.450]     ABI class: X.Org Server Extension, version 6.0
    [    15.450] (II) Loading extension DRI2
    [    15.450] (II) LoadModule: "fglrx"
    [    15.450] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/drivers/fglrx_drv.so
    [    15.728] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    [    15.740]     compiled for 1.4.99.906, module version = 8.91.4
    [    15.740]     Module class: X.Org Video Driver
    [    15.826] (II) Loading sub module "fglrxdrm"
    [    15.826] (II) LoadModule: "fglrxdrm"
    [    15.826] (II) Loading /usr/lib/x86_64-linux-gnu/xorg/extra-modules/extra-modules.dpkg-tmp/modules/linux/libfglrxdrm.so
    [    15.850] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    [    15.850]     compiled for 1.4.99.906, module version = 8.91.4
    [    15.850] (II) ATI Proprietary Linux Driver Version Identifier:8.91.4
    [    15.850] (II) ATI Proprietary Linux Driver Release Identifier: 8.911                                
    [    15.850] (II) ATI Proprietary Linux Driver Build Date: Oct 25 2011 21:24:13
    [    15.850] (++) using VT number 7
    
    [    15.851] (WW) Falling back to old probe method for fglrx
    [    15.931] (II) Loading PCS database from /etc/ati/amdpcsdb
    [    15.952] (--) Chipset Supported AMD Graphics Processor (0x68E0) found
    [    15.958] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
    [    15.958] (II) fglrx: intel VGA device detected, load intel driver.
    [    15.958] (II) LoadModule: "intel"
    [    15.958] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [    15.958] (II) Module intel: vendor="X.Org Foundation"
    [    15.958]     compiled for 1.11.3, module version = 2.17.0
    [    15.958]     Module class: X.Org Video Driver
    [    15.958]     ABI class: X.Org Video Driver, version 11.0
    [    15.960] ukiDynamicMajor: found major device number 249
    [    15.960] ukiDynamicMajor: found major device number 249
    [    15.960] ukiOpenByBusid: Searching for BusID PCI:1:0:0
    [    15.960] ukiOpenDevice: node name is /dev/ati/card0
    [    15.960] ukiOpenDevice: open result is 11, (OK)
    [    15.960] ukiOpenByBusid: ukiOpenMinor returns 11
    [    15.960] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
    [    15.971] (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.
    [    15.971] (EE) No devices detected.
    [    15.971] (==) Matched intel as autoconfigured driver 0
    [    15.971] (==) Matched vesa as autoconfigured driver 1
    [    15.971] (==) Matched fbdev as autoconfigured driver 2
    [    15.971] (==) Assigned the driver to the xf86ConfigLayout
    [    15.971] (II) LoadModule: "intel"
    [    15.971] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [    15.971] (II) Module intel: vendor="X.Org Foundation"
    [    15.971]     compiled for 1.11.3, module version = 2.17.0
    [    15.971]     Module class: X.Org Video Driver
    [    15.971]     ABI class: X.Org Video Driver, version 11.0
    [    15.971] (II) UnloadModule: "intel"
    [    15.971] (II) Unloading intel
    [    15.971] (II) Failed to load module "intel" (already loaded, 32576)
    [    15.971] (II) LoadModule: "vesa"
    [    15.971] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [    15.972] (II) Module vesa: vendor="X.Org Foundation"
    [    15.972]     compiled for 1.11.3, module version = 2.3.0
    [    15.972]     Module class: X.Org Video Driver
    [    15.972]     ABI class: X.Org Video Driver, version 11.0
    [    15.972] (II) LoadModule: "fbdev"
    [    15.972] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [    15.972] (II) Module fbdev: vendor="X.Org Foundation"
    [    15.972]     compiled for 1.11.3, module version = 0.4.2
    [    15.972]     ABI class: X.Org Video Driver, version 11.0
    [    15.972] (II) ATI Proprietary Linux Driver Version Identifier:8.91.4
    [    15.972] (II) ATI Proprietary Linux Driver Release Identifier: 8.911                                
    [    15.972] (II) ATI Proprietary Linux Driver Build Date: Oct 25 2011 21:24:13
    [    15.972] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
        i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
        E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
        965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
        4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
        Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
        Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
        Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
        Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
        Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server
    [    15.972] (II) VESA: driver for VESA chipsets: vesa
    [    15.972] (II) FBDEV: driver for framebuffer: fbdev
    [    15.972] (++) using VT number 7
    
    [    15.972] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
    [    15.972] (WW) xf86OpenConsole: setsid failed: Operation not permitted
    [    15.972] (WW) Falling back to old probe method for fglrx
    [    15.972] (II) Loading PCS database from /etc/ati/amdpcsdb
    [    15.972] (WW) Falling back to old probe method for vesa
    [    15.972] (WW) Falling back to old probe method for fbdev
    [    15.972] (EE) No devices detected.
    [    15.972] 
    Fatal server error:
    [    15.972] no screens found
    [    15.972] 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [    15.972] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [    15.972]
    Also here is my lshw -C -video output

    Code:
    *-display               
           description: VGA compatible controller
           product: Manhattan [Mobility Radeon HD 5400 Series]
           vendor: Hynix Semiconductor (Hyundai Electronics)
           physical id: 0
           bus info: pci@0000:01:00.0
           version: 00
           width: 64 bits
           clock: 33MHz
           capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
           configuration: driver=fglrx_pci latency=0
           resources: irq:16 memory:a0000000-afffffff memory:c4400000-c441ffff ioport:4000(size=256) memory:c4440000-c445ffff
      *-display
           description: VGA compatible controller
           product: Core Processor Integrated Graphics Controller
           vendor: Intel Corporation
           physical id: 2
           bus info: pci@0000:00:02.0
           version: 02
           width: 64 bits
           clock: 33MHz
           capabilities: msi pm vga_controller bus_master cap_list rom
           configuration: driver=i915 latency=0
           resources: irq:44 memory:c0000000-c03fffff memory:b0000000-bfffffff ioport:5050(size=8)
    Any help to get this working will be appreciated.

  6. #76
    Join Date
    Mar 2012
    Beans
    1

    Re: AMD/Intel Hybrid Graphics works !

    Running on a fresh 12.04 Daily Build.
    PPAs added.

    Won't boot X with the following settings.

    xorg.conf
    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[0]-0" 0 0
    EndSection
    
    Section "Module"
    EndSection
    
    Section "Monitor"
    	Identifier   "aticonfig-Monitor[0]-0"
    	Option	    "VendorName" "ATI Proprietary Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    EndSection
    
    Section "Device"
    	Identifier  "aticonfig-Device[0]-0"
    	Driver      "fglrx"
    	#BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
    	Identifier "aticonfig-Screen[0]-0"
    	Device     "aticonfig-Device[0]-0"
    	Monitor    "aticonfig-Monitor[0]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    xorg.log.0
    Code:
    [     5.767] 
    X.Org X Server 1.12.0
    Release Date: 2012-03-04
    [     5.767] X Protocol Version 11, Revision 0
    [     5.767] Build Operating System: Linux 2.6.24-30-xen i686 Ubuntu
    [     5.767] Current Operating System: Linux werbeboten-HP-Pavilion-g6-Notebook-PC 3.2.0-20-generic-pae #32-Ubuntu SMP Thu Mar 22 02:43:40 UTC 2012 i686
    [     5.767] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic-pae root=UUID=cd51926a-213f-455e-bed3-9e4a2e522a22 ro quiet splash vt.handoff=7
    [     5.767] Build Date: 08 March 2012  07:07:08AM
    [     5.767] xorg-server 2:1.12.0+git20120308+server-1.12-branch.b1be72c5-0ubuntu0ricotz (For technical support please see http://www.ubuntu.com/support) 
    [     5.767] Current version of pixman: 0.25.2
    [     5.767] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [     5.767] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [     5.767] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Mar 23 01:43:49 2012
    [     5.768] (==) Using config file: "/etc/X11/xorg.conf"
    [     5.768] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [     5.768] (==) ServerLayout "aticonfig Layout"
    [     5.768] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
    [     5.768] (**) |   |-->Monitor "aticonfig-Monitor[0]-0"
    [     5.769] (**) |   |-->Device "aticonfig-Device[0]-0"
    [     5.769] (==) Automatically adding devices
    [     5.769] (==) Automatically enabling devices
    [     5.769] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [     5.769] 	Entry deleted from font path.
    [     5.769] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    [     5.769] 	Entry deleted from font path.
    [     5.769] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [     5.769] 	Entry deleted from font path.
    [     5.769] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    [     5.769] 	Entry deleted from font path.
    [     5.769] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [     5.769] 	Entry deleted from font path.
    [     5.773] (WW) `fonts.dir' not found (or not valid) in "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType".
    [     5.773] 	Entry deleted from font path.
    [     5.773] 	(Run 'mkfontdir' on "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType").
    [     5.773] (==) FontPath set to:
    	/usr/share/fonts/X11/misc,
    	/usr/share/fonts/X11/Type1,
    	built-ins
    [     5.773] (==) ModulePath set to "/usr/lib/i386-linux-gnu/xorg/extra-modules,/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
    [     5.773] (II) The server relies on udev to provide the list of input devices.
    	If no devices become available, reconfigure udev or disable AutoAddDevices.
    [     5.773] (II) Loader magic: 0xb778d5a0
    [     5.773] (II) Module ABI versions:
    [     5.773] 	X.Org ANSI C Emulation: 0.4
    [     5.773] 	X.Org Video Driver: 12.0
    [     5.773] 	X.Org XInput driver : 16.0
    [     5.773] 	X.Org Server Extension : 6.0
    [     5.775] (--) PCI:*(0:0:2:0) 8086:0046:103c:1669 rev 2, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00006050/8
    [     5.775] (--) PCI: (0:1:0:0) 1002:6760:103c:1669 rev 0, Mem @ 0xa0000000/268435456, 0xc6400000/131072, I/O @ 0x00005000/256, BIOS @ 0x????????/131072
    [     5.775] (II) Open ACPI successful (/var/run/acpid.socket)
    [     5.775] (II) "extmod" will be loaded by default.
    [     5.775] (II) "dbe" will be loaded by default.
    [     5.775] (II) "glx" will be loaded by default.
    [     5.775] (II) "record" will be loaded by default.
    [     5.775] (II) "dri" will be loaded by default.
    [     5.775] (II) "dri2" will be loaded by default.
    [     5.775] (II) LoadModule: "extmod"
    [     5.779] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
    [     5.779] (II) Module extmod: vendor="X.Org Foundation"
    [     5.779] 	compiled for 1.12.0, module version = 1.0.0
    [     5.779] 	Module class: X.Org Server Extension
    [     5.779] 	ABI class: X.Org Server Extension, version 6.0
    [     5.779] (II) Loading extension MIT-SCREEN-SAVER
    [     5.779] (II) Loading extension XFree86-VidModeExtension
    [     5.779] (II) Loading extension XFree86-DGA
    [     5.779] (II) Loading extension DPMS
    [     5.779] (II) Loading extension XVideo
    [     5.779] (II) Loading extension XVideo-MotionCompensation
    [     5.779] (II) Loading extension X-Resource
    [     5.779] (II) LoadModule: "dbe"
    [     5.780] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
    [     5.780] (II) Module dbe: vendor="X.Org Foundation"
    [     5.780] 	compiled for 1.12.0, module version = 1.0.0
    [     5.780] 	Module class: X.Org Server Extension
    [     5.780] 	ABI class: X.Org Server Extension, version 6.0
    [     5.780] (II) Loading extension DOUBLE-BUFFER
    [     5.780] (II) LoadModule: "glx"
    [     5.780] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/modules/extensions/libglx.so
    [     5.781] (II) Module glx: vendor="Advanced Micro Devices, Inc."
    [     5.781] 	compiled for 6.9.0, module version = 1.0.0
    [     5.781] (II) Loading extension GLX
    [     5.781] (II) LoadModule: "record"
    [     5.788] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
    [     5.788] (II) Module record: vendor="X.Org Foundation"
    [     5.788] 	compiled for 1.12.0, module version = 1.13.0
    [     5.788] 	Module class: X.Org Server Extension
    [     5.788] 	ABI class: X.Org Server Extension, version 6.0
    [     5.788] (II) Loading extension RECORD
    [     5.788] (II) LoadModule: "dri"
    [     5.789] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
    [     5.789] (II) Module dri: vendor="X.Org Foundation"
    [     5.789] 	compiled for 1.12.0, module version = 1.0.0
    [     5.789] 	ABI class: X.Org Server Extension, version 6.0
    [     5.789] (II) Loading extension XFree86-DRI
    [     5.789] (II) LoadModule: "dri2"
    [     5.790] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
    [     5.790] (II) Module dri2: vendor="X.Org Foundation"
    [     5.790] 	compiled for 1.12.0, module version = 1.2.0
    [     5.790] 	ABI class: X.Org Server Extension, version 6.0
    [     5.790] (II) Loading extension DRI2
    [     5.790] (II) LoadModule: "fglrx"
    [     5.790] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so
    [     5.857] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    [     5.858] 	compiled for 1.4.99.906, module version = 8.95.3
    [     5.858] 	Module class: X.Org Video Driver
    [     5.859] (II) Loading sub module "fglrxdrm"
    [     5.859] (II) LoadModule: "fglrxdrm"
    [     5.860] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/modules/linux/libfglrxdrm.so
    [     5.861] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    [     5.861] 	compiled for 1.4.99.906, module version = 8.95.3
    [     5.861] (II) ATI Proprietary Linux Driver Version Identifier:8.95.3
    [     5.862] (II) ATI Proprietary Linux Driver Release Identifier: 8.95                                 
    [     5.862] (II) ATI Proprietary Linux Driver Build Date: Feb 14 2012 21:04:52
    [     5.862] (++) using VT number 7
    
    [     5.862] (WW) Falling back to old probe method for fglrx
    [     5.902] (II) Loading PCS database from /etc/ati/amdpcsdb
    [     5.905] (--) Chipset Supported AMD Graphics Processor (0x6760) found
    [     5.905] (II) fglrx: intel VGA device detected, load intel driver.
    [     5.905] (II) LoadModule: "intel"
    [     5.906] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [     5.906] (II) Module intel: vendor="X.Org Foundation"
    [     5.906] 	compiled for 1.12.0, module version = 2.18.0
    [     5.906] 	Module class: X.Org Video Driver
    [     5.906] 	ABI class: X.Org Video Driver, version 12.0
    [     5.909] ukiDynamicMajor: failed to open /proc/ati/major
    [     5.909] ukiDynamicMajor: failed to open /proc/ati/major
    [     5.910] (WW) PowerXpress feature is not supported
    [     5.910] (EE) No devices detected.
    [     5.910] (==) Matched intel as autoconfigured driver 0
    [     5.910] (==) Matched vesa as autoconfigured driver 1
    [     5.910] (==) Matched fbdev as autoconfigured driver 2
    [     5.910] (==) Assigned the driver to the xf86ConfigLayout
    [     5.910] (II) LoadModule: "intel"
    [     5.911] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [     5.911] (II) Module intel: vendor="X.Org Foundation"
    [     5.911] 	compiled for 1.12.0, module version = 2.18.0
    [     5.911] 	Module class: X.Org Video Driver
    [     5.911] 	ABI class: X.Org Video Driver, version 12.0
    [     5.911] (II) UnloadModule: "intel"
    [     5.911] (II) Unloading intel
    [     5.911] (II) Failed to load module "intel" (already loaded, -1217056484)
    [     5.911] (II) LoadModule: "vesa"
    [     5.912] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [     5.912] (II) Module vesa: vendor="X.Org Foundation"
    [     5.912] 	compiled for 1.11.99.901, module version = 2.3.0
    [     5.912] 	Module class: X.Org Video Driver
    [     5.912] 	ABI class: X.Org Video Driver, version 12.0
    [     5.912] (II) LoadModule: "fbdev"
    [     5.912] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [     5.913] (II) Module fbdev: vendor="X.Org Foundation"
    [     5.913] 	compiled for 1.11.99.901, module version = 0.4.2
    [     5.913] 	Module class: X.Org Video Driver
    [     5.913] 	ABI class: X.Org Video Driver, version 12.0
    [     5.913] (II) ATI Proprietary Linux Driver Version Identifier:8.95.3
    [     5.913] (II) ATI Proprietary Linux Driver Release Identifier: 8.95                                 
    [     5.913] (II) ATI Proprietary Linux Driver Build Date: Feb 14 2012 21:04:52
    [     5.913] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
    	i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
    	E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
    	965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
    	4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
    	Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
    	Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
    	Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
    	Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
    	Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server
    [     5.914] (II) VESA: driver for VESA chipsets: vesa
    [     5.914] (II) FBDEV: driver for framebuffer: fbdev
    [     5.914] (++) using VT number 7
    
    [     5.914] (WW) xf86OpenConsole: setpgid failed: Operation not permitted
    [     5.914] (WW) xf86OpenConsole: setsid failed: Operation not permitted
    [     5.914] (WW) Falling back to old probe method for fglrx
    [     5.914] (II) Loading PCS database from /etc/ati/amdpcsdb
    [     5.914] (WW) Falling back to old probe method for vesa
    [     5.914] (WW) Falling back to old probe method for fbdev
    [     5.914] (EE) No devices detected.
    [     5.914] 
    Fatal server error:
    [     5.914] no screens found
    [     5.914] 
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    [     5.914] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [     5.914]

    lspci | grep VGA
    Code:
    00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02)
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Seymour [Radeon HD 6400M Series]

    Somehow, this looks strange in log:

    Code:
    [     5.859] (II) LoadModule: "fglrxdrm"
    [     5.860] (II) Loading /usr/lib/i386-linux-gnu/xorg/extra-modules/modules/linux/libfglrxdrm.so
    [     5.861] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    [     5.861] 	compiled for 1.4.99.906, module version = 8.95.3
    [     5.861] (II) ATI Proprietary Linux Driver Version Identifier:8.95.3
    [     5.862] (II) ATI Proprietary Linux Driver Release Identifier: 8.95                                 
    [     5.862] (II) ATI Proprietary Linux Driver Build Date: Feb 14 2012 21:04:52
    [     5.862] (++) using VT number 7
    
    [     5.862] (WW) Falling back to old probe method for fglrx
    Any ideas?

    UPDATE:
    http://forums.fedoraforum.org/showthread.php?p=1564578

    uname -r
    Code:
    3.2.0-20-generic-pae
    Got this warning too.
    Will try a fresh install on 11.10 for testing purposes tomorrow.
    Last edited by Deradon; March 23rd, 2012 at 03:06 AM.

  7. #77
    Join Date
    Feb 2012
    Beans
    27

    Re: AMD/Intel Hybrid Graphics works !

    Hi people! I'm trying to get my new notebook working. I have a Intel hd3000 + amd radeon 6750M and I installed ubuntu precise. I added sarvatt ppa (xserver-xorg-video-intel 2.18) than I tried installing ati driver. Here is the problem, because with jokey-gtk I can install only the non-post-release driver,if I try installing the post release version it creashes (I found the bug also in launchpad). I tried compiling the driver downloaded from amd site, but when I try to install them through dpkg I give dependency error referred to the other packages I want to install.
    Then I tried installing fglrx-updates through synaptic and terminal. I can install the driver, give the aticonfig --install -f command but when I reboot (without any switch) a window appear saying me that ubuntu is running in low-graphic mode. After reconfiguring lightdm starts again.
    Furthermore I can't get Catalyst Control Center working. Any suggestion for the ati driver installation?

  8. #78
    Join Date
    Dec 2011
    Beans
    19

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by pinguinhood View Post
    Hi people! I'm trying to get my new notebook working. I have a Intel hd3000 + amd radeon 6750M and I installed ubuntu precise. I added sarvatt ppa (xserver-xorg-video-intel 2.18) than I tried installing ati driver. Here is the problem, because with jokey-gtk I can install only the non-post-release driver,if I try installing the post release version it creashes (I found the bug also in launchpad). I tried compiling the driver downloaded from amd site, but when I try to install them through dpkg I give dependency error referred to the other packages I want to install.
    Then I tried installing fglrx-updates through synaptic and terminal. I can install the driver, give the aticonfig --install -f command but when I reboot (without any switch) a window appear saying me that ubuntu is running in low-graphic mode. After reconfiguring lightdm starts again.
    Furthermore I can't get Catalyst Control Center working. Any suggestion for the ati driver installation?
    Its what we are trying to work out right now, from what I have seen even the Linux gurus are having problems with Intel/ATI hybrid graphics.

  9. #79
    Join Date
    Jul 2011
    Beans
    17

    Re: AMD/Intel Hybrid Graphics works !

    is the hybrid graphics problem is over ?
    when it complete ? id their any changes in the new ubuntu 12.04

  10. #80
    Join Date
    Sep 2011
    Beans
    2

    Re: AMD/Intel Hybrid Graphics works !

    I can confirm that following these instructions I was able to get Hybrid graphics on my Sony S VPCSA! Excellent! Of course, ATI graphics card gobbles up over TWICE the power than the integrated (~24-26k mW vs ~8-12k mW.)

    I was able to follow the same procedure on Linux Mint and got very good results, in fact faster and smoother than those that I got in Ubuntu 12.04 (which, granted is in Beta.)

    One problem I notice, at least with my linux Mint build (haven't confirmed on Ubuntu 12.04) if I try to switch to integrated graphics and restart X, it logs in fine, but doesn't bring up my gnome 3 panels, it seems something hangs up around then. I change back to dedicated and restart and it works fine again :-\.

    delsus: Not sure if you're still having this problem... I had a very similar problem. I had to follow Alexislavie's post on installing the newest drivers here: http://wiki.cchtml.com/index.php/Ubu...allation_Guide after installing the PPAs and that seemed to work.

Page 8 of 88 FirstFirst ... 6789101858 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •