Page 61 of 86 FirstFirst ... 1151596061626371 ... LastLast
Results 601 to 610 of 859

Thread: AMD/Intel Hybrid Graphics works

  1. #601
    Join Date
    Dec 2012
    Location
    Ringsted, Denmark
    Beans
    51
    Distro
    Kubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works

    Quote Originally Posted by jayeshsan View Post
    Hi,

    I've Dell Vostro 1540 laptop with Ubuntu 12.10 installed. Its working fine but not good with hi-res images. Is there any graphic driver available ?
    You've posted in the wrong thread. The Dell Vostro 1540 comes with Intel HD graphics only, with no "Discrete Graphics" to switch to when the need arises.

    So, my guess is that the proper driver is already loaded by Ubuntu.

    Note, Intel HD-graphics, despite its name, is not as feature-rich as dedicated GPU's from AMD or Nvidia, so expect some rough edges here and there.

  2. #602
    Join Date
    Jul 2008
    Beans
    223

    Re: AMD/Intel Hybrid Graphics works

    Quote Originally Posted by LarcBP View Post
    Dell N4110 14R
    Processor: Intel I5
    Graphics: ATi Radeon 6470M & Intel HD Graphics 3000

    I tested all drivers and tried with PPA's and another solutions.
    The only real solution for me is the last Catalyst (12.10) after install this and switch to Discrete Graphics (because when you reboot you get a shell, you need switch the graphics and restart
    Can you be more specific which ppa's you used, which Intel-xorg-video thing, what aticonfig command you used to switch to the discrete card, and any other specific info to help my 13 month dilemma being stuck in windows with my Intel HD 3000, and ATI Radeon 6850m.

    Every combination of (ubuntu distro, catalyst driver version, intel ppa, and "andrikos' patched fglrx and intel packages", Discrete or Integrated on/off), I have tried with have always resulted in a fail to start X.

    Please Help HP SUCKS

    Thanks Mark

  3. #603
    Join Date
    Jul 2008
    Beans
    223

    Re: AMD/Intel Hybrid Graphics works !

    Wegah, Thanks -
    - for clarifying yet again HP SUCKS !!

    Any help getting my HP Envy 17 running with Ubuntu would be much appreciated,

    Cheers, Mark

    Quote Originally Posted by wegah View Post
    You are wrong.
    Muxless systems use the same output hardware ( most the intel base) and just switch the processor ( being short).

    The manufaturer bios can do 3 kinds of choices when build the bios.

    ... .... ....

    About HP.
    Just computer with the ADVANCED OPTIONS in bios can do it. From second generation envy 17 and ahead is a nono.

    HP was very clear about this. They release this devices for windows not linux. they will not give support for windows.
    And same in windows windows 8 users or windows 7 already have big troubles with muxless drivers ( they how usual leave all second generation users stuck with old drivers and the 3 generation have problems).

    OBS. After they do this official statement about non windows. They released all bios not single signed ( for non hack mods). But they double and tripled signed the files Just to be certain of no one will open this options under bios.
    Like the UEFI mode enable disable. We have an expensive hp and intel chipset but we barely can change the date.

    Most of well coded expensive non mainstreamer notebooks have do have this choice.

    And believe you. the low end ones from china. the plastic ones. All have this options to. The bios most of time is full filled with choices.

    Mine mum use a chinese low end one with almost the same configuration from mine 2100cto. All plastic, all simples. But she can switch to UEFI mode and the default output path for video cards in bios. The i7, intel, amd card are exact the same.
    I even can install macosx almost 100% out of box. Minor glitches with wifi just.

    HP is a ****.

  4. #604
    Join Date
    Oct 2012
    Beans
    32

    Re: AMD/Intel Hybrid Graphics works !

    1. Ubuntu 12.04
    2. Toshiba
    3. Toshiba Satellite L850-18T
    4. I recently bought notebook Toshiba Satellite l850-18t - SPECS and i have problem with 2 usb ports, i think with 2 usb 3.0 porst on the left side and with drivers for my ati radeon 7670m.

    1. Only 1 usb port works, and other 2 on the left side dont work neither with 2.0 or 3.0 usb drives... When i plug-in usb nothing happen...

    2. I cant find drivers for my graphic card and linux finds some for ati radeon 6*** older version...


    please help me

    any help for my toshiba with amd 7670m and intel i5???

  5. #605
    Join Date
    Dec 2012
    Location
    Ringsted, Denmark
    Beans
    51
    Distro
    Kubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Mijuca View Post
    1. Ubuntu 12.04
    2. Toshiba
    3. Toshiba Satellite L850-18T
    4. I recently bought notebook Toshiba Satellite l850-18t - SPECS and i have problem with 2 usb ports, i think with 2 usb 3.0 porst on the left side and with drivers for my ati radeon 7670m.

    1. Only 1 usb port works, and other 2 on the left side dont work neither with 2.0 or 3.0 usb drives... When i plug-in usb nothing happen...

    2. I cant find drivers for my graphic card and linux finds some for ati radeon 6*** older version...


    please help me

    any help for my toshiba with amd 7670m and intel i5???
    With regards to the graphics, this will probably fit your needs:
    http://support.amd.com/us/gpudownloa...eon_linux.aspx
    See the first page of this thread on how to install the drivers.


    Maybe asking another question in the hardware-forum will get you help with your USB-troubles. This is, after all, a thread about hybrid graphics.

  6. #606
    Join Date
    Dec 2012
    Location
    Ringsted, Denmark
    Beans
    51
    Distro
    Kubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by markackerman8@gmail.com View Post
    Wegah, Thanks -
    HP SUCKS !!
    Yeah, I'm thinking, Asus maybe, next time I'm getting a laptop.

  7. #607
    Join Date
    Dec 2012
    Location
    Ringsted, Denmark
    Beans
    51
    Distro
    Kubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works

    Holy Crap!

    I gave a daily build of kubuntu 13.04 a spin, just to check it out.
    I decided to give it another shot at getting this hybrid graphics working and initially I figured the installation failed, mainly because installing the drivers resulted in a coredump, and well, bugger me with a fishfork, if I haven't got the "AMD - Testing Use Only" in the lower right corner of my screen. (I installed 12.11 beta)

    It runs like.. like something that doesn't run very well, but I can start CCC without any problems.

    Update: Well, I guess this explains a few things: In the background of the beta-logo, there's a crossed-out 3D, so I guess acceleration doesn't really work - but now there is a glimmer of hope.

    Screenshot: http://imgur.com/l9cED
    Last edited by MarcoDePollo; January 13th, 2013 at 10:15 AM. Reason: Update

  8. #608
    Join Date
    Dec 2012
    Location
    Ringsted, Denmark
    Beans
    51
    Distro
    Kubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works

    This just keeps getting better and better.

    There was an update to the Fglrx drivers, so I installed them directly from Ubuntu's repo and it's working. It's actually working.

    The logo in the bottom says "unsupported hardware" but CCC confirms it, as does fgl_glxgears, it's actually working.

    Here: have another screenshot http://imgur.com/YUHd4

    Edit: right, I had tried to install the fglrx-drivers from Ubuntu's repo, with the same result I got from AMD's betadrivers, but when I tried purging the drivers, they weren't installed. I guess they were after all. Looks like driver from Ubuntu is 12.9
    Last edited by MarcoDePollo; January 13th, 2013 at 12:29 PM.

  9. #609
    Join Date
    Dec 2012
    Location
    Ringsted, Denmark
    Beans
    51
    Distro
    Kubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works

    I've tried reinstalling a new "daily", just to see if the first success was a fluke. Installing fglrx still results in an error, but the result is the same, drivers are installed and running.

    aticonfig will report that no supported adapters are found, but cccle will list the card and relevant information.

    But, something happened on kernel-level, because my intel-graphics is no longer listed in lspci - and cccle mentions nothing of switchable graphics.

    sudo lspci
    00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
    00:01.1 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
    00:01.2 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
    00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
    00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
    00:1c.2 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 3 (rev b5)
    00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
    00:1c.6 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 7 (rev b5)
    00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
    00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
    00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
    00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
    00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler XT [AMD Radeon HD 6700M Series]
    01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
    09:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 3e)
    0a:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5209 PCI Express Card Reader (rev 01)
    10:00.0 Ethernet controller: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet (rev c0)
    11:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
    12:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

    Not that I'm complaining


    Oh, and:
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Whistler XT [AMD Radeon HD 6700M Series]
    Subsystem: Hewlett-Packard Company Device 1689
    Kernel driver in use: fglrx_pci
    Last edited by MarcoDePollo; January 15th, 2013 at 11:11 AM. Reason: lspci -k

  10. #610
    Join Date
    Dec 2012
    Location
    Ringsted, Denmark
    Beans
    51
    Distro
    Kubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works

    Removed fglrx and a subsequent reinstall:

    sudo apt-get install fglrx

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    fglrx-amdcccle
    The following NEW packages will be installed:
    fglrx fglrx-amdcccle
    0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0 B/86.4 MB of archives.
    After this operation, 257 MB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Selecting previously unselected package fglrx.
    (Reading database ... 108339 files and directories currently installed.)
    Unpacking fglrx (from .../fglrx_2%3a9.010-0ubuntu1_amd64.deb) ...
    Selecting previously unselected package fglrx-amdcccle.
    Unpacking fglrx-amdcccle (from .../fglrx-amdcccle_2%3a9.010-0ubuntu1_amd64.deb) ...
    Processing triggers for ureadahead ...
    ureadahead will be reprofiled on next reboot
    Setting up fglrx (2:9.010-0ubuntu1) ...
    update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode
    update-alternatives: warning: forcing reinstallation of alternative /usr/lib/fglrx/ld.so.conf because link group x86_64-linux-gnu_gl_conf is broken
    update-alternatives: using /usr/lib/fglrx/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode
    update-initramfs: deferring update (trigger activated)
    Loading new fglrx-9.010 DKMS files...
    Building only for 3.8.0-0-generic
    Building for architecture x86_64
    Building initial module for 3.8.0-0-generic
    Done.

    fglrx:
    Running module version sanity check.
    - Original module
    - No original module exists within this kernel
    - Installation
    - Installing to /lib/modules/3.8.0-0-generic/updates/dkms/

    depmod.....

    DKMS: install completed.
    update-initramfs: deferring update (trigger activated)
    Setting up fglrx-amdcccle (2:9.010-0ubuntu1) ...
    Processing triggers for initramfs-tools ...
    update-initramfs: Generating /boot/initrd.img-3.8.0-0-generic
    modprobe: ../tools/modprobe.c:550: print_action: Assertion `kmod_module_get_initstate(m) == KMOD_MODULE_BUILTIN' failed.
    Aborted (core dumped)
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place


    Post-reboot; Yup, still working, games run perfectly.
    Last edited by MarcoDePollo; January 15th, 2013 at 11:23 AM. Reason: update

Page 61 of 86 FirstFirst ... 1151596061626371 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •