Page 5 of 88 FirstFirst ... 345671555 ... LastLast
Results 41 to 50 of 875

Thread: AMD/Intel Hybrid Graphics works

  1. #41
    Join Date
    Mar 2011
    Location
    New Zealand
    Beans
    443
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Joe76000 View Post
    Hello Alexis,

    Keep going on and don't give up as a lot of people are more than interested by this hot topic.

    Thanks. Joe
    Yes thats me! I'm also stuck with these problems I would be very grateful+happy if it all worked properly.

    Roughly, my DV7 is running 10 to 15°C lower and the battery time is about double !
    Yea I'm still stuck with that issue. I'm getting about half battery life of what I would get in windows. :/

  2. #42
    Join Date
    Dec 2008
    Beans
    23

    Re: AMD/Intel Hybrid Graphics works !

    Sj3, by the view point of FUNCTIONALITY. If you buy a muxless card with gpu and discrete. The notebook will have full work. The only drawback is, the non use of the discrete one.

    By the investment side.
    Muxed ones, are PAST. MUXLESS are the present and future.

    We can't forgives that one of the problems with muxless cards are the fact of XORG/KERNEL and some EGOS cant be touched. Not only the fact of AMd or NVIDIA didn't release drivers for this cards..

    The facts is. This will be the future.
    Linux today, next 6 months, or next 2 years at last. will have full support for this.

    Then, If you buy a notebook with a intel gpu. will work well a lot. ( pity sandy bridge not be discernible). Just the discrete will have troubles. ( easy do disable ) and save battery.

    Of course. If you buy a WHITEBOOK kind like MSI ones that are NOT LOCKED at HELL LEVEL. You probably will have use of discrete card.

    By definition. All amd 60xx mobile and up are muxless.
    Want know if will work or not?
    Look at BIOS.IF you HAVE the option to choose discrete or GPU? ( YES WITH MUXLESS CARDS)
    Then, 90% of chance your notebook work well with discrete card, same being a muxless one under linux.

    Or buy one with just a discrete card...

    The option is your.

  3. #43
    Join Date
    Oct 2011
    Beans
    8

    Re: AMD/Intel Hybrid Graphics works !

    Thank you very much for your effort, OP. I have also been dealing with this problem for some time now. In fact, the lack of switchable graphics on my Ubuntu laptop is the only thing holding me back from fully enjoying having switched over to Linux.

    What I would like to ask you is whether your solution would also work with an AMD 5xxx / Intel configuration. (Acer 3820TG, AMD HD5650 and Intel Core i5-450m).

    Thanks again.

  4. #44
    Join Date
    Aug 2010
    Location
    Olivet, France
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: AMD/Intel Hybrid Graphics works !

    I forgot to mention :
    Please check the PCI adress in the xorg.conf generated (the line in red) and replace it if necessary by the adress this command outputs :
    echo "PCI:$(lspci | grep VGA | grep ATI | awk '{print $1}' | sed 's/\./:/')"
    Then switch to discrete GPU and reboot.

    Section "ServerLayout"
    Identifier "aticonfig Layout"
    Screen 0 "aticonfig-Screen[0]-0" 0 0
    EndSection

    Section "Module"
    EndSection

    Section "Monitor"
    Identifier "aticonfig-Monitor[0]-0"
    Option "VendorName" "ATI Proprietary Driver"
    Option "ModelName" "Generic Autodetecting Monitor"
    Option "DPMS" "true"
    EndSection

    Section "Device"
    Identifier "aticonfig-Device[0]-0"
    Driver "fglrx"
    BusID "PCI:1:0:0"
    EndSection

    Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device "aticonfig-Device[0]-0"
    Monitor "aticonfig-Monitor[0]-0"
    DefaultDepth 24
    SubSection "Display"
    Viewport 0 0
    Depth 24
    EndSubSection
    EndSection
    If the PCI adress isn't exact, then it is normal Xorg fails at start.
    I've seen many of you tried this on HP computers, did someone else than me tried it on a Dell ?
    Last edited by Alexislavie; March 5th, 2012 at 07:46 PM.

  5. #45
    Join Date
    Aug 2010
    Location
    Olivet, France
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: AMD/Intel Hybrid Graphics works !

    Please don't forget to tell your computer model, and the two drivers version. I used 2.17 for Intel and 12.1 for Catalyst. The actual version in the ppa is 2.18, so if it doesn't work with that one install 2.17 to give it a try : https://launchpad.net/~sarvatt/+arch...-archive-extra
    Download the i386 or amd64 package and install it manually.

  6. #46
    Join Date
    Feb 2012
    Beans
    27

    Re: AMD/Intel Hybrid Graphics works !

    Did anyone try it on Precise?

  7. #47
    Join Date
    Nov 2009
    Beans
    1

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by pinguinhood View Post
    Did anyone try it on Precise?
    I have tried with precise for the pass few days but with no luck.
    System: HP Pavilion dm4 i5 HD54xx with Ubuntu Precise-64bit

    Added the following repositories and do "sudo apt-get update"

    sudo add-apt-repository ppa: org-edgers/ppa
    sudo add-apt-repository ppa:sarvatt/intel-sna
    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates (no precise repository)

    The system installed with
    xserver-xorg-video-intel 2.18
    amd-driver-installer-12-1-x86.x86_64.run (installed with direct .run or convert to .deb packages - give the same results

    After the installationtion, have tried all the tests given in the link below and every things seems to work.
    http://wiki.cchtml.com/index.php/Ubu...allation_Guide

    But always get the following when check with fglrxinfo, I suppose it is correct since need to reboot to enable dgpu(but never success to boot properly)
    $ fglrxinfo
    display: :2.0 screen: 0
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
    OpenGL version string: 1.4 (3.0 Mesa 8.0)

    Also facing problem whenever I do "sudo aticonfig --px-dgpu, as it is looking for
    "/etc/OpenCL/vendors/amdocl32.icd' instead of "/etc/OpenCL/vendors/amdocl64.icd'

    Ignore the warning, and reboot system. System always hang. Has to go into recovery mode to
    remove the /etc/X11/xorg.conf

    Note: Recovery mode always set the mounted dev/sdax as read-only file system. so has to perform the following to find out the boot disk then remount it as rw:
    sudo fdisk -l
    sudo mount -o remount,rw /dev/sda8
    sudo rm /etc/X11/xorg.conf

    Right now without the ATI driver, xbmc Eden cannot work as it needs openGL. IGPU driver is no good for xbmc.

    Looking forward to Alexislavie to provide a solution.
    Last edited by cmeng; March 7th, 2012 at 09:29 AM.

  8. #48
    Join Date
    Mar 2012
    Beans
    1

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Alexislavie View Post
    Please don't forget to tell your computer model, and the two drivers version. I used 2.17 for Intel and 12.1 for Catalyst. The actual version in the ppa is 2.18, so if it doesn't work with that one install 2.17 to give it a try : https://launchpad.net/~sarvatt/+archive/intel-sna/+sourcepub/2245651/+listing-archive-extra
    Download the i386 or amd64 package and install it manually.
    Hi Alexislavie,

    I'm a french user too, and i'm sorry for my bad language in english.

    I posted too on your french topic, just in case.

    My laptop is a Sony Vaio SA2Z9E with this HW :

    Corei7
    Sandy Bridge
    Hybrid Integrated Intel Graphics HD 3000 + ATI Radeon HD6630M

    Ubuntu 11.10 Oneiric
    xserver-xorg-video-intel with -sna 2.17 from archives of ppa:sarvatt/intel-sna
    amd-ati-driver proprietary 12.1 compiled in .deb via this wiki


    So, i follow your guide step by step with no error until reboot my laptop at the end.

    Ubuntu start normaly with the boot animation and stop on a black screen, the series of ctrl+alt+f1 or ctrl+alt+backspace keys combinations doesn't work.

    i'm stuck on this black screen until i press on the power button, so the sequence to shutdown the laptop start and i see the ubuntu shutdown animation.

    If i start in recovery mode and look the logs :

    xorg.log --> no errors (EE)
    syslog --> "[Firmware Bug] : Duplicate ACPI video bus devices for the same VGA controller, please try module parameter "video.allow_duplicates=1" if the current driver doesn't work."




    After install of xserver-xorg-video-intel & ati driver proprietary, i generated the xorg.conf with "aticonfig --initial -f", no error.
    The BusID match with my HW "PCI:01:00:0"

    If i use fglrxinfo it's working and i see my sandy bridge HW
    I can switch between igpu and dgpu with aticonfig --px-igpu or aticonfig --px-dgpu

    but if i reboot after the end, i'm stuck on a black screen.

    Any idea ?

    Thx a lot


    EDIT :

    New : With the two command "sudo aticonfig --px-dgpu" or "sudo aticonfig --px-igpu" i have the same result for the commande "fglrxinfo"


    sudo aticonfig --px-dgpu
    PowerXpress: Discrete GPU is active (High-Performance Mode)

    fglrxinfo
    display: :0 screen: 0
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
    OpenGL version string: 1.4 (2.1 Mesa 7.11)
    sudo aticonfig --px-igpu
    PowerXpress info : Diagnostic output from /usr/lib64/fglrx/switchlibglx:
    update-alernatives: avertissement: création de /etc/OpenCL/vendors/amdocl32.icd abandonnée car le fichier associé /usr/lib/fglrx/etc/OpenCL/vendors/amdocl32.icd (du groupe de liens x86_64-linux-gnu_gl_conf) n'existe pas.

    PowerXpress : Integrated GPU is selected (Power-saving mode), please restart XServer for changes to take effect!



    fglrxinfo
    display: :0 screen: 0
    OpenGL vendor string: Tungsten Graphics, Inc
    OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
    OpenGL version string: 1.4 (2.1 Mesa 7.11)
    Attached Images Attached Images
    Last edited by clean31; March 7th, 2012 at 11:31 PM.

  9. #49
    Join Date
    Feb 2012
    Beans
    27

    Re: AMD/Intel Hybrid Graphics works !

    New Catalyst 12.2!

    Who's going to try it with hybrid graphics?! (I'm still waiting for new notebook, sigh )

  10. #50
    Join Date
    Feb 2012
    Beans
    4

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by pinguinhood View Post
    New Catalyst 12.2!

    Who's going to try it with hybrid graphics?! (I'm still waiting for new notebook, sigh )
    12.2 works good for me. HD3000/HD6770m using linux 3.3.0-rc7 and latest precise updates.
    I've tried to use xorg-edgers ppa without success (12.2 still doesnt support xserver 1.12). Haven't tried xf86-video-intel 2.18 yet but ubuntu's 2.17 works quite well and direct rendering now works.
    The only remaining problems I have are:

    - gnome-shell not starting automatically (from lightdm) on intel gpu, I have to manually start it from tty with :
    Code:
    DISPLAY=:0.0 gnome-shell --replace
    - random hard lockup when shutting down on ati gpu (most of the time after having played a bit): https://bugs.launchpad.net/ubuntu/+bug/750437

Page 5 of 88 FirstFirst ... 345671555 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •