Page 36 of 88 FirstFirst ... 2634353637384686 ... LastLast
Results 351 to 360 of 875

Thread: AMD/Intel Hybrid Graphics works

  1. #351
    Join Date
    Oct 2010
    Location
    Belo Horizonte, Brazil
    Beans
    75
    Distro
    Kubuntu 13.10 Saucy Salamander

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by ubik89 View Post
    No problems with 12.6 final and Intel HD 3000/Radeon HD 6450M.

    But I have to use this commands to switch:

    Code:
    sudo amdconfig --px-dgpu
    (switch to discrete)

    Code:
    amdconfig --px-igpu
    (switch to integrated)
    You can't switch using amdcccle? Because I can't switch with 12.6 beta. I can't believe that this problem wasn't fixed!

  2. #352
    Join Date
    Apr 2010
    Beans
    29

    Re: AMD/Intel Hybrid Graphics works !

    No, switching with amdcccle doesn't work. It's freezing my system.

  3. #353
    Join Date
    Oct 2010
    Location
    Belo Horizonte, Brazil
    Beans
    75
    Distro
    Kubuntu 13.10 Saucy Salamander

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by ubik89 View Post
    No, switching with amdcccle doesn't work. It's freezing my system.
    This is really strange. Coz I can switch from iGPU to dGPU but I cannot switch from dGPU to iGPU... probably something easy to figure out...

    I'll get some time to find this problem

  4. #354
    Join Date
    Jul 2012
    Beans
    4

    Re: AMD/Intel Hybrid Graphics works !

    First, Thanks very much for the great tutorial and you efforts here in the thread
    Second , I have a laptop hp probook 4530s with amd 6490 and intel 3000 I tried this tutorial and did it all step by step
    my problem is after running

    sudo aticonfig --initial -f
    then restart Ubuntu runs in the low graphics mode and i must reconfigure the grahpics

    also

    fglrxinfo
    X Error of failed request: BadRequest (invalid request code or no such operation)
    Major opcode of failed request: 136 (GLX)
    Minor opcode of failed request: 19 (X_GLXQueryServerString)
    Serial number of failed request: 12
    Current serial number in output stream: 12
    Last edited by mohgabr; July 9th, 2012 at 09:53 AM.

  5. #355
    Join Date
    Oct 2010
    Location
    Belo Horizonte, Brazil
    Beans
    75
    Distro
    Kubuntu 13.10 Saucy Salamander

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by mohgabr View Post
    First, Thanks very much for the great tutorial and you efforts here in the thread
    Second , I have a laptop hp probook 4530s with amd 6490 and intel 3000 I tried this tutorial and did it all step by step
    my problem is after running


    then restart Ubuntu runs in the low graphics mode and i must reconfigure the grahpics

    also
    Who's having low graphics mode problem, please follow this steps:

    1 - Post the following command output:
    Code:
    uname -a
    2 - follow the post #1, AND before install fglrx .deb files, execute the following command (must be executed inside fglrx .deb directory):
    Code:
    sudo dpkg -i fglrx*.deb >> fglrx_install.log 2>&1
    OBS: The command above will create a file fglrx_install.log logging all std output and error output occurred during fglrx installation.

    3 - post here the fglrx_install.log file content

    IMPORTANT TIP: To post something in this thread and be clear to everyone read it, use CODE /CODE declaration inside brackets.
    You can also use pastebin to paste your code, output or command stuff there and just put your stuff pastebin URL here. like that:
    uname -a output: http://pastebin.com/eaLcXUGV

    Cheers
    Last edited by Niccola; July 11th, 2012 at 12:31 PM.

  6. #356
    Join Date
    Oct 2010
    Location
    Belo Horizonte, Brazil
    Beans
    75
    Distro
    Kubuntu 13.10 Saucy Salamander

    Exclamation Intel Direct Rendering revision fix!!!

    Guys,
    sorry but there's an error in my post #107. Which, probably, will not work on 32-bits Linux.

    The 32-bits dri driver path is wrong. However, now I'll post an 10fglrx fix that will work to 32 or 64 bits.

    Before, make sure you have libgl1-mesa-dri installed. Without this package, you cannot have Intel direct rendering on 32 bits systems.

    Code:
    sudo apt-get install libgl1-mesa-dri
    Now, just edit /etc/X11/Xsession.d/10fglrx (with super user permission)

    Code:
    sudo gedit /etc/X11/Xsession.d/10fglrx
    REPLACE LINE 4 with code below:
    Code:
    LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib32/fglrx/dri:/usr/lib/x86_64-linux-gnu/dri
    AND ADD the code below between lines 11 and 12. (before export LIBGL_DRIVERS_PATH)
    Code:
    if [ `uname -m` = 'i686' ] | [ `uname -m` != 'x86_64' ]; then
        LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib/i386-linux-gnu/dri
    fi
    VERIFY YOUR CHANGES BEFORE SAVING
    Your file should looks like this:

    Code:
    LIBGL_DRIVERS_PATH=/usr/lib/fglrx/dri
    if [ `uname -m` = 'x86_64' ]; then
      if [ -d /usr/lib32/fglrx/dri ]; then
        LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib32/fglrx/dri:/usr/lib/x86_64-linux-gnu/dri
        if [ ! -z $LD_LIBRARY_PATH ]; then
    	LD_LIBRARY_PATH=$LD_LIBRARY_PATH:
        fi
        LD_LIBRARY_PATH=${LD_LIBRARY_PATH}/usr/lib32
        export LD_LIBRARY_PATH
      fi
    fi
    if [ `uname -m` = 'i686' ] | [ `uname -m` != 'x86_64' ]; then
        LIBGL_DRIVERS_PATH=${LIBGL_DRIVERS_PATH}:/usr/lib/i386-linux-gnu/dri
    fi
    export LIBGL_DRIVERS_PATH
    VERIFY YOUR CHANGES BEFORE SAVING
    Verify your changes, save and enjoy Direct Rendering in 32/64 bits OSs

    voila!

    You can download here all .deb files from amd Catalyst 12.6 final with 10fglrx fixed (ready to install).
    - This .deb files only works with 12.04 LTS Precise Ubuntu
    - I've add Kernel 3.4 support in this .deb files (for Ubuntu 12.04 LTS precise)
    - Fixed Intel direct rendering

    Download:
    for Ubuntu 12.04 LTS 64 bits: amd-12-6-fixed-Niccola-amd64.tar.gz
    for Ubuntu 12.04 LTS 32 bits: amd-12-6-fixed-Niccola-i386.tar.gz

    Instructions:
    1 - Extract inside a new and empty directory
    Code:
    tar -xvf amd-12-6-fixed-Niccola.tar.gz
    2 - Install:
    Code:
    sudo dpkg -i fglrx*.deb
    3 - Run automatic configuration for xorg.conf file:
    Code:
    sudo amdconfig --initial -f
    Reboot your machine

    4 - Switch to Intel Integrated Graphic Card:
    Code:
    sudo amdconfig --px-igpu
    reboot your machine

    5 - test Intel Direct Rendering:
    Code:
    glxinfo | egrep render
    Last edited by Niccola; July 13th, 2012 at 03:50 PM.

  7. #357
    Join Date
    Jul 2012
    Beans
    4

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Niccola View Post
    Who's having low graphics mode problem, please follow this steps:

    1 - Post the following command output:
    Code:
    uname -a
    2 - follow the post #1, AND before install fglrx .deb files, execute the following command (must be executed inside fglrx .deb directory):
    Code:
    sudo dpkg -i fglrx*.deb >> fglrx_install.log 2>&1
    OBS: The command above will create a file fglrx_install.log logging all std output and error output occurred during fglrx installation.

    3 - post here the fglrx_install.log file content

    IMPORTANT TIP: To post something in this thread and be clear to everyone read it, use CODE /CODE declaration inside brackets.
    You can also use pastebin to paste your code, output or command stuff there and just put your stuff pastebin URL here. like that:
    uname -a output: http://pastebin.com/eaLcXUGV

    Cheers
    Hi , thanks for your efforts
    And here is my output:

    Code:
    $ uname -a
    Linux MohGabr-Ubuntu 3.2.0-26-generic-pae #41-Ubuntu SMP Thu Jun 14 16:45:14 UTC 2012 i686 i686 i386 GNU/Linux
    about the other thing I removed the old packages and can't generate them again using :
    Code:
    sudo sh ./amd-driver-installer-12-4-x86.x86_64.run --buildpkg Ubuntu/precise
    it gives me this error
    Code:
    .
    .
    .
    .
    .
    .
    .
    .
    dpkg-buildpackage: error: debian/rules binary gave error exit status 2
    Removing temporary directory: fglrx-install.dL7xtG
    I will try to rebuild the packages again

  8. #358
    Join Date
    Oct 2010
    Location
    Belo Horizonte, Brazil
    Beans
    75
    Distro
    Kubuntu 13.10 Saucy Salamander

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by mohgabr View Post
    Hi , thanks for your efforts
    And here is my output:

    Code:
    $ uname -a
    Linux MohGabr-Ubuntu 3.2.0-26-generic-pae #41-Ubuntu SMP Thu Jun 14 16:45:14 UTC 2012 i686 i686 i386 GNU/Linux
    about the other thing I removed the old packages and can't generate them again using :
    Code:
    sudo sh ./amd-driver-installer-12-4-x86.x86_64.run --buildpkg Ubuntu/precise
    it gives me this error
    Code:
    .
    .
    .
    dpkg-buildpackage: error: debian/rules binary gave error exit status 2
    Removing temporary directory: fglrx-install.dL7xtG
    I will try to rebuild the packages again
    I don't know what's happen with this information you give me. But in this step you probably miss some packages installation.

    try it:
    Code:
    sudo apt-get install build-essential cdbs dh-make dkms execstack dh-modaliases fakeroot libqtgui4 libgl1-mesa-dri
    and after, download it to an empty directory:
    amd-12-6-fixed-Niccola-i386.tar.gz

    then execute following command, such that is post #357:
    Instructions:
    1 - Extract inside a new and empty directory
    Code:
    tar -xvf amd-12-6-fixed-Niccola.tar.gz
    2 - Install:
    Code:
    sudo dpkg -i fglrx*.deb
    3 - Run automatic configuration for xorg.conf file:
    Code:
    sudo amdconfig --initial -f
    Reboot your machine

    4 - Switch to Intel Integrated Graphic Card:
    Code:
    sudo amdconfig --px-igpu
    reboot your machine

    5 - test Intel Direct Rendering:
    Code:
    glxinfo | egrep render

  9. #359
    Join Date
    Jul 2012
    Location
    Germany
    Beans
    19
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: AMD/Intel Hybrid Graphics works !

    First of all I have to say thanks. I am following this thread since a long time and it was helping me a lot to get the switchable graphics working for my Samsung.

    Samsung Series 7 Chronos 700Z3A-SO2de, Intel HD 3000, AMD 6490m, HDMI Intel/AMD not tested/not tested, Mini DisplayPort Intel/AMD not testes/not tested

    Nevertheless there are still issues to fix. The laptop has been under linux always a little bit hotter than under windows. I had activated the integrated graphics card. But the dedicated seems to be online thought. Today I activated the dedicated and now the used power seems to be dropped by 0.5 to 1W and the temperature of the air coming out of the laptop seems to be lower.

    Does anyone made the same observation? Maybe the fglrx driver does'nt set the dedicated graphics card into a very low power mode when the integrated graphics card is chosen.

  10. #360
    Join Date
    Jul 2012
    Beans
    4

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Niccola View Post
    Instructions:
    1 - Extract inside a new and empty directory
    Code:
    tar -xvf amd-12-6-fixed-Niccola.tar.gz
    2 - Install:
    Code:
    sudo dpkg -i fglrx*.deb
    3 - Run automatic configuration for xorg.conf file:
    Code:
    sudo amdconfig --initial -f
    Reboot your machine

    4 - Switch to Intel Integrated Graphic Card:
    Code:
    sudo amdconfig --px-igpu
    reboot your machine

    5 - test Intel Direct Rendering:
    Code:
    glxinfo | egrep render
    Thanks for your great efforts I think it worked now
    I have downloaded your fixed packages
    and here is the output :
    1- The installation log file fglrx_install.log : http://pastebin.com/r8dipgCA

    2-
    Code:
    $ fglrxinfo
    display: :0.0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: AMD Radeon HD 6400M Series
    OpenGL version string: 4.2.11733 Compatibility Profile Context
    3-
    Code:
    $ glxinfo | egrep render
    direct rendering: Yes
    OpenGL renderer string: AMD Radeon HD 6400M Series
        GL_KTX_buffer_region, GL_NV_blend_square, GL_NV_conditional_render,
    But the switching not working
    Code:
    $ sudo amdconfig --px-igpu
    No layout section was found in the file: 'xorg.conf'.
    Please run 'aticonfig --initial' first or modify your configuration file manually and run aticonfig again.
    amdconfig: parsing the command-line failed.
    Last edited by mohgabr; July 14th, 2012 at 06:23 PM.

Page 36 of 88 FirstFirst ... 2634353637384686 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •