Page 3 of 87 FirstFirst 123451353 ... LastLast
Results 21 to 30 of 868

Thread: AMD/Intel Hybrid Graphics works

  1. #21
    Join Date
    Aug 2010
    Location
    Olivet, France
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Starks View Post
    Just to confirm, this is for both muxed and muxless?
    Only muxless system.
    Muxed system have a switch in the BIOS, this is why muxless system are a problem, because they do not have this option.
    Last edited by Alexislavie; February 26th, 2012 at 08:32 PM.

  2. #22
    Join Date
    Aug 2010
    Location
    Olivet, France
    Beans
    60
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: AMD/Intel Hybrid Graphics works !

    For those who want to try the unstable ppas, after running aticonfig --initial -f
    please check the result of this command :
    echo "PCI:$(lspci | grep VGA | grep ATI | awk '{print $1}' | sed 's/\./:/')"
    with the pci adress in /etc/X11/xorg.conf if they aren't the same please replace the one in the xorg.conf by the one the previous command gave you.

    I recommend to all of you to read this : http://forums.gentoo.org/viewtopic-p-6936730.html

  3. #23
    Join Date
    Dec 2006
    Beans
    177
    Distro
    Hardy Heron (Ubuntu Development)

    Re: AMD/Intel Hybrid Graphics works !

    This could use some more information. For instance, the fglrx version does match the deb package. Also, the deb package is difficult to determine the deb version. 930 ubuntu2 seems to match up with 12.1.

    Not sure on intel

  4. #24
    Join Date
    Mar 2007
    Location
    Hempstead, NY
    Beans
    1,694
    Distro
    Ubuntu Development Release

    Re: AMD/Intel Hybrid Graphics works !

    Quote Originally Posted by Alexislavie View Post
    X.org can't do this. Wayland will someday.
    dma-buf, not Wayland.

  5. #25
    Join Date
    Dec 2008
    Beans
    23

    Re: AMD/Intel Hybrid Graphics works !

    Already there is a sna enable ppa. Using the last intel drivers.
    https://launchpad.net/~sarvatt/+archive/intel-sna


    The ppa drive work. no idea for how long the owner will maintain or update.


    You need to use to.
    sudo add-apt-repository ppaorg-edgers/ppa
    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

  6. #26
    Join Date
    Dec 2008
    Beans
    23

    Re: AMD/Intel Hybrid Graphics works !

    not working. ATI Radeon HD 6850M envy 17 3d

    http://www.amd.com/us/products/noteb...n-6800m.aspx#2

    Same problem before;

    PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver

    The 6850m from what i know is a muxless ( at last inside windows).





    [ 41.939] (--) Chipset Supported AMD Graphics Processor (0x68A8) found
    [ 41.940] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
    [ 41.940] (II) fglrx: intel VGA device detected, load intel driver.
    [ 41.940] (II) LoadModule: "intel"
    [ 41.940] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
    [ 41.940] (II) Module intel: vendor="X.Org Foundation"
    [ 41.940] compiled for 1.11.2.902, module version = 2.17.0
    [ 41.940] Module class: X.Org Video Driver
    [ 41.940] ABI class: X.Org Video Driver, version 11.0
    [ 41.941] ukiDynamicMajor: found major device number 250
    [ 41.941] ukiDynamicMajor: found major device number 250
    [ 41.941] ukiOpenByBusid: Searching for BusID PCI:1:0:0
    [ 41.941] ukiOpenDevice: node name is /dev/ati/card0
    [ 41.941] ukiOpenDevice: open result is 8, (OK)
    [ 41.941] ukiOpenByBusid: ukiOpenMinor returns 8
    [ 41.941] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
    [ 41.942] (WW) PowerXpress feature is not supported on A+I Mux platform. Please uninstall fglrx driver.
    [ 41.942] (EE) No devices detected.
    [ 41.942]
    Fatal server error:
    [ 41.942] no screens found
    [ 41.942]
    Please consult the The X.Org Foundation support
    at http://wiki.x.org
    for help.
    [ 41.942] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
    [ 41.942]

  7. #27
    Join Date
    Oct 2010
    Beans
    2

    Re: AMD/Intel Hybrid Graphics works !

    Doesn't work on my Dv6-6030el either (Intel HD3000 + ATI HD6470M).

    added both PPAs, updated packages, installed catalyst12.1, ran "aticonfig --initial -f" (which created a xorg.conf file exactly like yours) but on reboot X segfaults.

    Xorg.0.log is not very helpful:

    Code:
    (EE) Screen 1 deleted because of no matching config section
    and backtrace:
    Code:
    0: /usr/bin/X (xorg_backtrace+0x26) [0x567006]
    1: /usr/bin/X (0x400000+0x16ac6a) [0x56ac6a]
    2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fa59b32f000+0x10060) [0x7fa59b33f060]
    3: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7fa597300000+0x631c5) [0x7fa5973631c5]
    4: /usr/bin/X (xf86DeleteScreen+0x7c) [0x47cdbc]
    5: /usr/bin/X (xf86BusConfig+0x1cb) [0x46459b]
    6: /usr/bin/X (InitOutput+0x903) [0x470c03]
    7: /usr/bin/X (0x400000+0x22dfd) [0x422dfd]
    8: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xed) [0x7fa59a25830d]
    9: /usr/bin/X (0x400000+0x232bd) [0x4232bd]
    Segmentation fault at address 0x4
    Other commands you tried in #4 work fine (apparently I can switch graphics, and that's a great step forward) except "fglrxinfo" which gives "Error: unable to open display (null)"

    I blacklisted radeon and added "nomodeset" at boot (as found via google) but nothing changed. Any other ideas?

  8. #28
    Join Date
    Mar 2008
    Beans
    4

    Re: AMD/Intel Hybrid Graphics works !

    I made a thread for this but seeing as it's not getting much attention I'll post it here also

    I recently installed the AMD drivers on a DV6 with hybrid graphics using the SMXI script, I installed the intel driver first, then the AMD one. It worked until I logged out, after which I got this error:
    (EE) Screen 1 deleted because of no matching config selection
    (EE) fglrx(0): PowerXpress: usr/lib64/fglrx/switchlibGL failed with exit status 1
    (EE) fglrx(0): PowerXpress: Failed to switch libGL link files.
    (EE) Screen(s) found, but none have a usable configuration.
    Fatal server error: No screens found.


    I'd like to see hybrid graphics work as well. The open source ati drivers are very energy hungry and inefficient

  9. #29
    Join Date
    Dec 2008
    Beans
    23

    Re: AMD/Intel Hybrid Graphics works !

    The "No screens found" relies in the fact at last for our AMd muxless card. There is in fact just one REAL HARDWARE VIDEO CARD. The INTEL GPU one.
    The intel GPU ones that controls the hardware, videos ports and everything. The AMD is more like a TURBO PROCESSOR. When we switch to AMd under windows. The hardware structure still being the intel but the system disable the logic from GPU intel and start to use the logic of AMD processor ( In mine understand no MUX mean that)

    The amd driver try to find an output for screen to control But this doesn't exist. who control is the gpu intel one.

    Now come the fact of A+I question.
    The driver already have or at last seems to have a background for muxles at some level.

    OR this messages are a kind of wrong identification of the card by the side of amd driver ( a+i are the muxed ones? or i'm wrong).

    OR the drive compatibility we saw in pictures are for MUXED ONES.

    OR there is a blacklist for non use the drivers in predefined cards same if work ( by the amd driver).

    OR there is 2 kinds of AMD MUXLESS devices.
    The ones in mine case amd 8550m that use the HARDWARE structure from GPU acting just like an advanced TURBO and other one that are muxless but both cards (GPU AND DISCRETE) have a full hardware control of video ports.

    So.. Is is. Because this the solution seems little magical to me. At last for mine devices.

    Still on wait.

  10. #30
    Join Date
    Dec 2008
    Beans
    23

    Re: AMD/Intel Hybrid Graphics works !

    From http://h20000.www2.hp.com/bizsupport...ctID=c03048374


    At last seems the option in linux drivers to switch the cards. Are made for the ATI + ATI ( muxed ones) and not the GPU + ATI ( or muxless).

Page 3 of 87 FirstFirst 123451353 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •