Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs hot

  1. #21
    Join Date
    Aug 2011
    Beans
    10

    Re: Update

    Quote Originally Posted by @gu79 View Post
    A quick reply. Let me know if you need more help.

    Grub is the program that shows you the different options during boot. So, select the line that you usually select to boot into ubuntu, but instead of pressing enter, press "e". In the next screen, go to the line that starts with "linux/boot/vmlinuz..." and append to that line:
    i915.i915_enable_rc6=1
    Press Ctrl-x to boot.

    That's not permanent, so if something doesn't work properly, just reboot.
    After trying this for a few weeks, I'm not sure if I'm noticing any difference. It runs warm & keyboard is warm as well. Maybe it's just supposed to be like this. The command doesn't seem to hurt anything. What is this command doing, btw? Do I need to download drivers? Model again is U56E-BAL7 asus.

    Any other recommendations? Looks like I've got a lot of studying linux up ahead, which is cool. I like ubuntu & learning this, problem solving, etc. It's been well worth all the hard work because I've been able to do things in linux that windows couldn't handle. (running 5 routers + 2 windows machines all within ubuntu)
    Last edited by chrisgianti; June 11th, 2012 at 02:35 AM.

  2. #22
    Join Date
    Nov 2011
    Beans
    28

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Not a clue. A good indication should be the battery life. What about the temperature in windows?
    You could try to install 12.04 and see how it behaves there.
    About RC6:
    https://wiki.ubuntu.com/Kernel/PowerManagementRC6

  3. #23
    Join Date
    Aug 2011
    Beans
    10

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Quote Originally Posted by @gu79 View Post
    Not a clue. A good indication should be the battery life. What about the temperature in windows?
    You could try to install 12.04 and see how it behaves there.
    About RC6:
    https://wiki.ubuntu.com/Kernel/PowerManagementRC6

    That's an awesome informational link. Thanks. This stuff is so cool.

  4. #24
    Join Date
    Jun 2012
    Beans
    1

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Quote Originally Posted by WBMachinery View Post
    I had the same problem with the same computer enter these commands and it will be solved.

    sudo modprobe -r iwlagn
    sudo modprobe iwlagn bt_coex_active=0

    If it worked you need to make it permanent.

    To make the change permanent:

    gsku gedit /etc/modprobe.d/iwl.conf

    Copy/paste this line into the new file:
    options iwlagn bt_coex_active=0

    Save and quit.

    After you do this you will experience very slow internet connection but it can be solved by making iwlag not use n and it can be done with these commands.

    sudo rmmod -f iwlagn
    sudo modprobe iwlagn 11n_disable=1

    if you see it made a difference once again you must make it perminent..

    gksudo gedit /etc/modprobe.d/iwlagn-disable11n.conf
    options iwlagn 11n_disable=1

    Save and quit.
    And thats all

    The change worked, and I would like to make it permanent, but when you wrote,

    "Copy/paste this line into the new file:
    options iwlagn bt_coex_active=0"

    I don't know what you mean by "the new file" could someone walk me through this step?

    thanks

  5. #25
    Join Date
    Aug 2012
    Beans
    1

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    [QUOTE=WBMachinery;11773925]I had the same problem with the same computer enter these commands and it will be solved.

    sudo modprobe -r iwlagn
    sudo modprobe iwlagn bt_coex_active=0

    If it worked you need to make it permanent.

    To make the change permanent:

    gsku gedit /etc/modprobe.d/iwl.conf

    Copy/paste this line into the new file:
    options iwlagn bt_coex_active=0

    Save and quit. [end quote]

    We did all of this and it indicated that it had connected to the wireless, but when i disconnected the Ethernet cable and it still indicated that it had connected to the wireless SSID but had no internet access. I know it isn't a problem with the modem because it works in windows fine. Please help and thanks for your efforts!

  6. #26
    Join Date
    Sep 2012
    Beans
    1

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Quote Originally Posted by WBMachinery View Post
    In the new kernel the wireless interface changes from iwlagn to iwlwifi, you can verify this with the command

    lspci -v

    and look under Network controller on the section called kernel modules.

    So all you have to do is subsitute iwlwifi in the commands I already posted instead of iwlagn and you should be good to go.

    sudo modprobe -r iwlwifi

    sudo modprobe iwlwifi bt_coex_active=0

    gksu gedit /etc/modprobe.d/iwl.conf

    options iwlwifi bt_coex_active=0

    and to ensure fast internet do the same:

    sudo rmmod -f iwlwifi
    gksu gedit /etc/modprobe.d/iwlwifi-disable11n.conf

    options iwlwifi 11n_disable=1
    I did this, but it won't stick (not permanent).

    Every time I reboot I have to use these two commands, otherwise I can't connect:

    sudo modprobe -r iwlwifi

    sudo modprobe iwlwifi bt_coex_active=0

    There are no conflicting files in /etc/modprobe.d, I already checked that.

    Any suggestions???

    Thanks

  7. #27
    Join Date
    Aug 2011
    Beans
    10

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Quote Originally Posted by @gu79 View Post
    That's a typo. Instead of gsku, you should use gksu, so:

    gksu gedit /etc/modprobe.d/iwl.conf

    "sudo" gives the instructions you are executing root (administrative) privileges, while gksu does the same, but for visual applications outside the terminal (read sudo vs gksu).
    Thanks! This worked for me (u56e-bal7, Linux Mint 15 Olivia). Took a while to find the command that worked!

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •