Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs hot

  1. #11
    Join Date
    Jan 2012
    Beans
    17

    Smile Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    In the new kernel the wireless interface changes from iwlagn to iwlwifi, you can verify this with the command

    lspci -v

    and look under Network controller on the section called kernel modules.

    So all you have to do is subsitute iwlwifi in the commands I already posted instead of iwlagn and you should be good to go.

    sudo modprobe -r iwlwifi

    sudo modprobe iwlwifi bt_coex_active=0

    gksu gedit /etc/modprobe.d/iwl.conf

    options iwlwifi bt_coex_active=0

    and to ensure fast internet do the same:

    sudo rmmod -f iwlwifi
    gksu gedit /etc/modprobe.d/iwlwifi-disable11n.conf

    options iwlwifi 11n_disable=1

  2. #12
    Join Date
    Feb 2012
    Beans
    9

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Quote Originally Posted by WBMachinery View Post
    In the new kernel the wireless interface changes from iwlagn to iwlwifi, you can verify this with the command

    lspci -v

    and look under Network controller on the section called kernel modules.

    So all you have to do is subsitute iwlwifi in the commands I already posted instead of iwlagn and you should be good to go.

    sudo modprobe -r iwlwifi

    sudo modprobe iwlwifi bt_coex_active=0

    gksu gedit /etc/modprobe.d/iwl.conf

    options iwlwifi bt_coex_active=0

    and to ensure fast internet do the same:

    sudo rmmod -f iwlwifi
    gksu gedit /etc/modprobe.d/iwlwifi-disable11n.conf

    options iwlwifi 11n_disable=1
    I tried these commands, and they do not seem to have any effect other than that sudo rmmod -f iwlwifi removes all wireless info from the indicator menu, as well as the option to enable wireless. The only thing that I can think of is that maybe deleting multiple versions with "edit connections" caused a problem, but I am not completely sure how to re-add my network.
    Thanks for your help, and any further suggestions would be appreciated!
    Last edited by Ubun2 gy; April 28th, 2012 at 03:42 AM.

  3. #13
    Join Date
    Feb 2012
    Beans
    9

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Bump!

  4. #14
    Join Date
    Nov 2011
    Beans
    28

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Quote Originally Posted by Ubun2 gy View Post
    Bump!
    If you see other networks and not yours (your SSID is not hidden, right? ), I guess it could be that your router is using high channels (above 10), which are not visible from ubuntu. I have had that problem and setting the router to transmit in a lower channel solved the problem. Hope it helps, otherwise I have no idea what to do...

  5. #15
    Join Date
    Jan 2012
    Beans
    17

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    If you upgraded Ubuntu the old files that were changed with the commands didn't get removed and are probably conflicting the new files, try deleting them all, first find all of those files with

    ls /etc/modprobe.d | grep iw

    you should see all the files that where created with the previous commands, to delete them use the command

    sudo rm "name of file"

    for each file that was found. After that try the new commands again.

  6. #16
    Join Date
    Feb 2012
    Beans
    9

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    @gu79, the SSID is not hidden, and I am not sure if the router is on a channel above 10, but I will check.

    WBMachinery, when I input
    Code:
    ls /etc/modprobe.d | grep iw
    into terminal I get the following results:
    Code:
    iwlagn-disable11n.conf
    iwl.conf
    iwl.conf~
    iwlwifi-disable11n.conf
    iwlwifi-disable11n.conf~
    but when I type
    Code:
    sudo rm iwlagn-disable11n.conf
    I get
    Code:
    rm: cannot remove `iwlagn-disable11n.conf': No such file or directory
    I have no clue why this is happening

  7. #17
    Join Date
    Jan 2012
    Beans
    17

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Well first of all you should delete all of those files, because they are conflicting with each other.

    Sorry that I forgot to tell you that in order to modify a file in any way you must be located in the directory that contains it. So you can either change directories or you can specify it in the command like this:

    Code:
    sudo rm /etc/modprobe.d/"name of file"
    execute this command for all the files that you found, for example:

    Code:
    sudo rm /etc/modporbe.d/iwl.conf~
    To ensure that all of the files were erased properly do the grep command once more and nothing should appear.
    Code:
    ls /etc/modprobe.d | grep iw
    Then repeat the commands I have already posted with the iwlwifi change and you should be good to go.
    Last edited by WBMachinery; May 4th, 2012 at 01:52 AM.

  8. #18
    Join Date
    Feb 2012
    Beans
    9

    Re: Issues with Asus U56e: Wireless does not connect, kernel stopped upgrading, runs

    Success!
    It is working now, I do not know why I did not think of cd'ing into the directory.

    Thanks @gu79; it turned out that another user on the network had accidentally hidden the SSID!

    My install is now (knock on wood) running smoothly, and the power managemt in 12.04 compared with 11.10 is like night and day!

  9. #19
    Join Date
    Aug 2011
    Beans
    10

    Re: Update

    Quote Originally Posted by @gu79 View Post
    I guess you installed Mint last. You can solve it reinstalling grub from ubuntu (check this for more info):

    Code:
    sudo grub-install --recheck /dev/sdX
    sudo update-grub
    (replace X according to your drive, "sda" for example)

    For the power issue (fans, temperature, battery life), try adding i915.i915_enable_rc6=1 as a kernel boot parameter: in the grub menu, press "e" to edit the line of Ubuntu, and then add that to the end of the line of the kernel (starting with linux).
    For example: linux /boot/vmlinuz-3.0.0-16-generic <...> quiet splash vt.handoff=7 i915.i915_enable_rc6=1

    If that works, you can modify grub to have it permanent:
    Code:
     gksu gedit /etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.i915_enable_rc6=1"
    And update grub, sudo update-grub

    They are fixing some bugs to have that as default in 12.04. Check this.

    About the wireless, do you see any network at all?
    >>I would like to try your power solution i915.i915_enable_rc6=1 ... but I have no idea how to do what you described. I also have a u56e (mine is a bal7) with similar specs as the guy who started this question (except I only have windows 7 & ubuntu 11.04 on my machine).
    Could you provide more instruction for a linux newbie?

  10. #20
    Join Date
    Nov 2011
    Beans
    28

    Re: Update

    Quote Originally Posted by chrisgianti View Post
    >>Could you provide more instruction for a linux newbie?
    A quick reply. Let me know if you need more help.

    Grub is the program that shows you the different options during boot. So, select the line that you usually select to boot into ubuntu, but instead of pressing enter, press "e". In the next screen, go to the line that starts with "linux/boot/vmlinuz..." and append to that line:
    i915.i915_enable_rc6=1
    Press Ctrl-x to boot.

    That's not permanent, so if something doesn't work properly, just reboot.
    Last edited by @gu79; May 20th, 2012 at 10:56 PM.

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •