Page 3 of 7 FirstFirst 12345 ... LastLast
Results 21 to 30 of 67

Thread: Webcam not working in Ubuntu 11.10

  1. #21
    Join Date
    May 2010
    Location
    uk
    Beans
    8,095
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Webcam not working in Ubuntu 11.10

    Hi

    Sorry for the delay. I have had a busy couple of days. Let's see if we can create a rule for your webcam.

    This is taken from here.

    http://tjworld.net/wiki/Linux/Ubuntu/UdevWebcamRules

    Open a terminal and copy and paste this code into the terminal. It will create the file /etc/udev/rules.d/70-webcam.rules.

    Code:
    echo 'SUBSYSTEM=="video4linux", BUS=="usb", SYSFS{idVendor}=="05c8", SYSFS{idProduct}=="021a", NAME="video0"' | sudo tee /etc/udev/rules.d/70-webcam.rules
    Reboot your PC and check it's created /dev/video0. Post back on efficacy.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  2. #22
    Join Date
    Feb 2012
    Beans
    32

    Re: Webcam not working in Ubuntu 11.10

    Hi Matt,Thanks for working on this with me.

    Here's what happened... I pasted that text in the terminal which then responded: SUBSYSTEM=="video4linux", BUS=="usb", SYSFS{idVendor}=="05c8", SYSFS{idProduct}=="021a", NAME="video0"

    I rebooted and now when I check in the terminal it says that the device is on video0.

    But... now Cheese, Video 4 and Skype all are set to video0, but the camera doesn't work!

  3. #23
    Join Date
    May 2010
    Location
    uk
    Beans
    8,095
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Webcam not working in Ubuntu 11.10

    Hi

    Quote Originally Posted by thestraniero View Post
    Hi Matt,Thanks for working on this with me.

    Here's what happened... I pasted that text in the terminal which then responded: SUBSYSTEM=="video4linux", BUS=="usb", SYSFS{idVendor}=="05c8", SYSFS{idProduct}=="021a", NAME="video0"

    I rebooted and now when I check in the terminal it says that the device is on video0.

    But... now Cheese, Video 4 and Skype all are set to video0, but the camera doesn't work!
    That's a real shame it did not work. It was only a hunch though. It's odd how it sometimes works. Maybe it's not loading the driver correctly. Can you post the output of

    Code:
    lsmod
    once for when it works and once for when it doesn't. I assume this is a V4L (UVC class) webcam. I should really check.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  4. #24
    Join Date
    Feb 2012
    Beans
    32

    Re: Webcam not working in Ubuntu 11.10

    Well, last night the webcam was coming on almost 1 in 2 times which probably explains why it won't come on at all this morning! I'll have to post the working results later. Here's the "not working" results below. By the way the system calls it "HP Webcam" if that helps... Thanks again!

    Module Size Used by
    usbhid 41905 0
    hid 77367 1 usbhid
    nls_iso8859_1 12617 0
    nls_cp437 12751 0
    usb_storage 44173 0
    uas 17699 0
    btrfs 622556 0
    zlib_deflate 26622 1 btrfs
    libcrc32c 12543 1 btrfs
    ufs 78131 0
    qnx4 13309 0
    hfsplus 83507 0
    hfs 49479 0
    minix 31444 0
    ntfs 100171 0
    vfat 17308 0
    msdos 17132 0
    fat 55577 2 vfat,msdos
    jfs 175084 0
    xfs 746838 0
    reiserfs 230932 0
    snd_hrtimer 12648 1
    rfcomm 38408 8
    bnep 17923 2
    parport_pc 32114 0
    ppdev 12849 0
    wl 2646601 0
    joydev 17393 0
    lib80211 14570 1 wl
    bcma 19571 0
    arc4 12473 2
    hp_wmi 13652 0
    sparse_keymap 13658 1 hp_wmi
    snd_hda_codec_idt 60049 1
    snd_hda_intel 24262 2
    snd_hda_codec 91859 2 snd_hda_codec_idt,snd_hda_intel
    snd_hwdep 13276 1 snd_hda_codec
    snd_pcm 80435 2 snd_hda_intel,snd_hda_codec
    uvcvideo 67271 1
    snd_seq_midi 13132 0
    videodev 85626 2 uvcvideo
    snd_rawmidi 25241 1 snd_seq_midi
    btusb 18160 2
    snd_seq_midi_event 14475 1 snd_seq_midi
    bluetooth 148839 23 rfcomm,bnep,btusb
    psmouse 73673 0
    serio_raw 12990 0
    snd_seq 51567 3 snd_seq_midi,snd_seq_midi_event
    snd_timer 28932 3 snd_hrtimer,snd_pcm,snd_seq
    snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
    brcmsmac 591864 0
    brcmutil 16885 1 brcmsmac
    mac80211 393421 1 brcmsmac
    binfmt_misc 17292 1
    cfg80211 172427 2 brcmsmac,mac80211
    snd 55902 14 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_ hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
    i915 509519 4
    crc_ccitt 12595 1 brcmsmac
    soundcore 12600 1 snd
    drm_kms_helper 32889 1 i915
    snd_page_alloc 14115 2 snd_hda_intel,snd_pcm
    wmi 18744 1 hp_wmi
    drm 192194 5 i915,drm_kms_helper
    i2c_algo_bit 13199 1 i915
    video 18908 1 i915
    lp 17455 0
    parport 40930 3 parport_pc,ppdev,lp
    ahci 21634 2
    libahci 25727 1 ahci
    r8169 43104 0

  5. #25
    Join Date
    Feb 2012
    Beans
    32

    Re: Webcam not working in Ubuntu 11.10

    This is the result while the camera was active...

    Module Size Used by
    nls_iso8859_1 12617 0
    nls_cp437 12751 0
    vfat 17308 0
    fat 55577 1 vfat
    usb_storage 44173 0
    uas 17699 0
    usbhid 41905 0
    hid 77367 1 usbhid
    snd_hrtimer 12648 1
    rfcomm 38408 8
    bnep 17923 2
    parport_pc 32114 0
    ppdev 12849 0
    wl 2646601 0
    lib80211 14570 1 wl
    bcma 19571 0
    arc4 12473 2
    joydev 17393 0
    hp_wmi 13652 0
    sparse_keymap 13658 1 hp_wmi
    snd_hda_codec_idt 60049 1
    snd_hda_intel 24262 2
    snd_hda_codec 91859 2 snd_hda_codec_idt,snd_hda_intel
    snd_hwdep 13276 1 snd_hda_codec
    snd_pcm 80435 2 snd_hda_intel,snd_hda_codec
    snd_seq_midi 13132 0
    brcmsmac 591864 0
    brcmutil 16885 1 brcmsmac
    snd_rawmidi 25241 1 snd_seq_midi
    btusb 18160 2
    mac80211 393421 1 brcmsmac
    uvcvideo 67271 1
    snd_seq_midi_event 14475 1 snd_seq_midi
    videodev 85626 2 uvcvideo
    psmouse 73673 0
    snd_seq 51567 3 snd_seq_midi,snd_seq_midi_event
    bluetooth 148839 23 rfcomm,bnep,btusb
    serio_raw 12990 0
    binfmt_misc 17292 1
    snd_timer 28932 3 snd_hrtimer,snd_pcm,snd_seq
    snd_seq_device 14172 3 snd_seq_midi,snd_rawmidi,snd_seq
    snd 55902 14 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_ hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_se q_device
    wmi 18744 1 hp_wmi
    i915 509519 4
    cfg80211 172427 2 brcmsmac,mac80211
    soundcore 12600 1 snd
    drm_kms_helper 32889 1 i915
    snd_page_alloc 14115 2 snd_hda_intel,snd_pcm
    drm 192194 5 i915,drm_kms_helper
    crc_ccitt 12595 1 brcmsmac
    i2c_algo_bit 13199 1 i915
    video 18908 1 i915
    lp 17455 0
    parport 40930 3 parport_pc,ppdev,lp
    ahci 21634 2
    libahci 25727 1 ahci
    r8169 43104 0

  6. #26
    Join Date
    May 2010
    Location
    uk
    Beans
    8,095
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Webcam not working in Ubuntu 11.10

    Hi

    This has got me really scratching my head. I can see nothing wrong with the loaded drivers.

    Just to get more information, what's your kernel ?

    Code:
    uname -a
    Anybody else have any ideas ?

    If i get time tomorrow, i will do some research.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  7. #27
    Join Date
    Feb 2012
    Beans
    32

    Re: Webcam not working in Ubuntu 11.10

    Well, I appreciate your head scratching. I don't get it either. Why does it occasionally work and other times no without doing anything at all in between trials?

    Linux mark-Compaq-Mini-CQ10-600 3.0.0-16-generic #29-Ubuntu SMP Tue Feb 14 12:49:42 UTC 2012 i686 i686 i386 GNU/Linux

    Thanks Matt!

  8. #28
    Join Date
    Feb 2012
    Beans
    32

    Re: Webcam not working in Ubuntu 11.10

    Now it's listing two video devices...

    mark@mark-Compaq-Mini-CQ10-600:~$ ls /dev/video*
    /dev/video0 /dev/video1
    mark@mark-Compaq-Mini-CQ10-600:~$

  9. #29
    Join Date
    May 2010
    Location
    uk
    Beans
    8,095
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Webcam not working in Ubuntu 11.10

    Hi

    Open a terminal and type

    Code:
    sudo lshw
    Post back the entire output.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  10. #30
    Join Date
    May 2006
    Location
    Bogotá
    Beans
    34
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Webcam not working in Ubuntu 11.10

    I report a similar problem, with a Genius FaceCam 310.

    Cheese gives the following message:


    ** (cheese:8231): WARNING **: Error starting streaming on device '/dev/video0'.


    ** (cheese:8231): WARNING **: Could not negotiate format

    Now in this case, it always looks for "video0" - there is no conflict with video1.

    Now, gstreamer-properties gives "Video for Linux 2 (v4l2): Error starting streaming on device '/dev/video0'."

    I believe somehow the kernel got messed up when there was an update...

    Any suggestion for a solution will be welcome!

    av

Page 3 of 7 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •