Hi All,

I'm running Oneiric on a Sony Vaio VPCSA with an i5-2520M CPU and hybrid graphics which is set to use the on-board Intel chip (and SSD, in case that's relevant). After a fresh boot, everything is fine for a while, but then CPU speed goes down to 800 MHz (the lowest non-idle setting) with the consequence that CPU load goes up and everything slows to a crawl. I've installed lm-sensors, and in this state (or before), I never see temperatures > 78`C (although on the outside, the laptop does become quite warm).

What I find peculiar is that at no time does the fan go up. When I reboot into Windows (dual-boot), I immediately hear the fan go up. I've tried installing the Jupiter applet, but the only effect is that when I use the 'Maximum Performance' mode, the speed only drops to 1000 MHz instead of 800 after a while. I've also tried the other settings, with no change to speed or temperature.

My kernel is 3.0.0.16.

This is the output from sensors when Jupiter is set to performance, and CPU is at 1000 MHz:
acpitz-virtual-0
Adapter: Virtual device
temp1: +77.0C (crit = +97.0C)

coretemp-isa-0000
Adapter: ISA adapter
Physical id 0: +78.0C (high = +86.0C, crit = +100.0C)
Core 0: +68.0C (high = +86.0C, crit = +100.0C)
Core 1: +69.0C (high = +86.0C, crit = +100.0C)

Thanks for any help.