Results 1 to 3 of 3

Thread: Wrong colors in games

  1. #1
    Join Date
    Aug 2010
    Location
    Munich, Germany
    Beans
    84

    Wrong colors in games

    Hi,

    I've installed Linux on my Power Mac G5 2003 (Radeon 9600 128 MB VRAM). I use the KMS/Gallium 0.4 driver for 3D acceleration. 3D works but I have wrong colors inside SuperTuxKart 0.8.

    I don't have a xorg.conf but in the yaboot.conf the follwing line:

    Code:
    append="video=radeonfb:off radeon.modeset=1"
    Any tips?

    Cheers,

    Xeno
    Attached Images Attached Images

  2. #2
    Join Date
    Aug 2010
    Location
    Munich, Germany
    Beans
    84

    Re: Wrong colors in games

    I've solved the conflict with fb driver with

    /etc/yaboot.conf

    Code:
    ....
    
    append="video=radeonfb:off radeon.modeset=1 video=offb:off video=1280x1024-32"
    
    ....
    but the problem with the wrong colors isn't solved

    A new screenshot: http://s4.imgload.info/yz74kd15u569jyb.png

    What can I do?

  3. #3
    Join Date
    Jan 2011
    Beans
    939

    Re: Wrong colors in games

    Have you thought about contacting the debian powerpc mailing list (http://lists.debian.org/debian-powerpc/ ) and seeing if you can catch the eye of somebody like Michel Danzer?

    I have a problem with KMS in Lubuntu - the window title bars are the wrong colour. I have a different radeon card to you though. Also cairo-dock can give messed up colours (non-KMS), but if you change the theme to one that uses a different picture format it can help.

    Sorry can't be much more help. If you were using non-KMS then I'd suggest playing around with the GART settings.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •