Page 2 of 7 FirstFirst 1234 ... LastLast
Results 11 to 20 of 63

Thread: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

  1. #11
    Join Date
    Feb 2012
    Beans
    5

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    Quote Originally Posted by Bucic View Post
    OK, so if it's not possible to fix the dependencies then how do I revert to 2.7.4? The script linked above suffer from the same dependency problem, so it's a no go
    Hey Bucic, I tried to install gimp 2.7.5 on ubuntu 12.04 LTS alpha 2. Same problem! Nothing to do! So you can:

    1. Wait until matthaeus fix it

    or

    2. Get source code of 2.7.4 then compile & install it

    3. If you have "old" 2.7.4 deb packages in /var/cache/apt/archives then reinstall gimp and gimp-data (remove 2.7.5 and all matthaeus' repositories first!)

    Hope it helps.
    Matheus

  2. #12
    Join Date
    Apr 2011
    Location
    Baltimore, Maryland
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    I would guess it's not? (I'm having this same issue.)

  3. #13
    Join Date
    Feb 2012
    Beans
    1

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    Just piling on. I already had Gimp installed, and after an automatic system update, it just disappeared on me! Trying to install it again, I got the exact same message as the first poster in the thread.

  4. #14
    Join Date
    Apr 2011
    Location
    Baltimore, Maryland
    Beans
    7
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    Quote Originally Posted by cartoonist View Post
    Just piling on. I already had Gimp installed, and after an automatic system update, it just disappeared on me! Trying to install it again, I got the exact same message as the first poster in the thread.
    Yeah, same thing happened to me.

  5. #15
    Join Date
    Nov 2005
    Location
    Helsinki, Finland
    Beans
    29
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    If you are using oneiric:

    GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos

    deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

    deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main
    Currently using: lubuntu lucid | Acer Aspire Ferrari Lucid | HP 6910p
    ChromiumOS | asus eee 901;
    LinuxMint 8 | DELL Latitude d510

  6. #16
    Join Date
    May 2005
    Location
    Indiana
    Beans
    1,935
    Distro
    Hardy Heron (Ubuntu Development)

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    Quote Originally Posted by lewmnik View Post
    If you are using oneiric:

    GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos

    deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main

    deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main
    Wow! That did the trick. Thank you. I was searching for a solution earlier today.

    A side note: for anyone who has installed a ppa that ends up having problems, and you'd just like to be able to at least go back to old versions, there is a package in the repos called ppa-purge that is pretty helpful with that.
    Today you are You, that is truer than true. There is no one alive who is Youer than You. - Dr. Seuss

  7. #17
    Join Date
    Mar 2007
    Location
    Sydney, Australia
    Beans
    231
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    I have the same problem but this solution didn't work for me. The download progressed normally, including those from the repositories mentioned above. However, when I tried to run Gimp, I got the message:

    "Gtk+ version too old (micro mismatch)

    GIMP requires GTK+ version 2.24.7 or later.
    Installed GTK+ version is 2.24.6.

    Somehow you or your software packager managed
    to install GIMP with an older GTK+ version.

    Please upgrade to GTK+ version 2.24.7 or later."

    Any thoughts?

  8. #18
    Join Date
    Nov 2005
    Location
    Helsinki, Finland
    Beans
    29
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    Quote Originally Posted by Buster95 View Post
    I have the same problem but this solution didn't work for me. The download progressed normally, including those from the repositories mentioned above. However, when I tried to run Gimp, I got the message:

    "Gtk+ version too old (micro mismatch)

    GIMP requires GTK+ version 2.24.7 or later.
    Installed GTK+ version is 2.24.6.

    Somehow you or your software packager managed
    to install GIMP with an older GTK+ version.

    Please upgrade to GTK+ version 2.24.7 or later."

    Any thoughts?
    Not being cheeky, but did you first:
    Code:
    sudo apt-get upgrade
    before reinstalling gimp?
    Currently using: lubuntu lucid | Acer Aspire Ferrari Lucid | HP 6910p
    ChromiumOS | asus eee 901;
    LinuxMint 8 | DELL Latitude d510

  9. #19
    Join Date
    Feb 2012
    Beans
    2

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    from: https://launchpad.net/~matthaeus123/...e/mrw-gimp-svn





    GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos
    deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main
    deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main

  10. #20
    Join Date
    Jan 2009
    Beans
    54

    Re: GIMP 2.7.5 dependencies on Ubuntu 11.10 x64

    Quote Originally Posted by eMirage View Post
    from: https://launchpad.net/~matthaeus123/...e/mrw-gimp-svn

    GIMP 2.7.5 Will not work with the current glib and gtk in Oneiric. To fix the problem install these repos
    deb http://ppa.launchpad.net/gnome3-team/gnome3/ubuntu oneiric main
    deb http://ppa.launchpad.net/ricotz/testing/ubuntu oneiric main
    After doing that, gimp installed but unable to launch because it lacked then another lib gtk+ 2.24.7 (I could not find it anywhere).
    BUT: also after add these two reps I had then this Nautilus:



    So I recovered Ubuntu from a backup I did with Acronis days ago, and I will not permit a partial update never again.

Page 2 of 7 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •