Results 1 to 5 of 5

Thread: Can't enable Hibernate option in menu

  1. #1
    Join Date
    Apr 2007
    Location
    NH USA
    Beans
    1,264
    Distro
    Ubuntu Development Release

    Can't enable Hibernate option in menu

    I'm running Ubuntu 13.04, all up to date. After testing my system with pm-hibernate (it worked perfectly), I created the policy file 'hibernate.pkla' in /var/lib/polkit-1/localauthority/50-local.d/ as described on several websites. Steill no hibernate item in the menu. Any ideas?

  2. #2
    Join Date
    Jun 2007
    Beans
    12,939

    Re: Can't enable Hibernate option in menu

    Works ok here though instead of creating a new .pkla just edited the one where it's disabled by default.
    Code:
    sudo nano  /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla
    There are 2 overrides there, don't think the 2nd one matters much (logind) though wouldn't hurt to also enable

    Otherwise it wouldn't show up if it didn't see an active swap or maybe active swap of a min. size? (your fstab is correct?

  3. #3
    Join Date
    Apr 2007
    Location
    NH USA
    Beans
    1,264
    Distro
    Ubuntu Development Release

    Re: Can't enable Hibernate option in menu

    I tried your suggestion, but still no joy. I've got plenty of swap - actually a tinch more than my 4GB of RAM, and it is activated. Like I said, pm-hibernate works fine.

    Strange. Any other ideas?

  4. #4
    Join Date
    Jun 2007
    Beans
    12,939

    Re: Can't enable Hibernate option in menu

    Forgot that you likely are using gnome-shell which doesn't have hibernate available in the session menu.
    Maybe an extension such as
    https://extensions.gnome.org/extensi...e-status-menu/

  5. #5
    Join Date
    Apr 2007
    Location
    NH USA
    Beans
    1,264
    Distro
    Ubuntu Development Release

    Re: Can't enable Hibernate option in menu

    Indeed I'm using Gnome Shell, and I've tried Alternative Status Menu, which purports to put Suspend and Hibernate on the status menu. It puts Suspend there, but not Hibernate. Oh well, typing 'pm-hibernate' once or twice a week is not such a big deal

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •