Results 1 to 3 of 3

Thread: change document root in lamp

  1. #1
    Join Date
    Nov 2009
    Beans
    145

    change document root in lamp

    Hi there!! I can not change the document Root in apache (LAMP). I follow the steps in https://help.ubuntu.com/community/Ap...#Virtual_Hosts.

    I change the default "/www/var" to "/home/jesus/Dropbox/htdocs/" in the file "mysite" (copy of default).

    But when I type the url: "localhost/index.html" I get the error message:

    Code:
    Forbidden
    
    You don't have permission to access /index.html on this server.
    And I am pretty sure index.html exists.

    What's the problem??

    Thank you very much!!

  2. #2
    Join Date
    Sep 2006
    Beans
    8,623
    Distro
    Ubuntu 14.04 Trusty Tahr

    directory permissions

    Have you checked that Other has read permissions to those directories?

    Code:
    chmod o=rx /home/jesus/Dropbox/htdocs/
    chmod o=rx /home/jesus/Dropbox/
    chmod o=rx /home/jesus/

    Then you also need to have set Directory permissions in Apache for the relevant virtual host's configuration file.


    Code:
    <Directory /home/jesus/Dropbox/htdocs/>
          Options Indexes FollowSymLinks MultiViews
          AllowOverride None
          Order allow,deny
          allow from all
    </Directory>

  3. #3
    Join Date
    Nov 2009
    Beans
    145

    Re: change document root in lamp

    HI Lars Noodén!!! Now it works!!!! you are right, it was a permission problem!! Thank you very very much!!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •