Page 5 of 5 FirstFirst ... 345
Results 41 to 42 of 42

Thread: After installing NVIDIA drivers, boots directly to blank screen

  1. #41
    Join Date
    Dec 2009

    Re: After installing NVIDIA drivers, boots directly to blank screen

    After about 5 tries, I was able to get the GRUB menu loaded. Holding <shift> didn't seem to work, and repeatedly tapping shift only sometimes seems to work. It must be a really narrow window.

    Anyway, I tried rebooting with graphics settings set to default and that didn't work. Still got to the blank-screen/flashing-login cycle.

    The Xorg.0.log file has the same messages as it did before with 11.10. I now also have Xorg.1.log and Xorg.99.log files as well. the Xorg.1.log shows it trying a bunch of different resolution/refresh-rate combos and failing. I can post those contents if desired. None of the attempted resolutions are the appropriate 1080p, for some reason.

  2. #42
    Join Date
    Jan 2011

    Re: After installing NVIDIA drivers, boots directly to blank screen

    It is possible that something being run when X starts is killing Xorg almost immediately if the nvidia driver is used alone (explanation below).

    I've noticed with the more recent Xorg's, that you don't actually need an xorg.conf for nvidia cards. In fact, having one can do more harm than good in certain circumstances.

    If you remove xorg.conf (or never have one to begin with), when Xorg starts, it will sequentially load just about every driver that it could possibly use for your hardware, then use some heuristics to decide which is best, then unload everything else. Without an xorg.conf, Xorg will start up with the native resolution, and you can use xrandr to set it to something else

    On my system it is essential for me to run without an xorg.conf.

    If I have an xorg.conf that was created by the nvidia software (or even one handcrafted for the Nvidia hardware), then as soon as I run certain programs, such as emacs or VirtualBox (or who knows what else), Xorg gets a segmentation violation (). This has been a problem for me ever since I installed Ubuntu (at 10.04), and I discovered the following after upgrading to 11.04:

    If, on the other hand, I do not have an xorg.conf, after Xorg goes through the process of loading all those drivers and then unloading all of them except for nvidia-current, something seems to get initialized that prevents emacs or Virtualbox (or who knows what else) from triggering an Xorg SEGV.

    Of course, this does not help if you need to configure multiple monitors .

    Interestingly, I do not need to remove xorg.conf on an older system that has a card which requires the nvidia-96 driver. On that system, Xorg never gets this SEGV.

Page 5 of 5 FirstFirst ... 345


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts