Hi, I'm new in the formun, I only had the the same problem, maybe a bit different. I have read all the post and reply locking for my solution.


Y installed Ubuntu 12.04 LTS in the mi asus k52f which comes with windows home premium OA.

Then my windows started to get bad and I decided to use de recovery partition with F9 but doesnt work, GRUB always started first.

But in my options of grub there was one to boot with the recovery partition. But when was starting my computer always failed and restart automatically, so I always couldn't restore it.

Then I stupidly decide to make de four DVDs with AI Burner (obviously y did the back of al my important data), y boot with those DVD, but after that my windows still the same. Then I realized that the back up was of my actual state of windows.

I was locking for solutions to this and I founded this http://www.youtube.com/watch?v=u0iEDk6n23k

But Then I decided to give one more oportunity to boot from GRUB in the restore partition, I thought that maybe the last stupid change fixed what was happennig (the failure and restart)
And Finaly Yes! It worked.

I used this option Recover Windows to first partition only. , and didnt make changes of ubuntu, only on windows partition, that was what i wanted.


Conclusion: Using the AI Recovery burner was not so stupid and finally coud start the recovery partition. Maybe isn't the solution to the problem of last year of dsurfer21. Because in his situation the partition didn't appear in the options. In my case the differnce was that it appeared but didnt work.

One unique problem:When I start the windows from Grub it throws one Error "No such device ............." I dont know why but then works fine, tipping any key. Maybe in the future will fix it some way. The owner of the notebook is my uncle, he was who wanted the recovery, if it was my decision i would have decide to format the partition and install windows and the drivers manually.

Spect to help someone.
Apologises about my english.
Good Lock!