Results 1 to 6 of 6

Thread: Java is not enabled or Java is not installed on your machine. Please, enable Java

  1. #1
    Join Date
    Apr 2007
    Location
    Out in Left Field
    Beans
    919
    Distro
    Ubuntu 14.04 Trusty Tahr

    Java is not enabled or Java is not installed on your machine. Please, enable Java

    I have signed up for a practice brokerage account with Questrade http://www.questrade.com , When I log on I get the following message
    Java is not enabled or Java is not installed on your machine. Please, enable Java in your browser or install Java.
    I have looked in my Firefox (10.0.1) settings in preference and it appears as though Java is enabled (Under Content Javascript is checked).

    Before I decide whether I want to use this brokerage I need to know how to correct the error message. Any help would be appreciated.

    I believe I have Java 6 installed on my machine but I am not sure how to verify this

  2. #2
    Join Date
    Feb 2011
    Location
    new york state
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Java is not enabled or Java is not installed on your machine. Please, enable Java

    Do you have JRE installed ? here is a LINK could be many other things also. but try that first if no workie please post all error's
    thanks
    Power tends to corrupt, and absolute power corrupts absolutely. Great men are almost always bad men, even when they exercise influence and not authority

  3. #3
    Join Date
    Sep 2011
    Location
    Wherever I go, Here I am
    Beans
    Hidden!
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Java is not enabled or Java is not installed on your machine. Please, enable Java

    I use this PPA
    Then
    Code:
    sudo apt-get install sun-java6
    Please mark your thread as Solved when appropriate || My WIKI
    ---------------------------


  4. #4
    Join Date
    Apr 2005
    Location
    Sydney, Australia
    Beans
    61
    Distro
    Ubuntu

    Re: Java is not enabled or Java is not installed on your machine. Please, enable Java

    Some Java apps will only run with Sun Java, not an open Java. Also, it's handy to install the JDK, so I usually install "sun-java6-jdk" (this will include the java-jre).

    You may also have to setup various env vars in your ~/.bashrc:

    export JAVA_HOME="/usr/lib/jvm/java-6-sun/jre"
    export PATH="$PATH:$JAVA_HOME/bin"

  5. #5
    Join Date
    Jan 2007
    Beans
    6,542
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Java is not enabled or Java is not installed on your machine. Please, enable Java

    Quote Originally Posted by SuperFreak View Post
    I have looked in my Firefox (10.0.1) settings in preference and it appears as though Java is enabled (Under Content Javascript is checked).
    Java and Javascript are two completely different things (I know, it's confusing). You need to install Java seperately if you haven't already. It's included in ubuntu-restricted-extras, which is a handy package to install, or you can install it seperately by installing icedtea6-plugin.

  6. #6
    Join Date
    Apr 2007
    Location
    Out in Left Field
    Beans
    919
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Java is not enabled or Java is not installed on your machine. Please, enable Java

    Thanks everyone for your replies. I went to https://help.ubuntu.com/community/AM...efoxAndPlugins for directions on installing sun-java6-plugin and it seems to work fine now.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •