Results 1 to 6 of 6

Thread: Catalyst 12.1 released (fglrx 8.930)

  1. #1
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Catalyst 12.1 released (fglrx 8.930)

    OK people, another month another Catalyst.

    Download is here: http://www2.ati.com/drivers/linux/am...x86.x86_64.run

    Tip! For a simple ramdisk, use /dev/shm !

    As normal, I run:

    $ chmod +x amd-driver-installer-12-1-x86.x86_64.run
    $ ./amd-driver-installer-12-1-x86.x86_64.run --buildpkg Ubuntu/precise
    $ sudo dpkg -i *.deb

    then copy the .debs somewhere for safekeeping.

    Installation proceeds as expected (no errors). Will reboot and see how it goes. According to a Phoronix thread linked from the Arch catalyst AUR page this release fixes rendering in gnome-shell. We'll see about that.
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  2. #2
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: Catalyst 12.1 released (fglrx 8.930)

    Well, there are no graphical glitches in gnome-shell, which is nice. Window dragging is still laggy as anything, though, but this is a problem with VSYNC (surprise!). I'm looking into how to disable vsync by default; there has to be a better way than running

    $ CLUTTER_VBLANK=none gnome-shell --replace
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  3. #3
    Join Date
    Feb 2007
    Location
    Rome, Italy
    Beans
    2,184

    Re: Catalyst 12.1 released (fglrx 8.930)

    Quote Originally Posted by jfernyhough View Post
    Well, there are no graphical glitches in gnome-shell, which is nice. Window dragging is still laggy as anything, though, but this is a problem with VSYNC (surprise!). I'm looking into how to disable vsync by default; there has to be a better way than running

    $ CLUTTER_VBLANK=none gnome-shell --replace
    great to hear catalyst now supports gnomeshell without glitches.. I see many in the past especially in the menu with distorted textures.

    usually I put that clutter_vblank export in /etc/environment to use apply it at boot time.

  4. #4
    Join Date
    Aug 2009
    Location
    College Place, WA
    Beans
    13
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Smile Re: Catalyst 12.1 released (fglrx 8.930)

    Thanks so much! Using the CLUTTER_VBLANK=none fixed my only video problems in 12.1. Gnome-shell is buttery smooth with no graphical glitches. Plus, all my graphics intensive programs (eg Minecraft) are working better than ever!

    Thanks again @jfernyhough!

  5. #5
    Join Date
    Aug 2006
    Location
    Just call me JF
    Beans
    1,052
    Distro
    Ubuntu Development Release

    Re: Catalyst 12.1 released (fglrx 8.930)

    Nice... just found an addition to the Arch ATI wiki page...

    Quote Originally Posted by Arch wiki
    Add this line:
    export CLUTTER_VBLANK=none
    into ~/.profile or into /etc/profile file. Restart X server or reboot system.
    I didn't fancy messing with /etc/environment . (plus I'm sure I tried that and it didn't work for me... anyway, .profile works well)
    1) Dell Studio 1749: i5 540 (2.5GHz), 8GB, ATi 5650, Intel 5300AGN XFCE@Manjaro-x64
    2) Lenovo X61: C2D T7200, 2GB, Intel HDA, iwlwifi, XFCE@Manjaro-x64
    3) Compaq Mini 311c: Atom N270 (OC@2.0GHz), 3GB, Nvidia ION, Broadcom G+BT XFCE@13.10x32

  6. #6
    Join Date
    Jul 2006
    Location
    Johannesburg, South Afric
    Beans
    31
    Distro
    Ubuntu

    Re: Catalyst 12.1 released (fglrx 8.930)

    Issues playing video with latest catalyst drivers:

    http://ati.cchtml.com/show_bug.cgi?id=337#c7

    Not a solution but a workaround; add the following snippet to your
    /etc/X11/xorg.conf, that way the crashy code won't be executed:

    Section "Extensions"
    Option "XVideo" "Disable"
    EndSection

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •