Results 1 to 6 of 6

Thread: Problem installing libapache2-mod-php5

  1. #1
    Join Date
    Nov 2009
    Location
    new delhi
    Beans
    10

    Problem installing libapache2-mod-php5

    So I was installing LAMP (I installed everything separately). Problem is, I keep getting stuck at this message while installing libapache2-mod-php5:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:

    The following packages have unmet dependencies:
    libapache2-mod-php5 : Depends: php5-common (= 5.3.5-1ubuntu7) but 5.3.5-1ubuntu7.4 is to be installed
    E: Broken packages
    I found some solutions via Google, like apt-get update, and using the -f option. Nothing has worked so far. I'd appreciate any help.

    I'm using Natty.

  2. #2
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,839
    Distro
    Ubuntu Development Release

    Re: Problem installing libapache2-mod-php5

    open your synaptic manager and at the bottom read message . then try to fix that broken packages from there .

    or

    in terminal

    sudo apt-get install -f

    give me that output here

    thank you.
    Google First your issue , if no solution then ask.

    రాజ శేఖర్ రెడ్డి

  3. #3
    Join Date
    Nov 2009
    Location
    new delhi
    Beans
    10

    Re: Problem installing libapache2-mod-php5

    Hi! Sorry for the late reply.

    I don't get any message as I open the Synaptic Package Manager.

    Sudo apt-get install -f gives this output:

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    git-man liberror-perl
    Use 'apt-get autoremove' to remove them.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    Thanks!

  4. #4
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,839
    Distro
    Ubuntu Development Release

    Re: Problem installing libapache2-mod-php5

    ok now try again to install that required package .

    let us know what you got .
    Google First your issue , if no solution then ask.

    రాజ శేఖర్ రెడ్డి

  5. #5
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,839
    Distro
    Ubuntu Development Release

    Re: Problem installing libapache2-mod-php5

    look for that required dependencies packages from ubuntu packages and install them

    sudo dpkg -i name.deb
    Google First your issue , if no solution then ask.

    రాజ శేఖర్ రెడ్డి

  6. #6
    Join Date
    Nov 2009
    Location
    new delhi
    Beans
    10

    Re: Problem installing libapache2-mod-php5

    Hi
    So I guess the problem was that the dependency php-common was the one conflicting. I removed it from synaptic, and tried again, and there was no problem!

    Thanks for helping me out!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •