Results 1 to 8 of 8

Thread: mounting issues

  1. #1
    Join Date
    Jun 2008
    Location
    here,...always here...
    Beans
    46
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Red face mounting issues

    I am running Ubuntu 10.04
    I have a hard drive that I use to keep all my stuff protected in case my primary which has my OS installed on it, decides to fail.
    Along with all my stuff is my music library
    Whenever I restart my computer, I have to open the hard drive to get my music program to see my library. If I log out and back in then It works fine but every time I reboot it's like something resets.
    I thought it was a mounting issue so I installed pysdm and followed some instructions I found on a ubuntu tips and tricks article. made things slightly worse as I can't unmount the drive by right clicking. When I do I get this message
    Error unmounting: umount exited with exit code 1: helper failed with:
    umount: only root can unmount /dev/sdb1 from /media/sdb1
    but I can unmount it through pysdm
    Is there any way to fix this problem and make so I don't have to open the hard drive myself to get my music program (and all other programs) to see it?
    Much appreciated and if this is in the wrong section, feel free to move it to the correct one.
    Then God said, “Let there be light,” and there was light.
    And God saw that the light was good.

  2. #2
    Join Date
    May 2010
    Location
    Lancaster, UK
    Beans
    315
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mounting issues

    Have you included the drive in your fstab file? If you have please post it here because I think there must be an error in it. If not, the below link explains how to do it. Once done the drive should automatically mount everytime you boot up.

    https://help.ubuntu.com/community/Fstab
    Last edited by carranty; January 21st, 2012 at 01:22 PM.

  3. #3
    Join Date
    Dec 2009
    Beans
    5,364

    Re: mounting issues

    I don't understand the nature of the problem.

    You want to have the partition automount so you used PySDM. Now you want to be able to unmount it as a regular user? If you want it to automount why do you want to unmount it? The "only root can unmount" is not an error message it's a statement of fact.

    I'm confused.

  4. #4
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,826
    Distro
    Ubuntu Development Release

    Re: mounting issues

    First uninstall that pysdm (better go for purging for complete removal). Then install it again, but this time be careful with configuration of it .

    I hope this link can provide some more valuable inforamtion.
    http://ubuntuforums.org/archive/inde...t-1309751.html

    All the best.
    Raja

    రాజ శేఖర్ రెడ్డి

  5. #5
    Join Date
    Jun 2008
    Location
    here,...always here...
    Beans
    46
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: mounting issues

    this is what my fstab file looks like, it is on Sdb1. any changes that could be made to this to fix it?

    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda6 during installation
    UUID=e8b8b14f-1769-4d02-920b-1d2f3d220b7f / ext4 defaults 0 1
    # swap was on /dev/sda7 during installation
    UUID=70f2ad83-db48-411d-9e20-bb231ca20813 none swap sw 0 0
    /dev/sdb1 /media/sdb1 ext3 errors=remount-ro 0 0
    /dev/sda1 /media/sda1 ntfs defaults 0 0
    Then God said, “Let there be light,” and there was light.
    And God saw that the light was good.

  6. #6
    Join Date
    Jun 2008
    Location
    here,...always here...
    Beans
    46
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: mounting issues

    Quote Originally Posted by Morbius1 View Post
    I don't understand the nature of the problem.

    You want to have the partition automount so you used PySDM. Now you want to be able to unmount it as a regular user? If you want it to automount why do you want to unmount it? The "only root can unmount" is not an error message it's a statement of fact.

    I'm confused.

    I thought psydm would be able to make so I wouldn't have to open Sdb1 every time I reboot my system. I don't recall it ever telling em I couldn't unmount a drive like that before (I may be wrong though)
    The main objective here is to be able to turn my computer on, and open and run my music program without having to open the drive where all my music is located first. maybe I don't need psydm, I'm not sure at this point.
    Then God said, “Let there be light,” and there was light.
    And God saw that the light was good.

  7. #7
    Join Date
    May 2010
    Location
    Lancaster, UK
    Beans
    315
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: mounting issues

    Quote Originally Posted by tru infini View Post
    this is what my fstab file looks like, it is on Sdb1. any changes that could be made to this to fix it?

    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc nodev,noexec,nosuid 0 0
    # / was on /dev/sda6 during installation
    UUID=e8b8b14f-1769-4d02-920b-1d2f3d220b7f / ext4 defaults 0 1
    # swap was on /dev/sda7 during installation
    UUID=70f2ad83-db48-411d-9e20-bb231ca20813 none swap sw 0 0
    /dev/sdb1 /media/sdb1 ext3 errors=remount-ro 0 0
    /dev/sda1 /media/sda1 ntfs defaults 0 0
    Try replacing the second to last line with
    Code:
    /dev/sdb1      /media/sdb1  ext3 defaults    0  0
    Also, it's better to identify drives by their UUID, rather than the /dev/sdb1 term. To get the UUID simply mount the drive (by opening it with your file browser) and then enter the below into a terminal
    Code:
    sudo blkid | grep /dev/sdb1
    Then just copy and paste the UUID into your fstab. For instance in my case

    Code:
    carranty@carranty-desktop ~/test $ sudo blkid | grep /dev/sdb1
    /dev/sdb1: UUID="4f754843-a651-4329-b8b7-1b8a9f03a861" TYPE="ext3"
    Therefore in my fstab the line would be

    Code:
     UUID=4f754843-a651-4329-b8b7-1b8a9f03a861 /media/sdb1  ext3 defaults    0  0
    Note that you do not copy the quotation marks.
    Last edited by carranty; January 21st, 2012 at 06:50 PM.

  8. #8
    Join Date
    Jun 2008
    Location
    here,...always here...
    Beans
    46
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: mounting issues

    That did it. much appreciated.
    I'll change the thread to [solved]
    Then God said, “Let there be light,” and there was light.
    And God saw that the light was good.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •