Results 1 to 8 of 8

Thread: Precise 12.04 Skype non-ascii font problem

  1. #1
    Join Date
    Oct 2009
    Location
    Belgrade, RS
    Beans
    180
    Distro
    Ubuntu 12.04 Precise Pangolin

    Precise 12.04 Skype non-ascii font problem

    I'm having some strange problem with text in Skype. Please look at the screenshot:



    Latin ASCII text is displayed correctly, while non-ascii characters are not. Specifically, Cyrillic characters are displayed in a smaller less visible font with Serbian specific Cyrillic characters (љ,њ,ј,ђ,ћ,џ) being substituted with boxes.

    That problem exists in Contacts list, in the messages area (both typing and displaying), Options windows and basically everywhere in Skype where there's any text.

    I tried changing the Style option in Skype's General Options, but no result.

    Any ideas? Thanks.
    Томица / Tomica ['tomitsa]

  2. #2
    Join Date
    Mar 2012
    Beans
    1

    Re: Precise 12.04 Skype non-ascii font problem

    I also have this problem with Skype. Some non-russian cyrillic characters are displayed as boxes [ ј њ љ ќ џ ѕ ѓ ]

  3. #3
    Join Date
    Oct 2009
    Location
    Belgrade, RS
    Beans
    180
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Precise 12.04 Skype non-ascii font problem

    Quote Originally Posted by GrEEnMK View Post
    I also have this problem with Skype. Some non-russian cyrillic characters are displayed as boxes [ ј њ љ ќ џ ѕ ѓ ]
    Non-russian Cyrillic letters are not showing because they're missing from the font used to display Cyrillic text. What's bothering me is why is Skype using different fonts to display Latin and non-latin text, even though it is set to use System Defaults. This is very annoying, because the second font is much smaller, and having to guess what letter should stand instead of a box is dumb.
    Томица / Tomica ['tomitsa]

  4. #4
    Join Date
    Jan 2009
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Precise 12.04 Skype non-ascii font problem

    Thread moved to Ubuntu +1

  5. #5
    Join Date
    Mar 2012
    Beans
    1

    Re: Precise 12.04 Skype non-ascii font problem

    Install qt4-qtconfig and set there appropriate font (ex. Ubuntu font) for your qt applications.

  6. #6
    Join Date
    Oct 2009
    Location
    Belgrade, RS
    Beans
    180
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Precise 12.04 Skype non-ascii font problem

    dilshodm thanks for the info. I did that, but it didn't work. In qt4-qtconfig Ubuntu font was already selected, and my Skype is still not showing non-ascii characters in Ubuntu font. I even tried using the provided font substitution option, but no luck.

    EDIT: No, I was wrong. Your soultion does work. Exactly what I needed! Why did it take you so long?! Thanks a lot.

    Also, it was not a good thing to move this thread to Ubuntu+1 section, because it's not a problem specific to Precise. It exists in Oneiric as well, and I only mentioned Precise because that's the version I'm currently using.
    Last edited by Томица; March 10th, 2012 at 08:34 AM.
    Томица / Tomica ['tomitsa]

  7. #7
    Join Date
    Jan 2009
    Beans
    3

    Angry Re: Precise 12.04 Skype non-ascii font problem

    Томица, what did you actually do to solve the problem? I have exactly the same issue: cyrrilic letters are shown in a weird font. I can read them but they all have different heights and widths.

    I installed qt4-config package, launched qtconfig-qt4 and made sure that font named "Ubuntu" is selected. Qtconfig's font preview shows cyrrilic letters in a nice way, but skype seems to completely ignore those settings. What am I doing wrong?

  8. #8
    Join Date
    Oct 2009
    Location
    Belgrade, RS
    Beans
    180
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Precise 12.04 Skype non-ascii font problem

    Try restarting Skype. There shouldn't be any tricky parts. I did just what dilshodm said: installed qt4-config, set my font to Ubuntu, style to Medium, size to 11. Oh yeah, and don't forget to save your settings (ctrl+S) before you close QT4-Config. Then restart Skype and see if it helps.
    Томица / Tomica ['tomitsa]

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •