Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 45

Thread: Need Expert advice how to proceed, newbie level user.

  1. #11
    Join Date
    May 2007
    Beans
    76

    Re: Need Expert advice how to proceed, newbie level user.

    Referring to your #7 post, I ran mythtv-setup from the shell. I get a screen to choose English US, next page Configuration 1/2. First entry says "MythTV could not connect to the database. Please verify your database settings below." At this point I do not know what to do.

    I Googled "mythtv-setup". http://www.mythtv.org/wiki/Mythtv-setup

    It suggest that running "mythtv-setup", a gui menu should appear offering the following options: General, Capture Cards, Video sources, Input connections, Channel Editor, Storage Directories, and System Events.

    I do not get this at all. The first screen opens with Country on the left "United States" and Language on the right "English (United States). I click 'save'. The next screen has a small box in the center of the screen that says No/UPnP/OK. I click on that box and the next screen says: Screen title, "Database Configuration 1/2"

    First entry says, " MythTV could not connect to the database. Please verify your database settings below. Required fields are marked with an asterisk (*).

    Next title says, "Database Server Settings"
    *Hostname: localhost
    x Ping test server? Port: 'empty'
    Database name: mythconverg
    User: mythtv
    Password: mythtv
    Next

    I click on next and get title, "Database Configuration 2/2
    x Use custom identifier for frontend preferences (not required, so I do not check it. The x is to show there is a checkbox.)
    x Enable database server wakeup (again not required, so I do not check it.)

    The final entry is "Finish" in the lower right corner of the screen. I click on "Finish" and the screen returns to the previous page.

    If I have made any changes on page 1/2, they return to the default entries I showed above.

    The only way I can get the screen that is described in the mythtv tutorial is to open it using sudo.

    When it opens, the "Backend Setup" shows my IP address: 192.168.0.111, Port as 6543, Status Port as 6544, Security PIN as 0000, then the title Master Backend and my IP address and port.

    When I close "sudo mythtv-setup", a window appears that says, "Would you like to start the mythtv backend? I click No and a window appears that says, "Would you like to run mythfilldatabase, what I describe when I open NOT in sudo or what I get when I open in sudo?

    What should I get for a screen when I run 'mythtv-setup' from the command line?

  2. #12
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Need Expert advice how to proceed, newbie level user.

    Quote Originally Posted by Shabakthanai View Post
    Referring to your #7 post, I ran mythtv-setup from the shell. I get a screen to choose English US, next page Configuration 1/2. First entry says "MythTV could not connect to the database. Please verify your database settings below." At this point I do not know what to do.

    I Googled "mythtv-setup". http://www.mythtv.org/wiki/Mythtv-setup

    It suggest that running "mythtv-setup", a gui menu should appear offering the following options: General, Capture Cards, Video sources, Input connections, Channel Editor, Storage Directories, and System Events.

    I do not get this at all. The first screen opens with Country on the left "United States" and Language on the right "English (United States). I click 'save'. The next screen has a small box in the center of the screen that says No/UPnP/OK. I click on that box and the next screen says: Screen title, "Database Configuration 1/2"

    First entry says, " MythTV could not connect to the database. Please verify your database settings below. Required fields are marked with an asterisk (*).

    Next title says, "Database Server Settings"
    *Hostname: localhost
    x Ping test server? Port: 'empty'
    Database name: mythconverg
    User: mythtv
    Password: mythtv
    Next
    you need to put in the correct password. It was randomly generated and reported to you when you first set up mythtv from the ubuntu packages. Look in /home/USER/.mythtv/mysql.txt and /root/.mythtv/mysql.txt and see if the password is in there. (Where USER = your user name)

    I click on next and get title, "Database Configuration 2/2
    x Use custom identifier for frontend preferences (not required, so I do not check it. The x is to show there is a checkbox.)
    x Enable database server wakeup (again not required, so I do not check it.)

    The final entry is "Finish" in the lower right corner of the screen. I click on "Finish" and the screen returns to the previous page.

    If I have made any changes on page 1/2, they return to the default entries I showed above.

    The only way I can get the screen that is described in the mythtv tutorial is to open it using sudo.

    When it opens, the "Backend Setup" shows my IP address: 192.168.0.111, Port as 6543, Status Port as 6544, Security PIN as 0000, then the title Master Backend and my IP address and port.

    When I close "sudo mythtv-setup", a window appears that says, "Would you like to start the mythtv backend? I click No and a window appears that says, "Would you like to run mythfilldatabase, what I describe when I open NOT in sudo or what I get when I open in sudo?

    What should I get for a screen when I run 'mythtv-setup' from the command line?
    Last edited by nickrout; January 16th, 2012 at 03:47 AM.

  3. #13
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Need Expert advice how to proceed, newbie level user.

    PS you can re-set up the password by running the following commands in a terminal:

    Code:
    sudo dpkg-reconfigure mythtv-database
    answer yes to the question posed

    Code:
    sudo dpkg-reconfigure mythtv-common
    the first question Database to be used to hold MythTV data" - the answer is mythconverg (should be the default)

    The second question Username used by MythTV to access its database: - answer is mythtv (should be the default)

    The third question Password used by MythTV to access its database you can leave blank, and get a random password, or insert something you can remeber, i suggest you do the latter and use mythtv for the password.

    Then when you start mythtv-setup OR mythfrontend, you will know what the password is supposed to be.

    PS there is a 4th question about what computer the database is on, leave this as localhost
    Last edited by nickrout; January 16th, 2012 at 04:36 AM.

  4. #14
    Join Date
    May 2007
    Beans
    76

    Re: Need Expert advice how to proceed, newbie level user.

    I applied your instructions, including changing the password and Host. The result was just more of the same that I have been experiencing.

    I did an additional google search and came up with this website:

    /wiki/User_Manualetailed_configuration_Frontend#Database_Configurat ion_1.2F2I

    Since using the 'localhost' did not work, I tried 127.0.0.1. There was a place for a pin number that was different from the manual, so I changed it to 0000 as advised. As a result of these changes, I have been able to configure the frontend and lock about 18 channels. I used the manual settings throughout the process, however when it came to starting the TV, I got an error that asked if the backend was working.

    There are so many parts to this installation, that I am unable to be absolutely certain, but there was a point prior to attempting to open the TV that I clicked 'Yes' if I wanted the backend started as well as mythfilldatabase, so I believe there is something that prevents front and backend from communicating.

    Is there some kind of command line entry that would help diagnose this part of the problem? Additionally, I am unable to get the selection of screen theme choices that were available before. As a result, I am unfamiliar with the theme I am using. It may not be important, but it would certainly help if I had the previous menu's to work with.

    I realise you must be frustrated with me, but I have been attempting to follow your instructions faithfully and still have probably made some mistakes. I will be grateful if you are willing to stay with me on this one. Thanks for your ongoing patience.

  5. #15
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Need Expert advice how to proceed, newbie level user.

    I think you mean you configured the backend to get 18 channels. Please be precise. mythtv-setup sets up the BACKend.

    Now you can't start the frontend? Try
    Code:
    ps aux|grep [b]ackend
    That will show if the backend is running. Here is my output:

    nick@dell:~$ ps aux|grep [b]ackend
    mythtv 2118 0.4 0.5 280596 7728 ? Sl Jan12 44:17 /usr/bin/mythbackend --logfile /var/log/mythtv/mythbackend.log --user mythtv
    By the way 'ps aux' lists all system processes, piping it though 'grep [b]ackend' searches for a process with the name including the name 'backend'

    If it is NOT running, start it with
    Code:
    sudo service mythtv-backend start
    Then run the ps command (as above) again to check it is running.

    Once you are sure the backend is running, run the frontend from the command line, and it will spit any debugging messages to the terminal you ran it from.
    Code:
    mythfrontend

  6. #16
    Join Date
    May 2007
    Beans
    76

    Re: Need Expert advice how to proceed, newbie level user.

    Here is what I got:

    steven@Yeshuah:~$ ps aux|grep [b]ackend
    mythtv 9568 0.0 0.9 578916 36832 ? Sl Jan17 1:06 /usr/bin/mythbackend --logfile /var/log/mythtv/mythbackend.log --user mythtv
    steven@Yeshuah:~$ mythfrontend
    2012-01-19 17:12:13.548 mythfrontend version: fixes/0.24 [v0.24.1-120-g294968b] www.mythtv.org
    2012-01-19 17:12:13.548 Using runtime prefix = /usr
    2012-01-19 17:12:13.548 Using configuration directory = /home/steven/.mythtv
    2012-01-19 17:12:13.548 Configuration::Load - Error parsing: /home/steven/.mythtv/config.xml at line: 1 column: 1
    2012-01-19 17:12:13.548 Configuration::Load - Error Msg: unexpected end of file
    2012-01-19 17:12:13.548 ThreadPool:HTTP: Initial 1, Max 25, Timeout 60000
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    2012-01-19 17:12:14.204 Unable to read configuration file mysql.txt
    2012-01-19 17:12:14.204 Empty LocalHostName.
    2012-01-19 17:12:14.204 Using localhost value of Yeshuah
    2012-01-19 17:12:14.204 Configuration::Load - Error parsing: /home/steven/.mythtv/config.xml at line: 1 column: 1
    2012-01-19 17:12:14.204 Configuration::Load - Error Msg: unexpected end of file
    2012-01-19 17:12:14.220 New DB connection, total: 1
    2012-01-19 17:12:14.222 Connected to database 'mythconverg' at host: localhost
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    Calling appendChild() on a null node does nothing.
    2012-01-19 17:12:14.225 Closing DB connection named 'DBManager0'
    2012-01-19 17:12:14.225 Connected to database 'mythconverg' at host: localhost
    2012-01-19 17:12:14.226 Current locale en_US
    2012-01-19 17:12:14.226 Reading locale defaults from /usr/share/mythtv//locales/en_us.xml
    2012-01-19 17:12:14.434 DPMS is disabled.
    2012-01-19 17:12:14.492 Desktop video mode: 3600x1080 60.000 Hz
    2012-01-19 17:12:14.542 Enabled verbose msgs: important general
    2012-01-19 17:12:14.561 Connecting to lcd server: 127.0.0.1:6545 (try 1 of 10)
    2012-01-19 17:12:14.563 Loading en_us translation for module mythfrontend
    2012-01-19 17:12:14.591 MythUIHelper, Warning: No theme dir: '/usr/share/mythtv/themes/Mythbuntu'
    2012-01-19 17:12:14.591 Could not find theme: Mythbuntu - Switching to Terra
    2012-01-19 17:12:14.592 Desktop video mode: 3600x1080 60.000 Hz
    2012-01-19 17:12:14.595 Trying 640x480 0.000 Hz
    DisplaResX: Desired Resolution and FrameRate not found.
    2012-01-19 17:12:14.595 SwitchToGUI: xrandr failed for 640x480 0.000 Hz
    2012-01-19 17:12:14.637 LIRC: Successfully initialized '/dev/lircd' using '/home/steven/.mythtv/lircrc' config
    2012-01-19 17:12:14.637 JoystickMenuThread: Joystick disabled - Failed to read /home/steven/.mythtv/joystickmenurc
    2012-01-19 17:12:14.700 Using Frameless Window
    2012-01-19 17:12:14.700 Using Full Screen Window
    2012-01-19 17:12:14.703 Using the OpenGL painter
    2012-01-19 17:12:14.801 OpenGL: OpenGL vendor : NVIDIA Corporation
    2012-01-19 17:12:14.801 OpenGL: OpenGL renderer: GeForce GTX 460/PCI/SSE2
    2012-01-19 17:12:14.801 OpenGL: OpenGL version : 4.1.0 NVIDIA 270.41.06
    2012-01-19 17:12:14.801 OpenGL: Max texture size: 16384 x 16384
    2012-01-19 17:12:14.801 OpenGL: Max texture units: 4
    2012-01-19 17:12:14.801 OpenGL: Direct rendering: Yes
    2012-01-19 17:12:14.801 OpenGL: Initialised MythRenderOpenGL
    2012-01-19 17:12:15.407 Current MythTV Schema Version (DBSchemaVer): 1264
    2012-01-19 17:12:16.299 ThemeInfo, Warning: Unable to open themeinfo.xml for /usr/share/mythtv/themes/BlackCurves-OSD/themeinfo.xml
    2012-01-19 17:12:16.299 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/BlackCurves-OSD) is missing a themeinfo.xml file.
    2012-01-19 17:12:16.317 ThemeInfo, Warning: Unable to open themeinfo.xml for /usr/share/mythtv/themes/Gray-OSD/themeinfo.xml
    2012-01-19 17:12:16.317 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/Gray-OSD) is missing a themeinfo.xml file.
    2012-01-19 17:12:16.616 Registering Internal as a media playback plugin.
    2012-01-19 17:12:16.639 No plugins directory /usr/lib/mythtv/plugins
    2012-01-19 17:12:16.654 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.654 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.654 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.655 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.655 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.655 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.656 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.657 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.657 MediaMonitorUnix::AddDevice() - empty device path.
    2012-01-19 17:12:16.831 Found mainmenu.xml for theme 'Terra'
    2012-01-19 17:12:17.124 MythCoreContext: Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
    2012-01-19 17:12:17.124 Using protocol version 63
    2012-01-19 17:12:26.999 TV: Attempting to change from None to WatchingLiveTV
    2012-01-19 17:12:26.999 MythCoreContext: Connecting to backend server: 127.0.0.1:6543 (try 1 of 1)
    2012-01-19 17:12:27.000 Using protocol version 63
    2012-01-19 17:12:27.048 Spawning LiveTV Recorder -- begin
    2012-01-19 17:12:27.304 Spawning LiveTV Recorder -- end
    2012-01-19 17:12:27.304 GetEntryAt(-1) failed.
    2012-01-19 17:12:27.304 It appears that your backend may be misconfigured. Check your backend logs to determine whether your capture cards, lineups, channels, or storage configuration are reporting errors. This issue is commonly caused by failing to complete all setup steps properly. You may wish to review the documentation for mythtv-setup.
    2012-01-19 17:12:27.304 EntryToProgram(0@Wed Dec 31 19:00:00 1969) failed to get pginfo
    2012-01-19 17:12:27.304 TV Error: HandleStateChange(): LiveTV not successfully started
    2012-01-19 17:12:27.304 We have a RingBuffer
    2012-01-19 17:12:27.304 TV Error: LiveTV not successfully started
    mount: can't find /dev/sdc in /etc/fstab or /etc/mtab
    2012-01-19 17:12:46.852 Failed to mount /dev/sdc.
    2012-01-19 17:12:47.669 OpenGL: Deleting OpenGL Resources
    2012-01-19 17:12:47.710 Deleting UPnP client...
    2012-01-19 17:12:48.383 Trying 3600x1080 50.000 Hz
    2012-01-19 17:12:48.383 SwitchToGUI: Switched to 3600x1080 60.000 Hz
    steven@Yeshuah:~$ sudo service mythtv-backend start
    [sudo] password for steven:
    start: Job is already running: mythtv-backend
    steven@Yeshuah:~$

    The theme is unrecognisable to me and doesn't have the options I expect, and it does not play any TV. I am sure that I locked in several channels. Also, Notice it says trying '3600x1080'; I think that is what caused the dwarf like images before. My primary monitor has an 16x 9 ratio and is 1920x1080.

    If 3600x1080 is wrong how do I change it? I attempted to change it in system settings, but it would not accept 1980x1080 and reverted to the 3600x19080 configuration.

    I thought my backend was running, but when I couldn't get mythfrontend to function, I went ahead and entered your second command line instruction; it said it is already running: mythtv-backend.

    By the way thanks for your ongoing patience.

    It is below freezing cold with minor snow here; how is the sunshine in your neck of the woods?

  7. #17
    Join Date
    Nov 2010
    Beans
    241

    Re: Need Expert advice how to proceed, newbie level user.

    Shabakthanai,

    I'm in this time for a generic advice. In any UNIX when you see the word error that usually means anything after that is meaningless. The error you are getting has to be fixed before proceeding. You may get a new error then, and it has to be fixed, too. Once you do not see any more errors in log you can expect things start working.
    In this case it's quite clear your mythtv-setup didn't succeed. I recommend checking permissions on your ~/.mythtv directory and files, it's possible you screwed it up when running mythtv-setup as root.

  8. #18
    Join Date
    Mar 2007
    Location
    Christchurch, NZ
    Beans
    3,239

    Re: Need Expert advice how to proceed, newbie level user.

    2012-01-19 17:12:27.304 It appears that your backend may be misconfigured. Check your backend logs to determine whether your capture cards, lineups, channels, or storage configuration are reporting errors. This issue is commonly caused by failing to complete all setup steps properly. You may wish to review the documentation for mythtv-setup.
    Clearly you didn't finish mythtv-setup

  9. #19
    Join Date
    Nov 2010
    Beans
    241

    Re: Need Expert advice how to proceed, newbie level user.

    Oh, and it was 75 F degrees today, I fired up my Harley and rode it for an hour, I really enjoyed it, thanks for asking. What's your zip?

  10. #20
    Join Date
    May 2007
    Beans
    76

    Re: Need Expert advice how to proceed, newbie level user.

    Under "Properties" for '.mythtv', both Owner and Group can view and modify content; x Only owner can rename and delete folder content.

    Ownership is User: steven and Group: steven

    Most of the time when I see an error message, I do not understand how to fix the problem. This is a good example.

    The way I understand your comment, something is wrong with my permissions in the .mythtv folder.

    I apparently have the permission to modify .mythtv, but do not yet understand how to do that.

    Some of my replies to posts have included the readout of a command-line entry where errors are present. When I ask about them, I don't believe I have gotten a reply.

    Gradually I am getting more understanding, but perhaps not fast enough or good enough to get the help I need. It is a difficult thing to be technically less-gifted. I expect it is very frustrating to help someone like me. I do appreciate the kindness extended though.

    In my previous reply, I included the readout from a 'mythfrontend' command.

    First error reads:

    2012-01-19 17:12:13.548 Configuration::Load - Error parsing: /home/steven/.mythtv/config.xml at line: 1 column: 1
    2012-01-19 17:12:13.548 Configuration::Load - Error Msg: unexpected end of file

    When I open that file, there is no content at all. The page is blank. IF the second error message is about that same configuration file, it is without data too.

    2012-01-19 17:12:14.204 Unable to read configuration file mysql.txt

    This line does not say it has an error, but when I open mysql.txt, that txt file is also a blank page with no information.

    012-01-19 17:12:14.204 Configuration::Load - Error parsing: /home/steven/.mythtv/config.xml at line: 1 column: 1
    2012-01-19 17:12:14.204 Configuration::Load - Error Msg: unexpected end of file

    These errors are same as before, the file does not contain any information at all.

    2012-01-19 17:12:14.492 Desktop video mode: 3600x1080 60.000 Hz

    This doesn't post as an error, however my primary monitor is 1920x1080 (16x9) and my secondary monitor is 1680x1050 (16x10)

    2012-01-19 17:12:16.299 ThemeInfo, Warning: Unable to open themeinfo.xml for

    I have no idea what the cure for this might be.

    2012-01-19 17:12:16.299 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/BlackCurves-OSD) is missing a themeinfo.xml file.

    How would I supply the missing information?

    2012-01-19 17:12:16.317 ThemeInfo, Warning: Unable to open themeinfo.xml for /usr/share/mythtv/themes/Gray-OSD/themeinfo.xml
    2012-01-19 17:12:16.317 ThemeInfo, Error: The theme (/usr/share/mythtv/themes/Gray-OSD) is missing a themeinfo.xml file.
    2012-01-19 17:12:16.616 Registering Internal as a media playback plugin.
    2012-01-19 17:12:16.639 No plugins directory /usr/lib/mythtv/plugins

    Are these items something I could enter using Synaptic Package Manager?

    2012-01-19 17:12:27.304 It appears that your backend may be misconfigured. Check your backend logs to determine whether your capture cards, lineups, channels, or storage configuration are reporting errors. This issue is commonly caused by failing to complete all setup steps properly. You may wish to review the documentation for mythtv-setup.
    2012-01-19 17:12:27.304 EntryToProgram(0@Wed Dec 31 19:00:00 1969) failed to get pginfo
    2012-01-19 17:12:27.304 TV Error: HandleStateChange(): LiveTV not successfully started

    I do not have the knowledge or experience to answer these questions without help.

    2012-01-19 17:12:27.304 TV Error: LiveTV not successfully started
    mount: can't find /dev/sdc in /etc/fstab or /etc/mtab
    2012-01-19 17:12:46.852 Failed to mount /dev/sdc.
    2012-01-19 17:12:47.669 OpenGL: Deleting OpenGL Resources
    2012-01-19 17:12:47.710 Deleting UPnP client...

    Where do I find the missing SDC and do I put it in both fstab and mtab when I have located it?

    I posted that command line entry looking for help finding the solution to the problems it contained. I don't know what to do without outside help.

    I would copy the contents of the files that I found empty, but they did not even contain even one letter or digit. They are blank files.

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •