Page 87 of 121 FirstFirst ... 3777858687888997 ... LastLast
Results 861 to 870 of 1201

Thread: Wayland Live CD

  1. #861
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    It seems that the compile has worked this time thanks Nerdopolis that libcolord.dev did the trick.



    Code:
    make[3]: Nothing to be done for `install-data-am'.
    make[3]: Leaving directory `/root/source/weston/clients'
    make[2]: Leaving directory `/root/source/weston/clients'
    make[1]: Leaving directory `/root/source/weston/clients'
    Making install in data
    make[1]: Entering directory `/root/source/weston/data'
    make[2]: Entering directory `/root/source/weston/data'
    make[2]: Nothing to be done for `install-exec-am'.
    test -z "/root/install/share/weston" || /bin/mkdir -p "/root/install/share/weston"
     /usr/bin/install -c -m 644 wayland.svg wayland.png pattern.png terminal.png border.png icon_window.png sign_close.png sign_maximize.png sign_minimize.png '/root/install/share/weston'
    make[2]: Leaving directory `/root/source/weston/data'
    make[1]: Leaving directory `/root/source/weston/data'
    Making install in protocol
    make[1]: Entering directory `/root/source/weston/protocol'
    make[2]: Entering directory `/root/source/weston/protocol'
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Leaving directory `/root/source/weston/protocol'
    make[1]: Leaving directory `/root/source/weston/protocol'
    Making install in tests
    make[1]: Entering directory `/root/source/weston/tests'
    make  install-am
    make[2]: Entering directory `/root/source/weston/tests'
    make[3]: Entering directory `/root/source/weston/tests'
    make[3]: Nothing to be done for `install-exec-am'.
    make[3]: Nothing to be done for `install-data-am'.
    make[3]: Leaving directory `/root/source/weston/tests'
    make[2]: Leaving directory `/root/source/weston/tests'
    make[1]: Leaving directory `/root/source/weston/tests'
    Making install in wcap
    make[1]: Entering directory `/root/source/weston/wcap'
    make[2]: Entering directory `/root/source/weston/wcap'
    test -z "/root/install/bin" || /bin/mkdir -p "/root/install/bin"
      /bin/bash ../libtool   --mode=install /usr/bin/install -c wcap-decode '/root/install/bin'
    libtool: install: /usr/bin/install -c wcap-decode /root/install/bin/wcap-decode
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Leaving directory `/root/source/weston/wcap'
    make[1]: Leaving directory `/root/source/weston/wcap'
    Making install in man
    make[1]: Entering directory `/root/source/weston/man'
    make[2]: Entering directory `/root/source/weston/man'
    make[2]: Nothing to be done for `install-exec-am'.
    test -z "/root/install/share/man/man1" || /bin/mkdir -p "/root/install/share/man/man1"
     /usr/bin/install -c -m 644 weston.1 '/root/install/share/man/man1'
    test -z "/root/install/share/man/man5" || /bin/mkdir -p "/root/install/share/man/man5"
     /usr/bin/install -c -m 644 weston.ini.5 '/root/install/share/man/man5'
    test -z "/root/install/share/man/man7" || /bin/mkdir -p "/root/install/share/man/man7"
     /usr/bin/install -c -m 644 weston-drm.7 '/root/install/share/man/man7'
    make[2]: Leaving directory `/root/source/weston/man'
    make[1]: Leaving directory `/root/source/weston/man'
    make[1]: Entering directory `/root/source/weston'
    make[2]: Entering directory `/root/source/weston'
    make[2]: Nothing to be done for `install-exec-am'.
    make[2]: Nothing to be done for `install-data-am'.
    make[2]: Leaving directory `/root/source/weston'
    make[1]: Leaving directory `/root/source/weston'
    
    Running weston, the example wayland compositor.
    Sleeping 2 seconds so the compositor is actually running by the time I run other stuff.
    Date: 2013-05-24 CEST
    [16:55:04.750] weston 1.1.90
                   http://wayland.freedesktop.org/
                   Bug reports to: https://bugs.freedesktop.org/enter_bug.cgi?product=Wayland&component=weston&version=1.1.90
                   Build: 1.1.0-150-gfc10cc0-dirty shell: Remove input panel debug fprintf (2013-05-23 21:47:37 -0400)
    [16:55:04.751] OS: Linux, 3.2.0-32-generic-pae, #51-Ubuntu SMP Wed Sep 26 21:54:23 UTC 2012, i686
    [16:55:04.751] warning: XDG_RUNTIME_DIR "/tmp" is not configured
    correctly.  Unix access mode must be 0700 but is 777,
    and XDG_RUNTIME_DIR must be owned by the user, but is
    owned by UID 0.
    Refer to your distribution on how to get it, or
    http://www.freedesktop.org/wiki/Specifications/basedir-spec
    on how to implement it.
    config file "weston.ini" not found.
    [16:55:04.751] Loading module '/root/install/lib/weston/x11-backend.so'
    [16:55:04.757] initializing x11 backend
    ./wayland-build-master.sh: line 804:  7861 Segmentation fault      (core dumped) $WLD/bin/weston
    vte terminal client isn't installed.
    QtWebKit web browser isn't installed.
    root@keith-K53SV:/home/keith/Downloads# failed to connect to Wayland display: No such file or directory
    failed to create display: No such file or directory
    config file "weston.ini" not found.
    failed to connect to Wayland display: No such file or directory
    failed to create display: No such file or directory
    $WLD/bin/weston vte terminal client isn't installed.
    QtWebKit web browser isn't installed.


    [Update - now added Qt5 from here https://launchpad.net/~canonical-qt5...ve/qt5-proper]

    The compile completed ...... ok I think ....... still will go with this - but have some RW dvds now
    RB is 1.6 Gig now .... - will install the latest RB if I fail to get this going.

    The Live Dvd works on my TV and Laptop combination Asus K53SV and a dvi cable to the TV
    Wayland 1270 x 720 great work.
    Last edited by 23dornot23d; May 24th, 2013 at 08:07 PM. Reason: Tried the Live Dvd

  2. #862
    Join Date
    Apr 2007
    Location
    Miami FL USA
    Beans
    1,236
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    Installer crashed three times but cd worked ok. tried another dl and it took 2 hours and when I went to dir it was in it was empty ???
    Going to try dl again, SourceForge it sloooow!

  3. #863
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Wayland was 300 kb/sec and lower for me too on the download.

    but here is a screenshot I took of it installing .......



    and another of the Browser running after the installation finished ..... and run from the main drive ......



    Forgot to mention - picked up the dual display perfectly for my set up .........
    Last edited by 23dornot23d; May 24th, 2013 at 10:04 PM. Reason: Forgot to mention - picked dual display perfectly for my set up

  4. #864
    Join Date
    Apr 2009
    Beans
    298
    Distro
    Kubuntu

    Re: Wayland Live CD

    Hi.

    I released the new ISO here

    http://sourceforge.net/projects/rebe...6.iso/download

    What's special about this one is that it now has the loginmanager I assembled for Wayland with bash.

    Although I had to switch back to the mainline Weston, because despite the other tree I was using on the previous ISO had some out of tree features, like the taskbar in the panel, that repository is now out of date.

    I described the login manager, and some information about its security here: http://lists.freedesktop.org/archive...ay/009475.html
    The glass is at 50% of its capacity.


  5. #865
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Downloading now and the speed is ok ty



    Ok it works ok from the LiveDvd but the autologin appears and goes away really quickly
    there was also a splash screen I saw momentarily .....

    Not sure if its meant to wait for a key press or not ..... but it did not on this .
    Last edited by 23dornot23d; May 25th, 2013 at 01:04 AM. Reason: Tried it out the login flashed by though

  6. #866
    Join Date
    Apr 2007
    Location
    Miami FL USA
    Beans
    1,236
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    Looks good Keith, after 2 hours finaly got the right checksum and burned cd, installer didnt crash it just locked up @ 66% 'configureing hardware' but it looks like everything got install.
    Going to try it and see if it boots, been a long day.

  7. #867
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    It seems to spend ages at 66 % , probably was NOT locked up ........ but only you
    would know that if you spent ages waiting for it ........

    Mine did the same on the install at 66% and I started to worry as there is nothing really apparent
    happening at that moment in time ......

    But it does then carry on - or at least it did on mine ......... the end part installs the bootloader etc
    so chances are you may be missing some things .
    Last edited by 23dornot23d; May 25th, 2013 at 01:21 AM. Reason: added on the install at 66%

  8. #868
    Join Date
    Apr 2007
    Location
    Miami FL USA
    Beans
    1,236
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    It booted up to the Kubuntu screen and stopped, guess I'll try it again, just woke up, 3 am here

  9. #869
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Best of luck with it -

    I am wondering what I have to gain by installing the latest with the login as I quite liked not having to login ......
    but I am the only user and others may not be in that position.
    KDE boots into 640 x 480 on the 40 inch TV , went into display settings and all the options have gone but one
    how to set dual display or larger screen resolution is evading me ......... may have to do it by other methods now
    xrandr or something ....... how do normal users change the display size now ....... have I missed something by not
    getting involved in the upgrades
    ( I stopped at precise as the direction for mobiles and Unity and advertising is not some thing I buy into )

    But will still look at wayland as I think this is still the way they should have gone .........

    Now installed the one with the login screen and it works ok ...... will post some pictures soon ......

    Wayland Login Screen



    One more but there was a problem - was slow to react and multiple boxes came up .......



    Only other problem was it crashed out when trying to play a video in the browser ...... no idea what caused it but
    if anyone needs me to check logs or anything just say and I will repeat the process .....

    The other crash was accessing a sd card ...... was wanting to post from wayland to show the pictures but am having to
    boot into a seperate OS precise to show what is going on here ........

    Where are the logs kept and which one should I look for to give any useful feedback ?
    Last edited by 23dornot23d; May 25th, 2013 at 08:25 PM. Reason: Login - Feedback on problems encountered

  10. #870
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Not much activity on here but - will post new messages as I know how messy it gets with Emails if I keep
    editing the past ones ......

    Added LXDE and can use it to get to 1920 x 1080 resolution so happy now can swap between
    added Qt5 too so now got .....

    Wayland and LXDE 1920 x 1080 ..... ( a lot better )
    Also setup KDE now ....



    The thing is it does not automatically detect it in the login menu system ....... (after restarting the login .....)
    so change terminal Alt+F1 and startx goes into LXDE for posting back here .

    This could become my main system if I can get Wings3d into it .... what have they altered that
    stops it loading in now from the repos .
    Last edited by 23dornot23d; May 26th, 2013 at 11:00 PM.

Page 87 of 121 FirstFirst ... 3777858687888997 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •