Page 28 of 117 FirstFirst ... 1826272829303878 ... LastLast
Results 271 to 280 of 1168

Thread: Wayland Live CD

  1. #271
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Cheers Chuck

    The fact that I have Arch on here now - also 3 desktops up and running and they
    are fast ......
    Also for animation Synfig Studio runs properly on here ( it will not run in 12.04 )
    Compiled makehuman last night (using AUR) and that runs so fast and it has really advanced a lot
    k3dsurf - blender and wings3d too .... this is going to be my 3D machine now.


    makes me happy.

    The problem I need to get into my head is how the information is handled by wayland
    and how to get the display to be used by it as nerdopolis as done.

    http://www.youtube.com/user/n3rdopolis?feature=watch

    Enjoyed it so far ..... and a fresh day a fresh start ......

    Will keep taking it piece by piece ..... little by little as the French say .... gets it done.

    Building QT5 now - as I have done this successfully before in Ubuntu .... will do it in Arch

    So first sort some dependancies out

    Requires libxcb >= 1.5.

    Required packages:
    libxcb1 libxcb1-dev libx11-xcb1 libx11-xcb-dev libxcb-keysyms1 libxcb-keysyms1-dev libxcb-image0 libxcb-image0-dev libxcb-shm0 libxcb-shm0-dev libxcb-icccm1 libxcb-icccm1-dev libxcb-sync0 libxcb-sync0-dev libxcb-render-util0 libxcb-render-util0-dev libxcb-xfixes0-dev libxrender-dev libxcb-shape0-dev

    On Ubuntu 11.10 icccm1 is replaced by icccm4 and xcb-render-util is not available:
    libxcb1 libxcb1-dev libx11-xcb1 libx11-xcb-dev libxcb-keysyms1 libxcb-keysyms1-dev libxcb-image0 libxcb-image0-dev libxcb-shm0 libxcb-shm0-dev libxcb-icccm4 libxcb-icccm4-dev libxcb-sync0 libxcb-sync0-dev libxcb-xfixes0-dev libxrender-dev libxcb-shape0-dev
    The packages for xcb-render-util can be installed manually from http://packages.ubuntu.com/natty/libxcb-render-util0 and http://packages.ubuntu.com/natty/lib...nder-util0-dev
    [keith@keith-aspire-7730zg xcb]$ sudo yaourt -Sy libxcb
    Password:
    :: Synchronizing package databases...
    core 103.7 KiB 162K/s 00:01 [#################################] 100%
    extra 1384.7 KiB 398K/s 00:03 [#################################] 100%
    community 1649.6 KiB 360K/s 00:05 [#################################] 100%
    archlinuxfr 32.9 KiB 173K/s 00:00 [#################################] 100%
    warning: libxcb-1.8.1-1 is up to date -- reinstalling
    resolving dependencies...
    looking for inter-conflicts...

    Targets (1): libxcb-1.8.1-1

    Total Installed Size: 4.40 MiB
    Net Upgrade Size: 0.00 MiB

    Proceed with installation? [Y/n] y
    (1/1) checking package integrity [#################################] 100%
    (1/1) loading package files [#################################] 100%
    (1/1) checking for file conflicts [#################################] 100%
    (1/1) checking available disk space [#################################] 100%
    (1/1) upgrading libxcb [#################################] 100%
    [keith@keith-aspire-7730zg xcb]$
    I hope Cecil is doing alright with it ...... whats happening Cecil ... ?
    Last edited by 23dornot23d; March 31st, 2012 at 02:35 PM.

  2. #272
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,301
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    This is one of the first things I do when I set up a fresh install of Arch, in the /etc/makepkg.conf you can change the CFLAGS & CXXFLAGS lines to this:
    Code:
    CFLAGS="-march=native -O2 -pipe -fstack-protector --param=ssp-buffer-size=4 -D_FORTIFY_SOURCE=2"
    CXXFLAGS="${CFLAGS}"
    that will make it compile for the CPU architecture, which might also make it a little faster.

  3. #273
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Ok cheers Chuck

    I have something called wayland-scanner

    built now .... but do not know what it does or how it is used .... am searching on it now

    http://devqt.blogspot.fr/2011/12/wayland-scanner.html

    will add your recommendations to that file thanks .....

  4. #274
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,301
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    Quote Originally Posted by 23dornot23d View Post
    Ok cheers Chuck

    I have something called wayland-scanner

    built now .... but do not know what it does or how it is used .... am searching on it now

    http://devqt.blogspot.fr/2011/12/wayland-scanner.html

    will add your recommendations to that file thanks .....
    I have no idea what it is, that was the first thing that got built the other day. It was only later when I tried building using weston in the AUR did I realize how big this project is.

  5. #275
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Yep - it rebuilds everything .... or so it seems .....

    I am hitting the easy things first .... here ..... then hopefully - later on it will all
    come together .......

    QT5 is failing for me here

    g++ -o "/home/keith/qt/qtbase/bin/qmake" project.o property.o main.o makefile.o unixmake2.o unixmake.o mingw_make.o option.o winmakefile.o projectgenerator.o meta.o makefiledeps.o metamakefile.o xmloutput.o pbuilder_pbx.o borland_bmake.o msvc_vcproj.o msvc_vcxproj.o msvc_nmake.o msvc_objectmodel.o msbuild_objectmodel.o gbuild.o qtextcodec.o qutfcodec.o qstring.o qtextstream.o qiodevice.o qmalloc.o qglobal.o qbytearray.o qbytearraymatcher.o qdatastream.o qbuffer.o qlist.o qfile.o qfilesystementry.o qfilesystemengine_unix.o qfilesystemengine.o qfilesystemiterator_unix.o qfsfileengine_unix.o qfsfileengine.o qfsfileengine_iterator.o qregexp.o qvector.o qbitarray.o qdir.o qdiriterator.o quuid.o qhash.o qfileinfo.o qdatetime.o qstringlist.o qabstractfileengine.o qtemporaryfile.o qmap.o qmetatype.o qsettings.o qsystemerror.o qlibraryinfo.o qvariant.o qvsnprintf.o qlocale.o qlocale_tools.o qlocale_unix.o qlinkedlist.o qurl.o qnumeric.o qcryptographichash.o qxmlstream.o qxmlutils.o qlogging.o
    The XCB test failed!
    You might need to install dependency packages.
    See src/plugins/platforms/xcb/README.
    [keith@keith-aspire-7730zg qtbase]$
    The wayland using the script ....... is stopping here .....

    make[2]: Entering directory `/home/keith/source/kbproto'
    make[2]: Nothing to be done for `install-exec-am'.
    test -z "/home/keith/install/include/X11/extensions" || /bin/mkdir -p "/home/keith/install/include/X11/extensions"
    /bin/install -c -m 644 XKBgeom.h XKB.h XKBproto.h XKBsrv.h XKBstr.h '/home/keith/install/include/X11/extensions'
    test -z "/home/keith/install/lib/pkgconfig" || /bin/mkdir -p "/home/keith/install/lib/pkgconfig"
    /bin/install -c -m 644 kbproto.pc '/home/keith/install/lib/pkgconfig'
    make[2]: Leaving directory `/home/keith/source/kbproto'
    make[1]: Leaving directory `/home/keith/source/kbproto'
    Already up-to-date.
    autoreconf: Entering directory `.'
    autoreconf: configure.ac: not using Gettext
    autoreconf: running: aclocal -I /home/keith/install/share/aclocal -I m4
    autoreconf: configure.ac: tracing
    autoreconf: running: libtoolize --copy
    autoreconf: running: /usr/bin/autoconf
    configure.ac:86: error: possibly undefined macro: XTRANS_CONNECTION_FLAGS
    If this token and others are legitimate, please use m4_pattern_allow.
    See the Autoconf documentation.
    autoreconf: /usr/bin/autoconf failed with exit status: 1
    [keith@keith-aspire-7730zg Downloads]$
    and

    installing
    yaourt -Sy weston


    wants to remove all my screen/display drivers ....

    ==> mesa-full-wayland conflicts:
    - mesa-8.0.2-1
    - libgl-8.0.2-1
    - libglapi-8.0.2-1
    - libgles-8.0.2-1
    - libegl-8.0.2-1
    - ati-dri-8.0.2-1
    - intel-dri-8.0.2-1
    - nouveau-dri-8.0.2-1
    hopefully to replace them with the newer ones that work ?

    loading packages...
    resolving dependencies...
    looking for inter-conflicts...
    :: mesa-full-wayland and mesa are in conflict. Remove mesa? [y/N] y
    :: mesa-full-wayland and libgl are in conflict. Remove libgl? [y/N] y
    :: mesa-full-wayland and libglapi are in conflict. Remove libglapi? [y/N] y
    :: mesa-full-wayland and libgles are in conflict. Remove libgles? [y/N] y
    :: mesa-full-wayland and libegl are in conflict. Remove libegl? [y/N] y
    :: mesa-full-wayland and ati-dri are in conflict. Remove ati-dri? [y/N] y
    :: mesa-full-wayland and intel-dri are in conflict. Remove intel-dri? [y/N] y
    :: mesa-full-wayland and nouveau-dri are in conflict. Remove nouveau-dri? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: svga-dri: requires mesa=8.0.2
    y[keith@keith-aspire-7730zg Downloads]$ y
    bash: y: command not found
    [keith@keith-aspire-7730zg Downloads]$
    Need to remove svga-dri and to remove that you also need to remove xf86-video-vmware

    this I am not sure is a good idea either ..... need another test Install
    going to try it on another system first ..... ( maybe a usb flash drive - needs a min of 9 gig though)



    Thing is once we have been through it once .....

    The second and third installs always seem much easier ...... as we learn what is going on .....
    ( hopefully .... it will not need doing a lot of times - as we clear things up - then the process should get shortened )

    Am really happy with this build of Kahel though .... whats happened to Cecil .....

    No doubt out on the Air Boat and living life up .....

    The 12.04 install ..... fails here ,,,, just updated this too using the script .... 0.85

    make[1]: Entering directory `/home/keith/source/mesa/src'
    Making sources for autoconf
    make[2]: Entering directory `/home/keith/source/mesa/src/mapi/shared-glapi'
    gcc -c -I../../../include -I../../../src/mapi -DMAPI_MODE_GLAPI -DMAPI_ABI_HEADER=\"shared-glapi/glapi_mapi_tmp.h\" -g -O2 -Wall -Wmissing-prototypes -std=c99 -fno-strict-aliasing -fno-builtin-memcmp -fPIC -DUSE_X86_ASM -DUSE_MMX_ASM -DUSE_3DNOW_ASM -DUSE_SSE_ASM -D_GNU_SOURCE -DPTHREADS -DHAVE_POSIX_MEMALIGN -DUSE_XCB -DGLX_INDIRECT_RENDERING -DGLX_DIRECT_RENDERING -DUSE_EXTERNAL_DXTN_LIB=1 -DIN_DRI_DRIVER -DHAVE_ALIAS -DHAVE_MINCORE -DHAVE_LIBUDEV -DHAVE_XCB_DRI2 -D__STDC_CONSTANT_MACROS -DHAVE_LLVM=0x0209 -fvisibility=hidden ../../../src/mapi/mapi/mapi_glapi.c -o mapi_glapi.o
    ../../../src/mapi/mapi/mapi_glapi.c: In function ‘_glapi_get_dispatch_table_size’:
    ../../../src/mapi/mapi/mapi_glapi.c:78:11: error: ‘MAPI_TABLE_NUM_STATIC’ undeclared (first use in this function)
    ../../../src/mapi/mapi/mapi_glapi.c:78:11: note: each undeclared identifier is reported only once for each function it appears in
    ../../../src/mapi/mapi/mapi_glapi.c:78:11: error: ‘MAPI_TABLE_NUM_DYNAMIC’ undeclared (first use in this function)
    ../../../src/mapi/mapi/mapi_glapi.c:79:1: warning: control reaches end of non-void function [-Wreturn-type]
    make[2]: *** [mapi_glapi.o] Error 1
    make[2]: Leaving directory `/home/keith/source/mesa/src/mapi/shared-glapi'
    make[1]: *** [subdirs] Error 1
    make[1]: Leaving directory `/home/keith/source/mesa/src'
    make: *** [default] Error 1
    keith@keith-Aspire-7730ZG:~/Downloads$
    Last edited by 23dornot23d; April 1st, 2012 at 01:22 PM.

  6. #276
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,301
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    Yeah, I'm sure he's out kickin' it in the sticks.

  7. #277
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    I like it .....

    Might now put KahelOS onto my faster laptop .... the Asus ....
    only trouble is its different hybrid graphics intel and nvidia 540

    See if I get the same problems or different ones .... and its another install then
    ready to use ..... * ( if I should mess this one up )

    May prove to be better .... who knows ..... as it could just use the intel driver .....
    Last edited by 23dornot23d; March 31st, 2012 at 03:42 PM.

  8. #278
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,301
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    Quote Originally Posted by 23dornot23d View Post
    I like it .....

    Might now put KahelOS onto my faster laptop .... the Asus ....
    only trouble is its different hybrid graphics intel and nvidia 540

    See if I get the same problems or different ones .... and its another install then
    ready to use ..... * ( if I should mess this one up )

    May prove to be better .... who knows ..... as it could just use the intel driver .....
    Yeah, that passes for music down here.

    That's what I was thinking, might have to blacklist one or the other but you might have more success with the intel given the current state of weston/wayland development.

  9. #279
    Join Date
    Nov 2009
    Beans
    3,225

    Re: Wayland Live CD

    Ok now installed on a second USB drive .... will see if the ASUS will work with it now ...



    Easy to install as long as you use a Primary partition and its over 9 Gig in size .....
    ( tried on a 8 gig USB stick and gave that warning 9 Gig min )

    I usually use 30 Gig nowadays (used to be 20 Gig was sufficient .... for all the programs I need and use)

    Ok Asus here we come .....

    So step by step ........ first try to upgrade the system using

    sudo pacman -Syu

    [keith@keith-k53sv ~]$ sudo pacman -Syu
    :: Synchronizing package databases...
    core is up to date
    extra is up to date
    community is up to date
    archlinuxfr is up to date
    :: The following packages should be upgraded first :
    pacman
    :: Do you want to cancel the current operation
    :: and upgrade these packages now? [Y/n] n

    :: Starting full system upgrade...
    :: Replace gnupg2 with core/gnupg? [Y/n] y
    :: Replace module-init-tools with core/kmod? [Y/n] y
    resolving dependencies...
    warning: dependency cycle detected:
    warning: udev will be installed before its util-linux dependency
    looking for inter-conflicts...
    :: gnome-shell-extension-user-theme and gnome-shell-extensions-common are in conflict. Remove gnome-shell-extensions-common? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: gnome-shell-extension-alternate-tab: requires gnome-shell-extensions-common
    :: gnome-shell-extension-alternative-status-menu: requires gnome-shell-extensions-common
    :: gnome-shell-extension-apps-menu: requires gnome-shell-extensions-common
    :: gnome-shell-extension-auto-move-windows: requires gnome-shell-extensions-common
    :: gnome-shell-extension-dock: requires gnome-shell-extensions-common
    :: gnome-shell-extension-drive-menu: requires gnome-shell-extensions-common
    :: gnome-shell-extension-gajim: requires gnome-shell-extensions-common
    :: gnome-shell-extension-native-window-placement: requires gnome-shell-extensions-common
    :: gnome-shell-extension-places-menu: requires gnome-shell-extensions-common
    :: gnome-shell-extension-system-monitor: requires gnome-shell-extensions-common
    :: gnome-shell-extension-windows-navigator: requires gnome-shell-extensions-common
    :: gnome-shell-extension-workspace-indicator: requires gnome-shell-extensions-common
    :: gnome-shell-extension-xrandr-indicator: requires gnome-shell-extensions-common
    :: mach64-dri: requires libgl=7.11.2
    :: mga-dri: requires libgl=7.11.2
    :: r128-dri: requires libgl=7.11.2
    :: savage-dri: requires libgl=7.11.2
    :: sis-dri: requires libgl=7.11.2
    :: tdfx-dri: requires libgl=7.11.2
    [keith@keith-k53sv ~]$
    Now we have to renove all the dependancy issues first ;;;

    So do each command one after the other in my history .... posted here

    http://ubuntuforums.org/showpost.php...&postcount=258

    example of what you will see

    [keith@keith-k53sv ~]$ sudo pacman -R gnome-shell-extension-apps-menu
    Password:
    checking dependencies...

    Remove (1): gnome-shell-extension-apps-menu-3.2.1-1

    Total Removed Size: 0.01 MB

    Do you want to remove these packages? [Y/n] y
    (1/1) removing gnome-shell-extension-apps-menu [######################] 100%
    [keith@keith-k53sv ~]$ sudo pacman -R gnome-shell-extension-auto-move-windows
    checking dependencies...

    Remove (1): gnome-shell-extension-auto-move-windows-3.2.1-1

    Total Removed Size: 0.02 MB

    Do you want to remove these packages? [Y/n] y
    (1/1) removing gnome-shell-extension-auto-move... [######################] 100%
    [keith@keith-k53sv ~]$ sudo pacman -R gnome-shell-extension-dock
    checking dependencies...

    Remove (1): gnome-shell-extension-dock-3.2.1-1

    Total Removed Size: 0.05 MB

    Do you want to remove these packages? [Y/n] y
    (1/1) removing gnome-shell-extension-dock [######################] 100%
    [keith@keith-k53sv ~]$ sudo pacman -R gnome-shell-extension-drive-menu
    checking dependencies...

    Remove (1): gnome-shell-extension-drive-menu-3.2.1-1

    Total Removed Size: 0.01 MB

    Do you want to remove these packages? [Y/n] y
    (1/1) removing gnome-shell-extension-drive-menu [######################] 100%
    [keith@keith-k53sv ~]$
    continue with them untill all my history is completed ...... then this will allow the upgrade to be performed

    Then you get this ....

    Code:
    [keith@keith-k53sv ~]$ sudo pacman -Syu
    :: Synchronizing package databases...
     core is up to date
     extra is up to date
     community is up to date
     archlinuxfr is up to date
    :: The following packages should be upgraded first :
        pacman
    :: Do you want to cancel the current operation
    :: and upgrade these packages now? [Y/n] n
    
    :: Starting full system upgrade...
    :: Replace gnupg2 with core/gnupg? [Y/n] y
    :: Replace module-init-tools with core/kmod? [Y/n] y
    resolving dependencies...
    warning: dependency cycle detected:
    warning: udev will be installed before its util-linux dependency
    looking for inter-conflicts...
    :: gnome-shell-extension-user-theme and gnome-shell-extensions-common are in conflict. Remove gnome-shell-extensions-common? [y/N] y
    
    Remove (3): module-init-tools-3.16-3  gnupg2-2.0.18-1
                gnome-shell-extensions-common-3.2.1-1
    
    Total Removed Size:   8.10 MB
    
    Targets (553): tzdata-2012b-1  glibc-2.15-7  a52dec-0.7.4-6  xcb-proto-1.7.1-1
                   xproto-7.0.23-1  libxdmcp-1.1.1-1  libxau-1.0.7-1
                   libxcb-1.8.1-1  kbproto-1.0.6-1  libx11-1.4.99.901-1
                   aalib-1.4rc5-9  alsa-lib-1.0.25-1  alsa-plugins-1.0.25-1
                   gcc-libs-4.6.3-1  bash-4.2.024-2  db-5.3.15-1  pam-1.1.5-2
                   shadow-4.1.5-4  gmp-5.0.4-1  coreutils-8.15-1  perl-5.14.2-7
                   openssl-1.0.1-2  zlib-1.2.6-1  pcre-8.30-1  glib2-2.30.2-2
                   kmod-7-1  pciutils-3.1.9-1  usbutils-005-1  udev-181-5
                   util-linux-2.21-6  apr-1.4.5-2  libsasl-2.1.23-9
                   e2fsprogs-1.42.1-1  libldap-2.4.30-1  apr-util-1.4.1-1
                   apache-2.2.22-3  libart-lgpl-2.3.21-2  art-sharp-2.24.2-2
                   libpciaccess-0.13-1  libdrm-2.4.33-1  xextproto-7.2.1-1
                   libxext-1.3.1-1  xf86vidmodeproto-2.3.1-2  libxxf86vm-1.1.2-1
                   fixesproto-5.0-2  libxfixes-5.0-2  damageproto-1.2.1-2
                   libxdamage-1.1.3-2  libglapi-8.0.2-1  libgl-8.0.2-1
                   ati-dri-8.0.2-1  libidl2-0.8.14-2  orbit2-2.14.19-2
                   ncurses-5.9-3  libxml2-2.7.8-2  libbonobo-2.32.1-2
                   inputproto-2.2-1  libxi-1.6.0-1  recordproto-1.14.2-1
                   libxtst-1.2.1-1  renderproto-0.11.1-2  libxrender-0.9.7-1
                   libxcursor-1.1.13-1  xineramaproto-1.2.1-2  libxinerama-1.1.2-1
                   compositeproto-0.4.2-2  libxcomposite-0.4.3-2
                   shared-mime-info-1.0-1  libpng-1.5.9-1  freetype2-2.4.9-1
                   fontconfig-2.8.0-2  pixman-0.24.4-1  cairo-1.10.2-3
                   libtasn1-2.12-1  p11-kit-0.11-1  gnutls-3.0.17-1
                   libjpeg-turbo-1.2.0-1  xz-5.0.3-2  libtiff-4.0.1-1
                   krb5-1.10.1-1  libdaemon-0.14-2  avahi-0.6.31-1  libcups-1.5.2-1
                   gdk-pixbuf2-2.24.1-3  gtk-update-icon-cache-2.24.10-3
                   gtk2-2.24.10-3  at-spi-1.32.0-5  at-spi2-core-2.2.3-1
                   at-spi2-atk-2.2.2-1  automake-1.11.3-1  sqlite3-3.7.11-1
                   libice-1.0.8-1  libsm-1.2.1-1  run-parts-4.2.1-1
                   ca-certificates-20120212-1  videoproto-2.3.1-2  libxv-1.0.7-1
                   hicolor-icon-theme-0.12-2  qt-4.8.1-1  gstreamer0.10-0.10.36-1
                   orc-0.4.16-1  gstreamer0.10-base-0.10.36-1  qtwebkit-2.2.1-2
                   sip-4.13.2-1  pyqt-4.9.1-1  python2-2.7.2-5
                   python2-sip-4.13.2-1  python2-pyqt-4.9.1-1  boost-libs-1.49.0-1
                   libxt-1.1.3-1  libxmu-1.1.1-1  glproto-1.4.15-1  mesa-8.0.2-1
                   glew-1.7.0-2  avogadro-1.0.3-5  blas-3.4.0-1  lcms2-2.3-2
                   polkit-0.104-1  libexif-0.6.20-2  gd-2.0.36RC1-5
                   libltdl-2.4.2-4  libgphoto2-2.4.13-1  libieee1284-0.2.11-4
                   v4l-utils-0.8.6-1  libnl-3.2.7-1  net-snmp-5.7.1-2
                   sane-1.0.22-7  colord-0.1.17-1  gtk3-3.2.3-3  bluefish-2.2.2-1
                   bluez-4.99-1  libxpm-3.5.10-1  libxaw-1.0.10-1  pyrex-0.9.9-3
                   brltty-4.3-4  ca-certificates-java-20120225-1
                   libsigc++-2.2.10-2  cairomm-1.10.0-2  cdparanoia-10.2-4
                   gnome-desktop-1:3.2.1-1  libcroco-0.6.4-1  librsvg-2.34.2-3
                   libvisual-0.4.0-4  libvorbis-1.3.3-1
                   gstreamer0.10-base-plugins-0.10.36-1
                   gstreamer0.10-good-0.10.31-1  libshout-1:2.3.0-1  libdv-1.0.0-4
                   wavpack-4.60.1-2  taglib-1.7.1-1  giflib-4.1.6-5
                   libid3tag-0.15.1b-7  imlib2-1.4.5-2  libcaca-0.99.beta17-2
                   gstreamer0.10-good-plugins-0.10.31-1
                   gstreamer0.10-bad-0.10.23-1  clutter-1.8.4-1
                   clutter-gst-1.4.6-1  mx-1.4.3-1  libgee-0.6.4-1
                   gnome-video-effects-0.3.0-2  cheese-3.2.2-1  nspr-4.9-1
                   nss-3.13.3-1  libevent-2.0.17-1  scrnsaverproto-1.2.2-1
                   libxss-1.2.2-1  xorg-fonts-encodings-1.0.4-3  libfontenc-1.1.1-1
                   xorg-mkfontscale-1.1.0-1  xorg-mkfontdir-1.0.7-1
                   ttf-dejavu-2.33-2  chromium-18.0.1025.142-1  libwbclient-3.6.3-4
                   cifs-utils-5.3-2  clamav-0.97.4-2  isl-0.09-1  cloog-0.17.0-1
                   cpufrequtils-008-2  openslp-1.2.1-4  lcms-1.19-2
                   poppler-0.18.4-1  cups-1.5.2-1  cups-pk-helper-0.2.1-1
                   libssh2-1.4.0-1  curl-7.25.0-1  dbus-sharp-0.7.0-4
                   dbus-sharp-glib-0.5.0-4  device-mapper-2.02.95-1  dhcpcd-5.5.5-1
                   libxslt-1.1.26-3  dia-0.97.2-2  djvulibre-3.5.24-3
                   dnsutils-9.9.0-1  docbook-xml-4.5-5  docbook-xsl-1.76.1-2
                   dotconf-1.3-3  sdl-1.2.15-1  ptlib-2.10.2-2  x264-20120204-1
                   opal-3.10.2-4  libnotify-0.7.5-1  ekiga-3.3.2-3
                   freeglut-2.8.0-1  jasper-1.900.1-7  ghostscript-9.05-1
                   libspectre-0.2.6-3  fontsproto-2.1.2-1  libxfont-1.4.5-1
                   xorg-bdftopcf-1.0.3-2  xorg-font-util-1.3.0-1
                   xorg-font-utils-7.6-3  gsfonts-1.0.7pre44-3
                   poppler-glib-0.18.4-1  evince-3.2.1-3  libical-0.46-2
                   evolution-data-server-3.2.3-2  iso-codes-3.32-1
                   gtkhtml4-4.2.3-1  libpst-0.6.54-1  evolution-3.2.3-2
                   exempi-2.2.0-1  faad2-2.7-3  gsm-1.0.13-7  lame-3.99.5-1
                   libvpx-1.0.0-1  opencore-amr-0.1.3-1  schroedinger-1.0.11-1
                   ffmpeg-20120317-1  fftw-3.3-2  file-5.11-1  filesystem-2012.2-2
                   firefox-11.0-2  flashplugin-11.2.202.228-1  fluidsynth-1.1.5-2
                   openjdk6-6.b24_1.11.1-3  freemind-0.9.0-2  fuse-2.8.7-1
                   ppl-0.12-1  gcc-4.6.3-1  gconf-editor-3.0.0-2
                   gconf-sharp-2.24.2-2  gnome-vfs-sharp-2.24.2-2  libglade-2.6.4-3
                   libgnomecanvas-2.30.3-2  libgnome-data-2.32.1-3  libcdio-0.83-1
                   libarchive-3.0.3-5  gvfs-1.10.1-3  libgnome-2.32.1-3
                   libbonoboui-2.24.5-2  libgnomeui-2.24.5-1
                   libgnome-sharp-2.24.2-2  gconf-sharp-peditors-2.24.2-2
                   gegl-0.1.8-2  geogebra-4.0.27.0-1  pygtk-2.24.0-3
                   libwmf-0.2.8.4-9  gimp-2.6.12-1  gjs-1.30.1-1  libassuan-2.0.3-1
                   gnupg-2.0.19-1  gpgme-1.3.1-4  gmime-2.6.7-1
                   gvfs-obexftp-1.10.1-3  openobex-1.5-3  obexd-client-0.44-1
                   gnome-bluetooth-3.2.2-1  shared-color-targets-0.1.1-1
                   gnome-color-manager-3.2.2-2  gnome-games-3.2.1-2
                   gnome-icon-theme-extras-3.0.0-2
                   gnome-icon-theme-symbolic-3.2.2-1  gnome-js-common-0.1.2-2
                   ndesk-dbus-0.6.0-3  gnome-keyring-sharp-1.0.2-3
                   gnome-mime-data-2.18.0-6  pacman-mirrorlist-20120211-1
                   pacman-4.0.2-1  packagekit-0.6.21-2  gnome-packagekit-3.2.1-2
                   gnome-sharp-2.24.2-2  mutter-3.2.2-2  iproute2-3.2.0-3
                   wireless_tools-29-6  wpa_supplicant-0.7.3-5
                   networkmanager-0.9.2.0-3  unzip-6.0-6  gnome-shell-3.2.2.1-1
                   gnome-shell-extension-user-theme-3.2.3-1  gtkhtml-3.32.2-3
                   guile-1.8.8-2  slib-3b3-2  libdbi-drivers-0.8.3_1-3
                   gnucash-2.4.10-1  grep-2.11-2  gsl-1.15-2  neon-0.29.6-4
                   musicbrainz-2.1.5-5  libcdaudio-0.99.12-6  mjpegtools-2.0.0-2
                   libmodplug-0.8.8.4-1  libofa-0.9.3-4  libass-0.10.0-3
                   libgme-0.6.0-2  libsndfile-1.0.25-2
                   gstreamer0.10-bad-plugins-0.10.23-1
                   gstreamer0.10-ffmpeg-0.10.13-1  gstreamer0.10-python-0.10.22-1
                   gstreamer0.10-ugly-0.10.19-1  libmad-0.15.1b-6
                   libsidplay-1.36.59-5  gstreamer0.10-ugly-plugins-0.10.19-1
                   gtk-engines-2.20.2-2  gtkspell-2.0.16-2  tdb-1.2.9-2
                   smbclient-3.6.3-4  gvfs-smb-1.10.1-3  hplip-3.12.2-1
                   hspell-1.1-2  imagemagick-6.7.6.2-1  inetutils-1.9.1-1
                   initscripts-2012.03.2-1  intel-dri-8.0.2-1  iptables-1.4.12.2-1
                   raptor-2.0.7-1  redland-1:1.0.15-3
                   redland-storage-virtuoso-1:1.0.15-3  libiodbc-3.52.7-5
                   virtuoso-6.1.4-2  soprano-2.7.5-1
                   shared-desktop-ontologies-0.9.0-1  qca-2.0.3-2  openexr-1.7.0-2
                   sg3_utils-1.33-1  parted-3.1-1  udisks-1.0.4-2
                   phonon-gstreamer-4.6.0-1  libqzeitgeist-0.8.0-2
                   phonon-1:4.6.0-2  kdelibs-4.8.1-2  facile-1.1-13
                   kdeedu-kalzium-4.8.1-1  lapack-3.4.0-1  less-444-3
                   libao-1.1.0-2  libasyncns-0.8-4  libdiscid-0.2.2-2
                   libedit-20120311_3.0-1  libgdiplus-2.10-2
                   libgnome-media-profiles-3.0.0-3  libidn-1.24-1
                   libmikmod-3.1.12-4  libmtp-1.1.2-1  libmusicbrainz3-3.0.3-2
                   libmysqlclient-5.5.22-1  libpaper-1.1.24-2  libpcap-1.2.1-2
                   libpurple-2.10.3-1  libraw1394-2.0.7-2
                   libreoffice-en-US-3.5.1-1  libreoffice-common-3.5.1-1
                   hsqldb-java-1:1.8.0.10-2  libreoffice-base-3.5.1-1
                   lpsolve-5.5.2.0-2  libreoffice-calc-3.5.1-1
                   libreoffice-draw-3.5.1-1  libreoffice-gnome-3.5.1-1
                   libreoffice-impress-3.5.1-1  libreoffice-kde4-3.5.1-1
                   libreoffice-math-3.5.1-1  zip-3.0-3  libreoffice-sdk-3.5.1-1
                   libreoffice-sdk-doc-3.5.1-1  libwpd-0.9.2-2  libwps-0.2.2-2
                   libreoffice-writer-3.5.1-1  libsocialweb-0.25.20-0
                   libtextcat-2.2-9  libtool-2.4.2-4  geoip-1.4.8-1
                   libtorrent-rasterbar-0.15.10-1  libtracker-sparql-0.12.10-1
                   libunique3-3.0.2-2  libupnp-1.6.16-1  libwebkit-1.6.3-1
                   libwebkit3-1.6.3-1  libxft-2.3.0-2  libxkbfile-1.0.8-1
                   xorg-xkbcomp-1.2.4-1  xkeyboard-config-2.5.1-1
                   libxklavier-5.1-2  libxres-1.0.6-1  libxvmc-1.0.7-1
                   linux-firmware-20120227-1  mkinitcpio-busybox-1.19.4-2
                   mkinitcpio-0.8.5-1  linux-3.2.13-1  lsb-release-1.4-12
                   lua-5.1.5-1  lvm2-2.02.95-1  man-db-2.6.1-1  man-pages-3.37-1
                   mdadm-3.2.3-1  metacity-2.34.1-2  python2-gconf-2.28.1-8
                   pywebkitgtk-1.1.8-2  python-notify-0.1.1-11
                   python-pycurl-7.19.0-6  mutagen-1.20-4  miro-4.0.6-1
                   mlocate-0.25-1  mono-addins-0.6.2-2  mpfr-3.1.0.p7-1
                   mysql-clients-5.5.22-1  mysql-5.5.22-1  netkit-bsd-finger-0.17-7
                   notification-daemon-0.7.4-1  nouveau-dri-8.0.2-1
                   ntfs-3g-2012.1.15-1  ntfsprogs-2012.1.15-1  obexfs-0.12-3
                   opensp-1.5.2-3  openssh-5.9p1-8  package-query-1.0.1-1
                   pcmciautils-018-2  perl-carp-clan-6.04-2  perl-bit-vector-7.2-1
                   perl-date-calc-6.3-2  perl-digest-hmac-1.03-2
                   perl-encode-locale-1.03-1  perl-http-date-6.01-1
                   perl-file-listing-6.04-1  perl-html-tagset-3.20-3
                   perl-html-parser-3.69-1  perl-lwp-mediatypes-6.02-1
                   perl-http-message-6.03-1  perl-http-cookies-6.01-1
                   perl-http-negotiate-6.01-1  perl-net-http-6.03-1
                   perl-www-robotrules-6.02-1  perl-libwww-6.04-1
                   perl-net-ip-1.25-5  perl-net-dns-0.68-1  perl-xml-parser-2.41-2
                   perl-xml-simple-2.18-4  php-5.3.10-4  php-apache-5.3.10-4
                   php-mcrypt-5.3.10-4  phpmyadmin-3.4.10.1-1  pidgin-2.10.3-1
                   pm-utils-1.4.1-4  psmisc-22.16-1  pulseaudio-alsa-2-1
                   pycups-1.9.61-1  pyorbit-2.24.0-4  pysmbc-1.0.13-1
                   python2-gnomecanvas-2.28.1-8  python2-bonobo-2.28.1-8
                   python2-gnomevfs-2.28.1-8  python2-gtkspell-2.25.3-12
                   python2-libgnome-2.28.1-8  python2-oauth-1.0.1-2
                   python-egenix-mx-base-3.2.3-1  python-gdata-2.0.16-1
                   python-simplejson-2.3.3-1  pyxdg-0.19-3  pyxml-0.8.4-9
                   qt3-1:3.3.8b-1  randrproto-1.3.2-2  recode-3.6-7  rtkit-0.10-3
                   samba-3.6.3-4  scribus-1.4.0-2  sdl_image-1.2.12-2
                   sdl_mixer-1.2.12-1  sdl_pango-0.1.2-4  sdl_ttf-2.0.11-2
                   sound-juicer-2.32.1-2  sound-theme-freedesktop-0.7-2
                   speech-dispatcher-0.7.1-6  sudo-1.8.4.p4-1  syslinux-4.05-3
                   syslog-ng-3.3.4-4  system-config-printer-common-1.3.9-1
                   system-config-printer-gnome-1.3.9-1  thunderbird-11.0.1-1
                   totem-plparser-2.32.6-3  totem-3.2.2-1  tracker-0.12.10-1
                   transmission-gtk-2.50-1  ttf-freefont-20100919-2
                   tuxpaint-0.9.21-5  unrar-4.1.4-2  libkate-0.4.1-3
                   libtiger-0.3.4-3  zvbi-0.2.33-4  vlc-2.0.1-1  whois-5.0.15-1
                   wvdial-1.61-4  wxgtk-2.8.12.1-3  xaos-3.5-5
                   xf86-input-acecad-1.5.0-3  xf86-input-aiptek-1.4.1-3
                   xf86-input-evdev-2.7.0-2  xf86-input-joystick-1.6.1-1
                   xf86-input-keyboard-1.6.1-2  xf86-input-mouse-1.7.2-1
                   mtdev-1.1.2-1  xf86-input-synaptics-1.5.99.902-1
                   xf86-input-vmmouse-12.8.0-1  xf86-input-void-1.4.0-3
                   xf86-video-apm-1.2.3-5  xf86-video-ark-0.7.4-1
                   xf86-video-ast-0.93.10-1  xf86-video-ati-6.14.4-2
                   xf86-video-chips-1.2.4-4  xf86-video-cirrus-1.4.0-1
                   xf86-video-dummy-0.3.5-1  xf86-video-fbdev-0.4.2-6
                   xf86-video-geode-2.11.13-1  xf86-video-glint-1.2.7-1
                   xf86-video-i128-1.3.5-1  xf86-video-i740-1.3.2-8
                   xf86-video-intel-2.18.0-1  xf86-video-neomagic-1.2.6-1
                   xf86-video-nouveau-0.0.16_git20120210-1  xf86-video-nv-2.1.18-5
                   xf86-video-rendition-4.2.4-6  xf86-video-s3-0.6.3-7
                   xf86-video-s3virge-1.10.4-7  xf86-video-siliconmotion-1.7.6-1
                   xf86-video-sisusb-0.9.4-6  xf86-video-trident-1.3.5-1
                   xf86-video-tseng-1.2.4-6  xf86-video-v4l-0.2.0-10
                   xf86-video-vesa-2.3.1-1  svga-dri-8.0.2-1
                   xf86-video-vmware-12.0.2-1  xf86-video-voodoo-1.2.4-6
                   xf86-video-xgixp-1.8.0-5  xorg-fonts-misc-1.0.1-2
                   xorg-setxkbmap-1.3.0-1  xorg-server-common-1.12.0-1
                   xorg-server-1.12.0-1  xorg-xhost-1.0.5-1  xorg-xmodmap-1.0.6-1
                   xorg-xrdb-1.0.9-2  xplc-0.3.13-4  xsane-0.998-2
                   xsane-gimp-0.998-2  yaourt-1.0.1-1  zim-0.55-1
    
    Total Download Size:    790.02 MB
    Total Installed Size:   3362.79 MB
    
    Proceed with installation? [Y/n]
    Answer yes and a long wait ..... as it downloads the packages ..... it cannot install them yet
    using the new pacman though - as the gpg problem needs sorting .... as shown below ...

    we do need to get the packages first ..... so that this can be done ....

    next upgrade of pacman ,,,,, now needs a new conf file ..... should merge the new into the old one
    but I like to see what its doing ...... so check the old against the new - I just had to add my local

    sudo mv /etc/pacman.conf.pacnew /etc/pacman.conf
    sudo pacman-key --init

    longish wait here while it generates the master key

    [keith@keith-k53sv ~]$ sudo mv /etc/pacman.conf.pacnew /etc/pacman.conf
    [keith@keith-k53sv ~]$ sudo pacman-key --init
    gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
    gpg: no ultimately trusted keys found
    gpg: Generating pacman keychain master key...
    gpg: key FDBA0094 marked as ultimately trusted
    gpg: Done
    ==> Updating trust database...
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
    gpg: depth: 0 valid: 1 signed: 0 trust: 0-, 0q, 0n, 0m, 0f, 1u
    [keith@keith-k53sv ~]$
    sudo gedit /etc/pacman.conf

    and all I needed was my custom setup adding

    as shown in the previous post .... here

    http://ubuntuforums.org/showpost.php...&postcount=259

    [root@keith-k53sv keith]# pacman -Sy pacman
    :: Synchronizing package databases...
    core is up to date
    extra is up to date
    community is up to date
    archlinuxfr is up to date
    warning: pacman-4.0.2-1 is up to date -- reinstalling
    resolving dependencies...
    looking for inter-conflicts...

    Targets (1): pacman-4.0.2-1

    Total Installed Size: 3.40 MiB
    Net Upgrade Size: 0.00 MiB

    Proceed with installation? [Y/n] y
    (1/1) checking package integrity [######################] 100%
    (1/1) loading package files [######################] 100%
    (1/1) checking for file conflicts [######################] 100%
    (1/1) checking available disk space [######################] 100%
    (1/1) upgrading pacman [######################] 100%
    [root@keith-k53sv keith]# pacman -Syyu
    :: Synchronizing package databases...
    core 103.7 KiB 83.4K/s 00:01 [######################] 100%
    extra 1384.8 KiB 222K/s 00:06 [######################] 100%
    community 1649.6 KiB 404K/s 00:04 [######################] 100%
    archlinuxfr 32.9 KiB 161K/s 00:00 [######################] 100%
    :: Starting full system upgrade...
    there is nothing to do
    [root@keith-k53sv keith]#

    Now to the adding of Wayland ..... again .....
    Job for tomorrow .... all roads are closed at the moment .... so will wait a while ....
    Last edited by 23dornot23d; March 31st, 2012 at 10:28 PM.

  10. #280
    Join Date
    Jun 2010
    Location
    Rockport, TX
    Beans
    2,301
    Distro
    Ubuntu Development Release

    Re: Wayland Live CD

    Keith, quickest way to handle the pacman-key --init thing is just open a terminal do a ls -R / a couple times and move a couple windows around.

Page 28 of 117 FirstFirst ... 1826272829303878 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •