Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Installing apps in offline

  1. #1
    Join Date
    Jul 2011
    Location
    now Iran
    Beans
    98
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Installing apps in offline

    Hi,
    I backup my ex-softwares and now I restore them in my ubuntu, how can I Install them??
    Is there anyway via Command Line for installing them?
    I restore them /var/cache/apt/archives/ .

  2. #2
    Join Date
    Jan 2007
    Beans
    6,542
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Installing apps in offline

    If you've dumped them into the APT cache all you need to do is run an update and you'll be able to install them through the normal tools (eg: Ubuntu Software Centre, apt-get, etc)

  3. #3
    Join Date
    Jul 2011
    Location
    now Iran
    Beans
    98
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Installing apps in offline

    how can I update them??
    is the command line: sudo apt-get update??
    what does mean this command line??

  4. #4
    Join Date
    Jan 2007
    Beans
    6,542
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Installing apps in offline

    Quote Originally Posted by sinaphysics View Post
    how can I update them??
    is the command line: sudo apt-get update??
    what does mean this command line??
    Yep, that's the one. It forces the package manager to check the repositories for updated versions of packages. If there's no connection it'll use the packages it already has in the cache.

    sudo = Super User Do (gives the command enough privileges to run)
    apt-get = Invokes APT, the Advanced Packaging Tool
    update = Tells APT to look for updates

  5. #5
    Join Date
    Jul 2011
    Location
    now Iran
    Beans
    98
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Installing apps in offline

    After restoring when I install same apps in both way ( software center and sudo apt-get), starts to download the package freshly except in some cases like firefox!! (this is when the laptop is connected to internet and when is not connected nothing happen)
    I use ubuntu 11.10.
    what do u suggest?
    Last edited by sinaphysics; March 14th, 2012 at 12:52 PM.

  6. #6
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Installing apps in offline

    Quote Originally Posted by sinaphysics View Post
    After restoring when I install same apps in both way ( software center and sudo apt-get), starts to download the package freshly except in some cases like firefox!! (this is when the laptop is connected to internet and when is not connected nothing happen)
    I use ubuntu 11.10.
    what do u suggest?
    This would indicate that your offline copies in /var/cache/apt/archives are not the most up-to-date. APT won't grab from the cache if it finds a newer copy available on the repository.
    Last edited by cortman; March 14th, 2012 at 09:08 PM.

  7. #7
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,827
    Distro
    Ubuntu Development Release

    Re: Installing apps in offline

    see this it have good information .
    https://help.ubuntu.com/community/InstallingSoftware
    Raja

    రాజ శేఖర్ రెడ్డి

  8. #8
    Join Date
    Jul 2011
    Location
    now Iran
    Beans
    98
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Installing apps in offline

    To clarify the issue, in past i use some softwares like 'kile','parley' or 'calibre' which in that case i backuped my system and after restoring in same folder in offline mode when i use 'sudo apt-get update' and then 'sudo apt-get install (soft name)' i can't install the mentioned apps. And in terminam page it shows that there exist some packages and some packages must be downloaded which cause failed.( Because there's no connection). While i use them in past. I'm really confused and internet is so expensive here to download them again, please help me.

  9. #9
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Installing apps in offline

    Ok, try running

    Code:
    sudo apt-get install calibre
    Since you said you've used it before. Please post all output.

  10. #10
    Join Date
    Jul 2011
    Location
    now Iran
    Beans
    98
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Installing apps in offline

    The output is :

    sina@sina-Vostro1510:~$ sudo apt-get install calibre [sudo] password for sina: Reading package lists... Done Building dependency tree Reading state information... Done The following packages were automatically installed and are no longer required: java-common icedtea-6-jre-cacao openjdk-6-jre-headless dkms tzdata-java icedtea-6-jre-jamvm openjdk-6-jre-lib screen-resolution-extra patch ca-certificates-java Use 'apt-get autoremove' to remove them. The following extra packages will be installed: calibre-bin imagemagick libcdt4 libchm1 libgraph4 libgvc5 liblqr-1-0 libmagickcore3 libmagickcore3-extra libmagickwand3 libnetpbm10 libpathplan4 libpodofo0.9.0 libqt4-dbus libqt4-declarative libqt4-designer libqt4-help libqt4-network libqt4-opengl libqt4-script libqt4-scripttools libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-test libqt4-xml libqt4-xmlpatterns libqtassistantclient4 libqtcore4 libqtgui4 netpbm python-beautifulsoup python-cherrypy3 python-clientform python-cssutils python-cssutils-doc python-django python-django-tagging python-dnspython python-encutils python-lxml python-mechanize python-pyparsing python-qt4 python-routes python-sip python-webob qdbus Suggested packages: imagemagick-doc autotrace curl enscript ffmpeg gnuplot grads hp2xx html2ps libwmf-bin povray radiance texlive-base-bin transfig ufraw-batch libqt4-declarative-folderlistmodel libqt4-declarative-gestures libqt4-declarative-particles libqt4-declarative-shaders qt4-qmlviewer libqt4-dev qt4-qtconfig python-psycopg2 python-psycopg python-mysqldb python-flup python-sqlite python-yaml python-lxml-dbg python-qt4-dbg python-paste The following NEW packages will be installed: calibre calibre-bin imagemagick libcdt4 libchm1 libgraph4 libgvc5 liblqr-1-0 libmagickcore3 libmagickcore3-extra libmagickwand3 libnetpbm10 libpathplan4 libpodofo0.9.0 libqt4-designer libqt4-help libqt4-scripttools libqt4-test libqtassistantclient4 netpbm python-beautifulsoup python-cherrypy3 python-clientform python-cssutils python-cssutils-doc python-django python-django-tagging python-dnspython python-encutils python-lxml python-mechanize python-pyparsing python-qt4 python-routes python-sip python-webob The following packages will be upgraded: libqt4-dbus libqt4-declarative libqt4-network libqt4-opengl libqt4-script libqt4-sql libqt4-sql-mysql libqt4-svg libqt4-xml libqt4-xmlpatterns libqtcore4 libqtgui4 qdbus 13 upgraded, 36 newly installed, 0 to remove and 357 not upgraded. Need to get 30.7 MB/45.1 MB of archives. After this operation, 147 MB of additional disk space will be used. Do you want to continue [Y/n]? y Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main liblqr-1-0 i386 0.4.1-1ubuntu2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libmagickcore3 i386 8:6.6.0.4-3ubuntu1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libmagickwand3 i386 8:6.6.0.4-3ubuntu1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main imagemagick i386 8:6.6.0.4-3ubuntu1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libcdt4 i386 2.26.3-5ubuntu4 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe libchm1 i386 2:0.40-3 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libgraph4 i386 2.26.3-5ubuntu4 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libpathplan4 i386 2.26.3-5ubuntu4 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libgvc5 i386 2.26.3-5ubuntu4 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libmagickcore3-extra i386 8:6.6.0.4-3ubuntu1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libnetpbm10 i386 2:10.0-12.2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main libqtassistantclient4 i386 4.6.3-3ubuntu1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main netpbm i386 2:10.0-12.2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-beautifulsoup all 3.2.0-2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-cherrypy3 all 3.1.2-1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-encutils all 0.9.8~a1-1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-cssutils all 0.9.8~a1-1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-cssutils-doc all 0.9.8~a1-1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric-updates/main python-django all 1.3-2ubuntu1.1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-django-tagging all 0.3.1-1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-dnspython all 1.9.4-0ubuntu2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-lxml i386 2.3-0.1build1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-pyparsing all 1.5.2-2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-sip i386 4.12.4-1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-qt4 i386 4.8.5-0ubuntu2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-routes all 1.12.3-1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-clientform all 0.2.10-2.1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe python-mechanize all 0.1.11-1.1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe libpodofo0.9.0 i386 0.9.0-1ubuntu2 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe calibre-bin i386 0.8.8+dfsg-1ubuntu1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/universe calibre all 0.8.8+dfsg-1ubuntu1 Could not resolve 'us.archive.ubuntu.com' Err http://us.archive.ubuntu.com/ubuntu/ oneiric/main python-webob all 1.0.8-1 Could not resolve 'us.archive.ubuntu.com' Err http://security.ubuntu.com/ubuntu/ oneiric-security/main python-django all 1.3-2ubuntu1.1 Could not resolve 'security.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu2_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu4_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/....40-3_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu4_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu4_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu4_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...-12.2_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...-12.2_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/....2.0-2_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/....1.2-1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...8~a1-1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...8~a1-1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...8~a1-1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://security.ubuntu.com/ubuntu/po...ntu1.1_all.deb Could not resolve 'security.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/....3.1-1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...buntu2_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...uild1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/....5.2-2_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...2.4-1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu2_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...12.3-1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...10-2.1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...11-1.1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu2_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...untu1_i386.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/...buntu1_all.deb Could not resolve 'us.archive.ubuntu.com' Failed to fetch http://us.archive.ubuntu.com/ubuntu/....0.8-1_all.deb Could not resolve 'us.archive.ubuntu.com' E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    so??

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •