Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Prevent pulseaudio from changing output connector?

  1. #1
    Join Date
    Mar 2008
    Location
    Oregon, USA
    Beans
    165

    Prevent pulseaudio from changing output connector?

    Hi I already posted about this, but received no response with several bumps over several days. Basically, if I re-insert my headphones into the jack, PulseAudio changes the output connector to "Analog Headphones" which produces no sound. So it forces me to manually change it back to "Analog Speakers" through the sound settings to get the audio working properly. This is a real nuisance. Any help is greatly appreciated. I'm sick of that feeling of dread the moment I accidentally disconnect my headphones. Please help!

    P.S. Hundredth post! That cheers me up. : )
    Ubuntu is my past, present, and future. Gonna help it take over the world, someday.
    System specs: CPU - AMD Phenom II X4 830 @ 3.2GHz | GPU - AMD Radeon HD 6670 | MB - MSI 760GM-P23 | RAM - 4GB DDR3 1366 MHz | OS - Arch, Windows 7

  2. #2
    Join Date
    Mar 2010
    Location
    Dublin, Ireland
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Prevent pulseaudio from changing output connector?

    When you change the settings back to "Analog Output", do the headphones work, and are the speakers muted?

    You can change the switching mechanism, by adjusting the paths in /usr/share/pulseaudio/alsa-mixer/paths. The files you probably want to be researching are analog-output-headphones.conf and analog-output.conf (the comments in analog-output.conf.common are helpful too).

    However, to see what we might need to change, could you please post the output of:

    Code:
    aplay --list-devices
    Thanks
    Matt
    blog.mattrudge.net for extra helpings of geeky Ubuntu goodness
    Get the Ubuntu Weekly Newsletter

  3. #3
    Join Date
    Mar 2008
    Location
    Oregon, USA
    Beans
    165

    Re: Prevent pulseaudio from changing output connector?

    Hello and thanks for the response. Sorry for the delay. I got into the analog-output-headphones.conf file and investigated, however I'm unsure what to do next. Here's the output of that command:
    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    I figure the automatic output switching that pulseaudio does is a feature. I don't believe I need it, as my sound card(?) already manages that for me. So it should be as simple as disabling that feature. I don't recall having this problem before with pulse on this computer, so it could've been from an update.
    Ubuntu is my past, present, and future. Gonna help it take over the world, someday.
    System specs: CPU - AMD Phenom II X4 830 @ 3.2GHz | GPU - AMD Radeon HD 6670 | MB - MSI 760GM-P23 | RAM - 4GB DDR3 1366 MHz | OS - Arch, Windows 7

  4. #4
    Join Date
    Mar 2010
    Location
    Dublin, Ireland
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Prevent pulseaudio from changing output connector?

    Hi and thanks for your reply,

    Could you try opening a terminal window and typing:

    Code:
    alsamixer
    Check that the Headphones level doesn't have "MM" beneath it. If it does, then use the arrow keys to highlight Headphones, and then press M to unmute.

    Rather than try to disable the auto-switch, it might be a better idea to see if we can fix PulseAudio so that it switches properly.
    Matt
    blog.mattrudge.net for extra helpings of geeky Ubuntu goodness
    Get the Ubuntu Weekly Newsletter

  5. #5
    Join Date
    Mar 2008
    Location
    Oregon, USA
    Beans
    165

    Re: Prevent pulseaudio from changing output connector?

    I ran alsamixer. The headphones level has '00' under it and I can't change it. Pressing M changes '00' to 'MM'.
    Ubuntu is my past, present, and future. Gonna help it take over the world, someday.
    System specs: CPU - AMD Phenom II X4 830 @ 3.2GHz | GPU - AMD Radeon HD 6670 | MB - MSI 760GM-P23 | RAM - 4GB DDR3 1366 MHz | OS - Arch, Windows 7

  6. #6
    Join Date
    Sep 2011
    Beans
    4

    Re: Prevent pulseaudio from changing output connector?

    I have exactly the same problem on a fresh Kubuntu 11.10 installed on an Asus N73S laptop.

    Here is the output of "aplay --list-devices", in case you need it:

    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC269VB Digital [ALC269VB Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    In alsamixer, the Headphone column is unmuted (i.e. 00) but there is no sound level bar on top of the [00] so the sound level cannot be adjusted (whether the headphones are plugged in or not).

    If I max out the volume in any music player, I get a very faint signal of the music in the headphones.

    I reported this in bug #911331 , which might be a duplicate of bug #909348 and bug #817943, but not exactly like bug #829843.

    It looks like bug #817943 is the culprit here.

    It's quite annoying and we don't know when it's going to be resolved, so it would be nice if someone could explain how we can disable the automatic switching mechanism in the meantime (I didn't understand much of the documentation in analog-output.conf.common). We don't need this feature anyway because, as rectec794613 mentioned, the speaker muting is already managed (somehow) when the headphones are plugged in, even if the output connector is set back to "Analog Speakers".


    Thanks in advance for your help.

    Vianney

  7. #7
    Join Date
    Mar 2010
    Location
    Dublin, Ireland
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Prevent pulseaudio from changing output connector?

    Yes, I'm starting to become convinced that we need to add options to alsa-base.conf in the /etc/modprobe.d directory. I'm just not sure which ones

    I'll keep looking, though, in case someone with more experience than me doesn't solve it in the meantime!
    Matt
    blog.mattrudge.net for extra helpings of geeky Ubuntu goodness
    Get the Ubuntu Weekly Newsletter

  8. #8
    Join Date
    Mar 2008
    Location
    Oregon, USA
    Beans
    165

    Re: Prevent pulseaudio from changing output connector?

    Quote Originally Posted by Viybel View Post
    I have exactly the same problem on a fresh Kubuntu 11.10 installed on an Asus N73S laptop.

    Here is the output of "aplay --list-devices", in case you need it:

    Code:
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC269VB Digital [ALC269VB Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    In alsamixer, the Headphone column is unmuted (i.e. 00) but there is no sound level bar on top of the [00] so the sound level cannot be adjusted (whether the headphones are plugged in or not).

    If I max out the volume in any music player, I get a very faint signal of the music in the headphones.

    I reported this in bug #911331 , which might be a duplicate of bug #909348 and bug #817943, but not exactly like bug #829843.

    It looks like bug #817943 is the culprit here.

    It's quite annoying and we don't know when it's going to be resolved, so it would be nice if someone could explain how we can disable the automatic switching mechanism in the meantime (I didn't understand much of the documentation in analog-output.conf.common). We don't need this feature anyway because, as rectec794613 mentioned, the speaker muting is already managed (somehow) when the headphones are plugged in, even if the output connector is set back to "Analog Speakers".


    Thanks in advance for your help.

    Vianney
    Exactly. Glad to see I'm not the only one who has this problem. And thanks for that bug report. I have no clue how to submit one. Output switching seems to be a basic hardware level mechanism that's been around for a while. I don't know much about it, but I'll get back if I find some info.
    Ubuntu is my past, present, and future. Gonna help it take over the world, someday.
    System specs: CPU - AMD Phenom II X4 830 @ 3.2GHz | GPU - AMD Radeon HD 6670 | MB - MSI 760GM-P23 | RAM - 4GB DDR3 1366 MHz | OS - Arch, Windows 7

  9. #9
    Join Date
    Mar 2008
    Location
    Oregon, USA
    Beans
    165

    Re: Prevent pulseaudio from changing output connector?

    I recently set up Arch as a secondary OS and installed X11, Gnome-Shell, Pulse... all the goodies. I found that I don't get this problem with that particular install of PA, so I figure it must be something that Ubuntu does with Pulse's settings that makes it behave this way.
    Ubuntu is my past, present, and future. Gonna help it take over the world, someday.
    System specs: CPU - AMD Phenom II X4 830 @ 3.2GHz | GPU - AMD Radeon HD 6670 | MB - MSI 760GM-P23 | RAM - 4GB DDR3 1366 MHz | OS - Arch, Windows 7

  10. #10
    Join Date
    Sep 2011
    Beans
    4

    Re: Prevent pulseaudio from changing output connector?

    I did this https://wiki.ubuntu.com/Audio/Instal...aDriverModules and it solved my problem.

    In some similar bug reports, other people solved their problem with this: https://help.ubuntu.com/community/HdaIntelSoundHowto

    I have to say this was really painful for me: I had to search for a dozen hours before finally being able to use my headphones on a very common computer (Asus N73S).

    Vianney

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •