Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Set time for 12 hour instead of 24 hour, in Lubuntu?

  1. #1
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    980
    Distro
    Ubuntu 14.04 Trusty Tahr

    Arrow Set time for 12 hour instead of 24 hour, in Lubuntu?

    The clock panel applet is set for the 24 hour but I want to set it for 12 hour. I can't stand it when I want to know what time it is and it shows 1300 (or whatever) instead of 1pm, so I have to sit there and count to figure out what time it is.

    Is it possible to change the clock to display 12 hour am/pm time?
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  2. #2
    Join Date
    Feb 2008
    Beans
    5,636

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Right click it->Edit Digital Clock settings.
    Change clock format from %R to %r.

  3. #3
    Join Date
    Jun 2009
    Beans
    66
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Can you right click on the clock and select Digital Clock Settings
    Under Clock Format
    Change to something like

    Code:
    %a %b %I:%M %P
    That will give you Date/day time

    You can change that to your own preference
    More info in terminal type in
    man strftime

  4. #4
    Join Date
    Jan 2011
    Location
    Linux heaven
    Beans
    980
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Quote Originally Posted by TeoBigusGeekus View Post
    Right click it->Edit Digital Clock settings.
    Change clock format from %R to %r.
    No kidding? That easy? Cool.

    Thanx.

    That resolved it.
    Be inspired by phreaking.
    http://tinyurl.com/about-phreaking
    And don't touch the Linux hat!
    Linux user #572109


  5. #5
    Join Date
    Mar 2007
    Beans
    318

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    You can always change how time is displayed by choosing "System Settings - Regional & Language - Time & Dates (Tab)" and changing how it's displayed in there too.

  6. #6
    Join Date
    Nov 2008
    Beans
    6
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Right click on the LXDE panel's digital clock and then left click on "Digital Clock" Settings. The configuration window that pops up will refer you to man 3 strftime. That function was not present in 11.04 but it was present in 11.10. In 12.04, it's gone again. In 11.04, I couldn't figure out why the manual page was missing but this time around, I got lucky. The answer was at

    http://kernel.org/doc/man-pages/missing_pages.html

    In short, crank up Synaptic and add two packages:
    manpages-posix and manpages-posix-dev.

    As always, thanks to those who share their knowledge.

  7. #7
    Join Date
    Dec 2009
    Beans
    14

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Just to let anyone know how to actually change it in most recent distros add in this:
    Code:
    %I:%M:%S %p
    Replace the %R part with the code.

    enjoy.

    Oh and for the record I use Ubuntu with LXDE, Compiz has better performance with it.

  8. #8
    Join Date
    May 2011
    Beans
    8

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Quote Originally Posted by TeoBigusGeekus View Post
    Right click it->Edit Digital Clock settings.
    Change clock format from %R to %r.
    Thanks worked like a charm.

    I hd to re-set my password using my old dell inspiron 6000 with keybordtht have the a, . not working specially to reply to you and thank you..

    and hey guys with old machines looking for something lighter than even xp do not think of windows 7 or 8 .... just go LUBUNtu!!!


  9. #9
    Join Date
    Mar 2013
    Beans
    3

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Works great! Thanks for the tip!

  10. #10
    Join Date
    Feb 2012
    Beans
    74

    Re: Set time for 12 hour instead of 24 hour, in Lubuntu?

    Followed the guidance of this post reply. The format is now 12hr but four hours ahead of the correct time. BIOS time was correct when last checked. Guidance sought.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •