Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Hard drive: Read only problem

  1. #1
    Join Date
    Apr 2011
    Beans
    43

    Hard drive: Read only problem

    I'm trying to create a backup of all my files on an external hard drive but every time I try I get an error message saying that it's a "Read Only File System". I've tried re-formatting to NTFS and changing the permissions but none of it seems to be working..

    Anyone know anything about this?

  2. #2
    Join Date
    Dec 2009
    Beans
    319
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hard drive: Read only problem

    first, I would not use NTFS for an external drive. It's not a Linux native file system. I would keep it as a FAT 32, for maximum portability if if it ONLY going to be used to Linux, and you want File permissions, then I'd go with ext4.

    I DO find it odd that it is mounting as Read-only. if this is a USB it SHOULD automount as read write.

    For now if this continues, use
    Code:
    sudo mount -t fat32 -o rw /dev/sdb1 /mnt
    This assumes a fat32 file system and that your drive is the second hard drive connected to the computer, AND that you want to use the first/only partition on that drive.

    This also means you may have to use type
    Code:
    sudo nautilus
    to back up said files. as it will mount the hard drive for the root user, but that should do it. if you code post us the output of
    Code:
    cat /etc/fstab
    that would tell us if there is anything "wonky" with your file system mounting procedure

    "Wonky" is an industry term

  3. #3
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,909
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hard drive: Read only problem

    fat32 has a file-syze limit of 4GB which is pretty annoyng nowadays if you have dvd-iso's. If you don't then that's fine! Unfortunately nowadays you cannot make happy everyone MacOS/Win/*nix. If you are working between win and *nix, NTFS is a good choice in my opinion (for the reason stated above). If you are working with MacOS then you can you HFS (no journal!!!). Fat32 it will work on all well if you don't have files >=4gb

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  4. #4
    Join Date
    Apr 2011
    Beans
    43

    Re: Hard drive: Read only problem

    Quote Originally Posted by Synoc View Post
    first, I would not use NTFS for an external drive. It's not a Linux native file system. I would keep it as a FAT 32, for maximum portability if if it ONLY going to be used to Linux, and you want File permissions, then I'd go with ext4.

    I DO find it odd that it is mounting as Read-only. if this is a USB it SHOULD automount as read write.

    For now if this continues, use
    Code:
    sudo mount -t fat32 -o rw /dev/sdb1 /mnt
    This assumes a fat32 file system and that your drive is the second hard drive connected to the computer, AND that you want to use the first/only partition on that drive.

    This also means you may have to use type
    Code:
    sudo nautilus
    to back up said files. as it will mount the hard drive for the root user, but that should do it. if you code post us the output of
    Code:
    cat /etc/fstab
    that would tell us if there is anything "wonky" with your file system mounting procedure

    "Wonky" is an industry term
    This code didn't work for some reason:
    Code:
    sudo mount -t fat32 -o rw /dev/sdb1 /mnt
    Instead I got this read out:
    Code:
    mount: unknown filesystem type 'fat32'
    mount: maybe you meant 'vfat'?
    For
    Code:
    cat /etc/fstab
    I got this:
    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid -o value -s UUID' to print the universally unique identifier
    # for a device; this may be used with UUID= as a more robust way to name
    # devices that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    nodev,noexec,nosuid 0       0
    /dev/sda1       /               ext4    errors=remount-ro 0       1
    /dev/sda5       none            swap    sw              0       0
    The external drive doesn't seem to register.

  5. #5
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,909
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hard drive: Read only problem

    the type is wrong , ot should be:
    Code:
    sudo mount -t vfat /dev/sdb1 /mnt

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  6. #6
    Join Date
    Apr 2011
    Beans
    43

    Re: Hard drive: Read only problem

    Quote Originally Posted by fdrake View Post
    fat32 has a file-syze limit of 4GB which is pretty annoyng nowadays if you have dvd-iso's. If you don't then that's fine! Unfortunately nowadays you cannot make happy everyone MacOS/Win/*nix. If you are working between win and *nix, NTFS is a good choice in my opinion (for the reason stated above). If you are working with MacOS then you can you HFS (no journal!!!). Fat32 it will work on all well if you don't have files >=4gb
    Ah I see.

    I can't put ANY amount of files from my computer to my hard drive. I don't get it..

  7. #7
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,909
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hard drive: Read only problem

    Quote Originally Posted by AaronDaycentChild View Post
    Ah I see.

    I can't put ANY amount of files from my computer to my hard drive. I don't get it..
    no you can put files in the fat32 system but the files cannot be bigger that 4GB in size. let's say you have a *.rar or *.zip file . The cannot be bigger then 4GB otherwise the copying process won't be successful!
    see http://wiki.vuze.com/w/FAT32_file_size_limit

    hold a moment are you mounting a FAT32 or NTFS disk?

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  8. #8
    Join Date
    Apr 2011
    Beans
    43

    Re: Hard drive: Read only problem

    Quote Originally Posted by fdrake View Post
    no you can put files in the fat32 system but the files cannot be bigger that 4GB in size. let's say you have a *.rar or *.zip file . The cannot be bigger then 4GB otherwise the copying process won't be successful!
    see http://wiki.vuze.com/w/FAT32_file_size_limit
    Oh, I see now. Thank you!

    Quote Originally Posted by Synoc View Post
    first, I would not use NTFS for an external drive. It's not a Linux native file system. I would keep it as a FAT 32, for maximum portability if if it ONLY going to be used to Linux, and you want File permissions, then I'd go with ext4.

    I DO find it odd that it is mounting as Read-only. if this is a USB it SHOULD automount as read write.

    For now if this continues, use
    Code:
    sudo mount -t fat32 -o rw /dev/sdb1 /mnt
    This assumes a fat32 file system and that your drive is the second hard drive connected to the computer, AND that you want to use the first/only partition on that drive.

    This also means you may have to use type
    Code:
    sudo nautilus
    to back up said files. as it will mount the hard drive for the root user, but that should do it. if you code post us the output of
    Code:
    cat /etc/fstab
    that would tell us if there is anything "wonky" with your file system mounting procedure

    "Wonky" is an industry term
    Okay, I got it working. It's finally backing up. No problems yet.

    Just one question: If I quit the terminal will the process cancel?

  9. #9
    Join Date
    May 2006
    Location
    Boston
    Beans
    1,909
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hard drive: Read only problem

    to mount ntfs do:
    Code:
    sudo apt-get install  ntfs-3g ntfs-config
    sudo reboot now
    sudo mkdir /media/ntfs
    sudo mount -t vfuse /dev/sdb1 /media/ntfs
    Last edited by fdrake; December 27th, 2011 at 10:29 PM.

    blog
    Donations BTC : 12FwoB7uAM5FnweykpR1AEEDVFaTLTYFkS
    DOUBLEPLUSGOOD!!

  10. #10
    Join Date
    Dec 2009
    Beans
    319
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Hard drive: Read only problem

    exiting terminal will have no effect on your mounted file systems. BTW sorry about the code, been a while... the /etc/fstab file will not show any drives connected to the... What it does show is how the permenantly mounted file systems are mounted. If you want this new hard drive to permanently mount, you add it to this file. if you want to mount it as needed, then "sudo mount" will work. That said. IS this a USB HHD? and if so, haave you been able to get it to automount?

    PS sorry about the mount syntax, I am rusty on manually mounting a fat system.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •