Results 1 to 10 of 10

Thread: Conky shows LightDM background instead of Xfce desktop

  1. #1
    Join Date
    Oct 2008
    Location
    Ontario
    Beans
    11
    Distro
    Xubuntu 10.04 Lucid Lynx

    Conky shows LightDM background instead of Xfce desktop

    This is a bit of a weird issue. When starting Conky on Xubuntu 11.10, the background shows LightDM instead of the Xfce desktop. It does not matter when I start Conky; even after having logged in for several minutes conky will still display the LightDM background when started.

    Here is my conkyrc file (header omitted):
    Code:
    alignment bottom_right
    background yes
    border_width 1
    cpu_avg_samples 2
    default_color white
    default_outline_color white
    default_shade_color white
    draw_borders no
    draw_graph_borders yes
    draw_outline no
    draw_shades no
    use_xft yes
    xftfont Sawasdee:size=16
    gap_x 5
    gap_y 20
    minimum_size 5 5
    net_avg_samples 2
    no_buffers yes
    out_to_console no
    out_to_stderr no
    extra_newline no
    own_window yes
    own_window_class Conky
    own_window_type desktop
    own_window_transparent yes
    stippled_borders 0
    update_interval 1.0
    uppercase no
    use_spacer none
    show_graph_scale no
    show_graph_range no
    format_human_readable yes
    double_buffer yes
    
    lua_load ~/Projects/Scripts/draw_bg.lua
    lua_draw_hook_pre draw_bg
    
    TEXT
    ${outlinecolor #888888}${font Sawasdee:size=50}${time %I:%M %P}$font
    ${font Sawasdee:size=20}${time %A, %e %B %Y}$font${if_existing /proc/acpi/battery/BAT0}
    ${font Sawasdee:bold:size=16}Battery:$font $battery_percent%, $battery_time${endif}${if_up wlan0}
    ${font Sawasdee:bold:size=16}Wireless: $font${wireless_essid wlan0} ${wireless_link_qual_perc wlan0}%${endif}
    ${font Sawasdee:bold:size=16}CPU:$font $cpu%${font Sawasdee:size=12}
    ${top cpu 1}% ${top name 1}
    ${top cpu 2}% ${top name 2}

    I also tried changing own_window_type between "override" and "desktop" modes; both behave the same.
    Attached Images Attached Images

  2. #2
    Join Date
    Jul 2006
    Beans
    1,876
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Conky shows LightDM background instead of Xfce desktop


  3. #3
    Join Date
    Oct 2008
    Location
    Ontario
    Beans
    11
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: Conky shows LightDM background instead of Xfce desktop

    Yeah, I already do that. It doesn't matter how long I wait; conky still shows the wrong background if started minutes or even hours after login.

  4. #4
    Join Date
    Feb 2008
    Beans
    1,145
    Distro
    Xubuntu

    Re: Conky shows LightDM background instead of Xfce desktop

    http://ubuntuforums.org/showthread.php?t=1861153

    This one might help (might not, but what the heck).
    Help yourself: Ubuntu Docs - Ubuntu Packages

  5. #5
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Conky shows LightDM background instead of Xfce desktop

    Try
    Code:
    own_window_type normal

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Conky shows LightDM background instead of Xfce desktop

    Quote Originally Posted by gsmanners View Post
    http://ubuntuforums.org/showthread.php?t=1861153

    This one might help (might not, but what the heck).
    +1.
    Add:
    Code:
    own_window_argb_visual yes
    own_window_argb_value 0
    You need to have the compositor enabled for them to work.

  7. #7
    Join Date
    Oct 2008
    Location
    Ontario
    Beans
    11
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: Conky shows LightDM background instead of Xfce desktop

    Thanks guys, ARGB visual did it (and yes, I have the compositor enabled).

    own_window_type_normal actually draws window frames around Conky, which is not what I wanted.

  8. #8
    Join Date
    Nov 2009
    Beans
    1

    Re: Conky shows LightDM background instead of Xfce desktop

    Thanks Toz! your answer was helpful for me!

  9. #9
    Join Date
    Feb 2010
    Beans
    Hidden!

    Re: Conky shows LightDM background instead of Xfce desktop

    Quote Originally Posted by Zercius View Post
    Thanks guys, ARGB visual did it (and yes, I have the compositor enabled).

    own_window_type_normal actually draws window frames around Conky, which is not what I wanted.
    From the #! Forums, I don't use Xfce:

    Quote Originally Posted by VastOne
    These are my settings in conky for transparency with Xfce
    Code:
    draw_borders no
    own_window_argb_visual yes
    own_window_type normal
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
    own_window yes
    own_window_transparent yes
    own_window_class conky-semi
    If I do not enable compositing, I have a black box background

    I do not use Cairo Compositing, I use xcompmgr, which is the #! default

    On several machines I am responsible for, these are the same settings ... I have never seen or known of any issues with xcompmgr... Not sure if this means anything at all, but just saying I do not have issues of lag or cpu/ram usage with xcompmgr

  10. #10
    Join Date
    Jun 2011
    Beans
    4
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Conky shows LightDM background instead of Xfce desktop

    Thanks Toz!

    Ubuntu 12.04 / LXDE / Openbox Window Manager / with xcompmgr running.

    "own_window_argb_visual yes" made my own background visible behind conky, instead of the (well known, default orange-ish) ubuntu login background.

    All my "own-window" entries in ~/.conkyrc were:

    Code:
    own_window yes
    own_window_class Conky
    own_window_type normal
    own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
    own_window_transparent yes
    own_window_argb_visual yes

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •