Hello everyone

i have an old version of hardy 8.04.4 LTS ubuntu-server and i wanted to upgrade it to lucid 10.04

here what i got

Code:
uname -a
PHP Code:
Linux <xxxxxxx2.6.32.2-xxxx-std-ipv4-32 #1 SMP Tue Dec 29 14:40:32 UTC 2009 i686 GNU/Linux 
Code:
lsb_release -a
PHP Code:
Distributor ID:    Ubuntu
Description
:    Ubuntu 8.04.4 LTS
Release
:    8.04
Codename
:    hardy 
https://help.ubuntu.com/community/LucidUpgrades
i did exactly as in "Upgrade from 8.04 LTS to 10.04 LTS"

after
Code:
 sudo do-release-upgrade
then i got this


PHP Code:
Traceback (most recent call last):
  
File "/usr/bin/do-release-upgrade"line 8in <module>
    
from UpdateManager.Core.DistUpgradeFetcherCore import DistUpgradeFetcherCore
  File 
"/usr/lib/python2.5/site-packages/UpdateManager/Core/DistUpgradeFetcherCore.py"line 34in <module>
    
import GnuPGInterface
ImportError
No module named GnuPGInterface 
i tried to do
Code:
apt-get upgrade
then i got this
PHP Code:
Reading package lists... Done
Building dependency tree       
Reading state information
... Done
You might want to run 
'apt-get -f install' to correct these.
The following packages have unmet dependencies.
  
compiz-gnomeDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  evolution
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gdm
Dependslibcanberra-gtk0 (>= 0.4but it is not installed
       Depends
libgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
       Depends
upstart-job
  gnome
-appletsDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gnome
-control-centerDependslibcanberra-gtk0 (>= 0.2but it is not installed
                        Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gnome
-screensaverDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gnome
-session-binDependslibgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  gnome
-settings-daemonDependslibcanberra-gtk0 (>= 0.2but it is not installed
                         Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  initramfs
-toolsDependsutil-linux (> 2.15~rc1but 2.13.1-5ubuntu3.1 is installed
  irssi
Dependslibperl5.10 (>= 5.10.1but it is not installed
  language
-support-writing-enDependsmyspell-en-us but it is not installed
  libappindicator0
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libapt
-pkg-perlDependsperlapi-5.8.8 but it is not installable
  libauthen
-pam-perlDependsperlapi-5.8.7 but it is not installable
  libcupsimage2
Dependslibcups2 (>= 1.4.0but it is not installed
  libdbusmenu
-gtk1Dependslibgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
  libedataserverui1.2
-8Dependslibgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  libevdocument2
Dependslibgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  libevview2
Dependslibgtk2.0-(>= 2.20.0but 2.12.9-3ubuntu5 is installed
  libgnome
-desktop-2-17Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgnome
-window-settings1Dependslibgtk2.0-(>= 2.15.0but 2.12.9-3ubuntu5 is installed
  libgnome2
-canvas-perlDependsperlapi-5.8.8 but it is not installable
  libgnome2
-perlDependsperlapi-5.8.7 but it is not installable
  libgnomekbd4
Dependslibgtk2.0-(>= 2.20.0but 2.12.9-3ubuntu5 is installed
  libgtk2
-perlDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgtkhtml
-editor0Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgtkhtml3.14
-19Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgucharmap7
Dependslibgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
  libindicator0
Dependslibgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
  libmetacity
-private0Dependslibcanberra-gtk0 (>= 0.2but it is not installed
  libnet
-ssleay-perlDependsperlapi-5.8.7 but it is not installable
  libpurple0
Dependslibperl5.10 (>= 5.10.1but it is not installed
  librsvg2
-2Dependslibgtk2.0-(>= 2.16but 2.12.9-3ubuntu5 is installed
  librsvg2
-commonDependslibgtk2.0-(>= 2.16but 2.12.9-3ubuntu5 is installed
  libsnmp15
Dependslibperl5.8 (>= 5.8.8but it is not installable
  libsvn
-perlDependsperlapi-5.8.8 but it is not installable
  libtext
-iconv-perlDependsperlapi-5.8.7 but it is not installable
  libxml
-parser-perlDependsperlapi-5.8.8 but it is not installable
  metacity
Dependslibcanberra-gtk0 (>= 0.2but it is not installed
            Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  openoffice
.org-base-coreDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-calcDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-drawDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-gnomeDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-gtkDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
                      Depends
libgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  openoffice
.org-impressDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-style-galaxyDependsopenoffice.org-core (>= 1:3.2.0~betabut it is not installed
  openoffice
.org-style-humanDependsopenoffice.org-common (= 1:2.4.1-1ubuntu2.5but 1:3.2.0-7ubuntu4.2 is installed
  openoffice
.org-thesaurus-deDependsopenoffice.org-core (>= 1.9but it is not installed
  openoffice
.org-thesaurus-de-chDependsopenoffice.org-core (>= 1.9but it is not installed
  openoffice
.org-thesaurus-plDependsopenoffice.org-core (>= 1.9but it is not installed
  openoffice
.org-writerDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  pidgin
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  policykit
-1-gnomeDependslibgtk2.0-(>= 2.17.1but 2.12.9-3ubuntu5 is installed
  python
Dependspython-minimal (= 2.5.2-0ubuntu1but 2.6.5-0ubuntu1 is installed
  python
-cairoDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-evinceDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-evolutionDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gconfDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-glade2Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
                 Depends
libgtk2.0-(>= 2.19.0but 2.12.9-3ubuntu5 is installed
  python
-gnome2Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomeappletDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomecanvasDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomedesktopDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomekeyringDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomeprintDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gobjectDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gtk2Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
               Depends
libgtk2.0-(>= 2.19.1but 2.12.9-3ubuntu5 is installed
  python
-gtopDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-mediaprofilesDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-metacityDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-pyorbitDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-rsvgDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-totem-plparserDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-unoDependsopenoffice.org-core (= 1:2.4.1-1ubuntu2.5but it is not installed
  python
-wnckDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  slapd
Dependslibperl5.10 (>= 5.10.1but it is not installed
  udev
Dependsupstart-job
        Depends
util-linux (> 2.15~rc2but 2.13.1-5ubuntu3.1 is installed
  ufw
Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
       Depends
upstart-job
  util
-linux-localesDependsutil-linux (>= 2.17.2-0but 2.13.1-5ubuntu3.1 is installed
  x11
-commonDependsupstart-job
  xchat
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
         Depends
libperl5.10 (>= 5.10.1but it is not installed
  xchat
-gnomeDependslibcanberra-gtk0 (>= 0.3but it is not installed
               Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
               Depends
libperl5.10 (>= 5.10.0but it is not installed
E
Unmet dependencies. Try using -f

then i tried
Code:
apt-get -f install
and i got this
PHP Code:
Reading package lists... Done
Building dependency tree       
Reading state information
... Done
Correcting dependencies
... failed.
The following packages have unmet dependencies.
  
compiz-gnomeDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  evolution
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gdm
Dependslibcanberra-gtk0 (>= 0.4but it is not installed
       Depends
libgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
       Depends
upstart-job
  gnome
-appletsDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gnome
-control-centerDependslibcanberra-gtk0 (>= 0.2but it is not installed
                        Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gnome
-screensaverDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  gnome
-session-binDependslibgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  gnome
-settings-daemonDependslibcanberra-gtk0 (>= 0.2but it is not installed
                         Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  initramfs
-toolsDependsutil-linux (> 2.15~rc1but 2.13.1-5ubuntu3.1 is installed
  irssi
Dependslibperl5.10 (>= 5.10.1but it is not installed
  language
-support-writing-enDependsmyspell-en-us but it is not installed
  libappindicator0
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libapt
-pkg-perlDependsperlapi-5.8.8 but it is not installable
  libauthen
-pam-perlDependsperlapi-5.8.7 but it is not installable
  libcupsimage2
Dependslibcups2 (>= 1.4.0but it is not installed
  libdbusmenu
-gtk1Dependslibgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
  libedataserverui1.2
-8Dependslibgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  libevdocument2
Dependslibgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  libevview2
Dependslibgtk2.0-(>= 2.20.0but 2.12.9-3ubuntu5 is installed
  libgnome
-desktop-2-17Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgnome
-window-settings1Dependslibgtk2.0-(>= 2.15.0but 2.12.9-3ubuntu5 is installed
  libgnome2
-canvas-perlDependsperlapi-5.8.8 but it is not installable
  libgnome2
-perlDependsperlapi-5.8.7 but it is not installable
  libgnomekbd4
Dependslibgtk2.0-(>= 2.20.0but 2.12.9-3ubuntu5 is installed
  libgtk2
-perlDependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgtkhtml
-editor0Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgtkhtml3.14
-19Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  libgucharmap7
Dependslibgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
  libindicator0
Dependslibgtk2.0-(>= 2.16.0but 2.12.9-3ubuntu5 is installed
  libmetacity
-private0Dependslibcanberra-gtk0 (>= 0.2but it is not installed
  libnet
-ssleay-perlDependsperlapi-5.8.7 but it is not installable
  libpurple0
Dependslibperl5.10 (>= 5.10.1but it is not installed
  librsvg2
-2Dependslibgtk2.0-(>= 2.16but 2.12.9-3ubuntu5 is installed
  librsvg2
-commonDependslibgtk2.0-(>= 2.16but 2.12.9-3ubuntu5 is installed
  libsnmp15
Dependslibperl5.8 (>= 5.8.8but it is not installable
  libsvn
-perlDependsperlapi-5.8.8 but it is not installable
  libtext
-iconv-perlDependsperlapi-5.8.7 but it is not installable
  libxml
-parser-perlDependsperlapi-5.8.8 but it is not installable
  metacity
Dependslibcanberra-gtk0 (>= 0.2but it is not installed
            Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  openoffice
.org-base-coreDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-calcDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-drawDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-gnomeDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-gtkDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
                      Depends
libgtk2.0-(>= 2.14.0but 2.12.9-3ubuntu5 is installed
  openoffice
.org-impressDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  openoffice
.org-style-galaxyDependsopenoffice.org-core (>= 1:3.2.0~betabut it is not installed
  openoffice
.org-style-humanDependsopenoffice.org-common (= 1:2.4.1-1ubuntu2.5but 1:3.2.0-7ubuntu4.2 is installed
  openoffice
.org-thesaurus-deDependsopenoffice.org-core (>= 1.9but it is not installed
  openoffice
.org-thesaurus-de-chDependsopenoffice.org-core (>= 1.9but it is not installed
  openoffice
.org-thesaurus-plDependsopenoffice.org-core (>= 1.9but it is not installed
  openoffice
.org-writerDependsopenoffice.org-core (= 1:3.2.0-7ubuntu4.2but it is not installed
  pidgin
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
  policykit
-1-gnomeDependslibgtk2.0-(>= 2.17.1but 2.12.9-3ubuntu5 is installed
  python
Dependspython-minimal (= 2.5.2-0ubuntu1but 2.6.5-0ubuntu1 is installed
  python
-cairoDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-evinceDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-evolutionDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gconfDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-glade2Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
                 Depends
libgtk2.0-(>= 2.19.0but 2.12.9-3ubuntu5 is installed
  python
-gnome2Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomeappletDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomecanvasDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomedesktopDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomekeyringDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gnomeprintDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gobjectDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-gtk2Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
               Depends
libgtk2.0-(>= 2.19.1but 2.12.9-3ubuntu5 is installed
  python
-gtopDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-mediaprofilesDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-metacityDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-pyorbitDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-rsvgDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-totem-plparserDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  python
-unoDependsopenoffice.org-core (= 1:2.4.1-1ubuntu2.5but it is not installed
  python
-wnckDependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
  slapd
Dependslibperl5.10 (>= 5.10.1but it is not installed
  udev
Dependsupstart-job
        Depends
util-linux (> 2.15~rc2but 2.13.1-5ubuntu3.1 is installed
  ufw
Dependspython (>= 2.6but 2.5.2-0ubuntu1 is installed
       Depends
upstart-job
  util
-linux-localesDependsutil-linux (>= 2.17.2-0but 2.13.1-5ubuntu3.1 is installed
  x11
-commonDependsupstart-job
  xchat
Dependslibgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
         Depends
libperl5.10 (>= 5.10.1but it is not installed
  xchat
-gnomeDependslibcanberra-gtk0 (>= 0.3but it is not installed
               Depends
libgtk2.0-(>= 2.18.0but 2.12.9-3ubuntu5 is installed
               Depends
libperl5.10 (>= 5.10.0but it is not installed
E
ErrorpkgProblemResolver::Resolve generated breaksthis may be caused by held packages.
EUnable to correct dependencies 
i tried that also

Code:
dpkg --configure -a
PHP Code:
dpkgdependency problems prevent configuration of libgnomekbd4:
 
libgnomekbd4 depends on libgtk2.0-(>= 2.20.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing libgnomekbd4 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-gnome2:
 
python-gnome2 depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-gnome2 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of gdm:
 
gdm depends on libcanberra-gtk0 (>= 0.4); however:
  
Package libcanberra-gtk0 is not installed.
 
gdm depends on libgtk2.0-(>= 2.16.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
 
gdm depends on upstart-jobhowever:
  
Package upstart-job is not installed.
dpkgerror processing gdm (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of initramfs-tools:
 
initramfs-tools depends on util-linux (>> 2.15~rc1); however:
  
Version of util-linux on system is 2.13.1-5ubuntu3.1.
dpkgerror processing initramfs-tools (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of xchat-gnome:
 
xchat-gnome depends on libcanberra-gtk0 (>= 0.3); however:
  
Package libcanberra-gtk0 is not installed.
 
xchat-gnome depends on libgtk2.0-(>= 2.18.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
 
xchat-gnome depends on libperl5.10 (>= 5.10.0); however:
  
Package libperl5.10 is not installed.
dpkgerror processing xchat-gnome (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-wnck:
 
python-wnck depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-wnck (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of gnome-settings-daemon:
 
gnome-settings-daemon depends on libcanberra-gtk0 (>= 0.2); however:
  
Package libcanberra-gtk0 is not installed.
 
gnome-settings-daemon depends on libgnomekbd4 (>= 2.29.5); however:
  
Package libgnomekbd4 is not configured yet.
 
gnome-settings-daemon depends on libgtk2.0-(>= 2.18.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing gnome-settings-daemon (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of openoffice.org-gnome:
 
openoffice.org-gnome depends on openoffice.org-core (= 1:3.2.0-7ubuntu4.2); however:
  
Package openoffice.org-core is not installed.
dpkgerror processing openoffice.org-gnome (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of metacity:
 
metacity depends on libcanberra-gtk0 (>= 0.2); however:
  
Package libcanberra-gtk0 is not installed.
 
metacity depends on libgtk2.0-(>= 2.18.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing metacity (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of libgnome-desktop-2-17:
 
libgnome-desktop-2-17 depends on libgtk2.0-(>= 2.18.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing libgnome-desktop-2-17 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-gnomeapplet:
 
python-gnomeapplet depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-gnomeapplet (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-mediaprofiles:
 
python-mediaprofiles depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-mediaprofiles (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of openoffice.org-impress:
 
openoffice.org-impress depends on openoffice.org-core (= 1:3.2.0-7ubuntu4.2); however:
  
Package openoffice.org-core is not installed.
dpkgerror processing openoffice.org-impress (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of libgnome-window-settings1:
 
libgnome-window-settings1 depends on libgnome-desktop-2-17 (>= 1:2.29.92); however:
  
Package libgnome-desktop-2-17 is not configured yet.
 
libgnome-window-settings1 depends on libgtk2.0-(>= 2.15.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing libgnome-window-settings1 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of libpurple0:
 
libpurple0 depends on libperl5.10 (>= 5.10.1); however:
  
Package libperl5.10 is not installed.
dpkgerror processing libpurple0 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of openoffice.org-style-galaxy:
 
openoffice.org-style-galaxy depends on openoffice.org-core (>= 1:3.2.0~beta); however:
  
Package openoffice.org-core is not installed.
dpkgerror processing openoffice.org-style-galaxy (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-evince:
 
python-evince depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-evince (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-gnomecanvas:
 
python-gnomecanvas depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-gnomecanvas (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of libdeskbar-tracker:
 
libdeskbar-tracker depends on python-gnome2however:
  
Package python-gnome2 is not configured yet.
dpkgerror processing libdeskbar-tracker (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of policykit-1-gnome:
 
policykit-1-gnome depends on libgtk2.0-(>= 2.17.1); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing policykit-1-gnome (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-totem-plparser:
 
python-totem-plparser depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-totem-plparser (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-gnome2-desktop:
 
python-gnome2-desktop depends on python-evince (>= 2.30.0-0ubuntu1.1); however:
  
Package python-evince is not configured yet.
 
python-gnome2-desktop depends on python-gnomeapplet (>= 2.30.0-0ubuntu1.1); however:
  
Package python-gnomeapplet is not configured yet.
 
python-gnome2-desktop depends on python-mediaprofiles (>= 2.30.0-0ubuntu1.1); however:
  
Package python-mediaprofiles is not configured yet.
 
python-gnome2-desktop depends on python-totem-plparser (>= 2.30.0-0ubuntu1.1); however:
  
Package python-totem-plparser is not configured yet.
 
python-gnome2-desktop depends on python-wnck (>= 2.30.0-0ubuntu1.1); however:
  
Package python-wnck is not configured yet.
dpkgerror processing python-gnome2-desktop (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of libappindicator0:
 
libappindicator0 depends on libgtk2.0-(>= 2.18.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing libappindicator0 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of libevdocument2:
 
libevdocument2 depends on libgtk2.0-(>= 2.14.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing libevdocument2 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-cairo:
 
python-cairo depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-cairo (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of gnome-control-center:
 
gnome-control-center depends on libappindicator0 (>= 0.0.19); however:
  
Package libappindicator0 is not configured yet.
 
gnome-control-center depends on libcanberra-gtk0 (>= 0.2); however:
  
Package libcanberra-gtk0 is not installed.
 
gnome-control-center depends on libgnome-desktop-2-17 (>= 1:2.29.92); however:
  
Package libgnome-desktop-2-17 is not configured yet.
 
gnome-control-center depends on libgnome-window-settings1 (= 1:2.30.1-0ubuntu2); however:
  
Package libgnome-window-settings1 is not configured yet.
 
gnome-control-center depends on libgnomekbd4 (>= 2.29.5); however:
  
Package libgnomekbd4 is not configured yet.
 
gnome-control-center depends on libgtk2.0-(>= 2.18.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
 
gnome-control-center depends on gnome-settings-daemon (>= 2.26); however:
  
Package gnome-settings-daemon is not configured yet.
dpkgerror processing gnome-control-center (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of libevview2:
 
libevview2 depends on libevdocument2 (>= 2.29.5); however:
  
Package libevdocument2 is not configured yet.
 
libevview2 depends on libgtk2.0-(>= 2.20.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing libevview2 (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-evolution:
 
python-evolution depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-evolution (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-pyorbit:
 
python-pyorbit depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-pyorbit (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of openoffice.org-draw:
 
openoffice.org-draw depends on openoffice.org-core (= 1:3.2.0-7ubuntu4.2); however:
  
Package openoffice.org-core is not installed.
dpkgerror processing openoffice.org-draw (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-gtop:
 
python-gtop depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-gtop (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of irssi:
 
irssi depends on libperl5.10 (>= 5.10.1); however:
  
Package libperl5.10 is not installed.
dpkgerror processing irssi (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of openoffice.org-gtk:
 
openoffice.org-gtk depends on openoffice.org-core (= 1:3.2.0-7ubuntu4.2); however:
  
Package openoffice.org-core is not installed.
 
openoffice.org-gtk depends on libgtk2.0-(>= 2.14.0); however:
  
Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkgerror processing openoffice.org-gtk (--configure):
 
dependency problems leaving unconfigured
dpkg
dependency problems prevent configuration of python-gnomeprint:
 
python-gnomeprint depends on python (>= 2.6); however:
  
Version of python on system is 2.5.2-0ubuntu1.
dpkgerror processing python-gnomeprint (--configure):
 
dependency problems leaving unconfigured
Setting up dictionaries
-common (1.4.0ubuntu2) ...
Can't load '/usr/lib/perl5/auto/Text/Iconv/Iconv.so' for module Text::Iconv: /usr/lib/perl5/auto/Text/Iconv/Iconv.so: undefined symbol: Perl_Tcurpad_ptr at /usr/lib/perl/5.10/DynaLoader.pm line 193.
 at /usr/share/perl5/Debian/DictionariesCommon.pm line 6
Compilation failed in require at /usr/share/perl5/Debian/DictionariesCommon.pm line 6.
BEGIN failed--compilation aborted at /usr/share/perl5/Debian/DictionariesCommon.pm line 6.
Compilation failed in require at /usr/sbin/update-default-ispell line 3.
BEGIN failed--compilation aborted at /usr/sbin/update-default-ispell line 3.
dpkg: error processing dictionaries-common (--configure):
 subprocess installed post-installation script returned error exit status 9
dpkg: dependency problems prevent configuration of gnome-session:
 gnome-session depends on gnome-settings-daemon (>= 2.26); however:
  Package gnome-settings-daemon is not configured yet.
dpkg: error processing gnome-session (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtkhtml-editor0:
 libgtkhtml-editor0 depends on libgtk2.0-0 (>= 2.18.0); however:
  Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkg: error processing libgtkhtml-editor0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librsvg2-2:
 librsvg2-2 depends on libgtk2.0-0 (>= 2.16); however:
  Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkg: error processing librsvg2-2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libedataserverui1.2-8:
 libedataserverui1.2-8 depends on libgtk2.0-0 (>= 2.14.0); however:
  Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkg: error processing libedataserverui1.2-8 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgtk2-perl:
 libgtk2-perl depends on libgtk2.0-0 (>= 2.18.0); however:
  Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkg: error processing libgtk2-perl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gnomedesktop:
 python-gnomedesktop depends on libgnome-desktop-2-17 (>= 1:2.29.92); however:
  Package libgnome-desktop-2-17 is not configured yet.
 python-gnomedesktop depends on python (>= 2.6); however:
  Version of python on system is 2.5.2-0ubuntu1.
dpkg: error processing python-gnomedesktop (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of x11-common:
 x11-common depends on upstart-job; however:
  Package upstart-job is not installed.
dpkg: error processing x11-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-glade2:
 python-glade2 depends on python (>= 2.6); however:
  Version of python on system is 2.5.2-0ubuntu1.
 python-glade2 depends on libgtk2.0-0 (>= 2.19.0); however:
  Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
dpkg: error processing python-glade2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of myspell-en-za:
 myspell-en-za depends on dictionaries-common (>= 0.10) | openoffice.org-updatedicts; however:
  Package dictionaries-common is not configured yet.
  Package openoffice.org-updatedicts is not installed.
  Package dictionaries-common which provides openoffice.org-updatedicts is not configured yet.
dpkg: error processing myspell-en-za (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of util-linux-locales:
 util-linux-locales depends on util-linux (>= 2.17.2-0); however:
  Version of util-linux on system is 2.13.1-5ubuntu3.1.
dpkg: error processing util-linux-locales (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of evolution-exchange:
 evolution-exchange depends on libedataserverui1.2-8 (>= 2.28.3); however:
  Package libedataserverui1.2-8 is not configured yet.
dpkg: error processing evolution-exchange (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-gnomekeyring:
 python-gnomekeyring depends on python (>= 2.6); however:
  Version of python on system is 2.5.2-0ubuntu1.
dpkg: error processing python-gnomekeyring (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of librsvg2-common:
 librsvg2-common depends on libgtk2.0-0 (>= 2.16); however:
  Version of libgtk2.0-0 on system is 2.12.9-3ubuntu5.
 librsvg2-common depends on librsvg2-2 (= 2.26.3-0ubuntu1.1); however:
  Package librsvg2-2 is not configured yet.
dpkg: error processing librsvg2-common (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of ufw:
 ufw depends on python (>= 2.6); however:
  Version of python on system is 2.5.2-0ubuntu1.
 ufw depends on upstart-job; however:
  Package upstart-job is not installed.
dpkg: error processing ufw (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-rsvg:
 python-rsvg depends on librsvg2-2 (>= 2.26.0); however:
  Package librsvg2-2 is not configured yet.
 python-rsvg depends on python (>= 2.6); however:
  Version of python on system is 2.5.2-0ubuntu1.
 python-rsvg depends on librsvg2-common; however:
  Package librsvg2-common is not configured yet.
dpkg: error processing python-rsvg (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-metacity:
 python-metacity depends on python (>= 2.6); however:
  Version of python on system is 2.5.2-0ubuntu1.
dpkg: error processing python-metacity (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Errors were encountered while processing:
 libgnomekbd4
 python-gnome2
 gdm
 initramfs-tools
 xchat-gnome
 python-wnck
 gnome-settings-daemon
 openoffice.org-gnome
 metacity
 libgnome-desktop-2-17
 python-gnomeapplet
 python-mediaprofiles
 openoffice.org-impress
 libgnome-window-settings1
 libpurple0
 openoffice.org-style-galaxy
 python-evince
 python-gnomecanvas
 libdeskbar-tracker
 policykit-1-gnome
 python-totem-plparser
 python-gnome2-desktop
 libappindicator0
 libevdocument2
 python-cairo
 gnome-control-center
 libevview2
 python-evolution
 python-pyorbit
 openoffice.org-draw
 python-gtop
 irssi
 openoffice.org-gtk
 python-gnomeprint
 dictionaries-common
 gnome-session
 libgtkhtml-editor0
 librsvg2-2
 libedataserverui1.2-8
 libgtk2-perl
 python-gnomedesktop
 x11-common
 python-glade2
 myspell-en-za
 util-linux-locales
 evolution-exchange
 python-gnomekeyring
 librsvg2-common
 ufw
 python-rsvg
 python-metacity
Processing was halted because there were too many errors. 

what should i do to fix this !!! please help me

thanks in advance