Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Speakers making a popping sound randomly throughout usage. (11.10)

  1. #1
    Join Date
    Dec 2011
    Beans
    8

    Speakers making a popping sound randomly throughout usage. (11.10)

    When I boot Ubuntu 11.10, the speakers make a popping sound. And when I run Skype, Banshee, and any other audio-based programs, my speakers pop. The speakers also pop at shut down. Like three times. And IT IS LOUD AND ANNOYING!!!

    Sincerely,
    Langstaff

    P.S.
    Please, respond with a reasonable and understandable answer. I just got Ubuntu four days ago.

  2. #2
    Join Date
    Jul 2011
    Location
    Lebanon
    Beans
    222

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    hello and welcome, can you give more info about your system?

    it might be a bug with the alsa driver bug#445135

    https://bugs.launchpad.net/ubuntu/+s...er/+bug/445135

    if so then the fix for it has been released follow the link above. hope this helps.
    Last edited by pierreyy; December 9th, 2011 at 12:07 AM.
    The Tim Taylor of Ubuntu!

  3. #3
    Join Date
    Nov 2010
    Location
    UK
    Beans
    12
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    Did this happen with your previous operating system, running the same hardware, or have you changed something hardware-wise? If so it's likely to be a hardware issue.

    Is it the same sort of noise you often get when plugging or unplugging audio cables with the power switched on? In that case, presuming it's not a hardware problem, then it could be that your sound card is being switched on and off every time it plays anything, which is weird as it should usually stay on all the time.

    It would help if you could post some more information about your setup. Are you using the built-in speakers in a laptop, stand-alone self-powered desktop speakers, an external amplifier/sound system, etc. Have you tried it with headphones to see if it makes the same noise?

  4. #4
    Join Date
    Dec 2011
    Beans
    8

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    It has never happened with my other OS. And I haven't changed anything hardware-wise, other than RAM, but that was before I got Ubuntu.
    They are built-in speakers. Also, I have heard of a power-save thingy that may be the problem, but I'm not sure. Again, I just got started you guys, so try to keep it simple please!
    And thanks for the quick reply, guys.
    Last edited by Langstaff; December 9th, 2011 at 12:23 AM.

  5. #5
    Join Date
    Nov 2010
    Location
    UK
    Beans
    12
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    Could you tell us a bit more about this power-save thingy you mention.

  6. #6
    Join Date
    Dec 2011
    Beans
    8

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    In other threads, I have heard of similar things happening to other people. (where people mention the term "power_save") Here's a few examples:

    http://ubuntuforums.org/showthread.php?t=1748115

    http://ubuntuforums.org/showthread.php?t=1314834

    To answer your question... I have no idea what it's about other than what it says in other posts.
    Last edited by Langstaff; December 9th, 2011 at 06:57 AM.

  7. #7
    Join Date
    Nov 2010
    Location
    UK
    Beans
    12
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    Okay, try running this command:

    Code:
    cat /etc/modprobe.d/alsa-base.conf
    Copy everything it displays and post it here.

  8. #8
    Join Date
    Dec 2011
    Beans
    8

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    Holy Cow! Here you are:

    marc_langstaff@ubuntu:~$ cat /etc/modprobe.d/alsa-base.conf
    # autoloader aliases
    install sound-slot-0 /sbin/modprobe snd-card-0
    install sound-slot-1 /sbin/modprobe snd-card-1
    install sound-slot-2 /sbin/modprobe snd-card-2
    install sound-slot-3 /sbin/modprobe snd-card-3
    install sound-slot-4 /sbin/modprobe snd-card-4
    install sound-slot-5 /sbin/modprobe snd-card-5
    install sound-slot-6 /sbin/modprobe snd-card-6
    install sound-slot-7 /sbin/modprobe snd-card-7

    # Cause optional modules to be loaded above generic modules
    install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
    #
    # Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
    install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
    install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
    install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
    #
    install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
    # Cause optional modules to be loaded above sound card driver modules
    install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
    install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

    # Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
    install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
    # Prevent abnormal drivers from grabbing index 0
    options bt87x index=-2
    options cx88_alsa index=-2
    options saa7134-alsa index=-2
    options snd-atiixp-modem index=-2
    options snd-intel8x0m index=-2
    options snd-via82xx-modem index=-2
    options snd-usb-audio index=-2
    options snd-usb-caiaq index=-2
    options snd-usb-ua101 index=-2
    options snd-usb-us122l index=-2
    options snd-usb-usx2y index=-2
    # Ubuntu #62691, enable MPU for snd-cmipci
    options snd-cmipci mpu_port=0x330 fm_port=0x388
    # Keep snd-pcsp from being loaded as first soundcard
    options snd-pcsp index=-2
    # Keep snd-usb-audio from beeing loaded as first soundcard
    options snd-usb-audio index=-2

    Ok, I have no idea what that was... but I'm a beginner, so excuse my lametalk. I don't know Linux code yet.
    Last edited by Langstaff; December 10th, 2011 at 03:35 AM.

  9. #9
    Join Date
    Nov 2010
    Location
    UK
    Beans
    12
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    OK, it doesn't look like you have the power_save option enabled like in the thread you linked, so that can't be the problem. However, some of the threads mentioned other power saving features that can cause a similar problem. In either case, a popping sound usually happens when sound hardware is turned on or off, so power saving features would be the first thing to look at.

    Do you know what make or model sound card is installed in your PC?

  10. #10
    Join Date
    Dec 2011
    Beans
    8

    Re: Speakers making a popping sound randomly throughout usage. (11.10)

    My sound card is Conexant AC-Audio, possibly a CX20468-31. I think so. I haven't booted Vista in a while (I am using a multi-boot) to see what my sound card was, but it sounds like it is the Conexant AC-Audio CX20468-31 AC97. (Altec Lansing)

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •