Results 1 to 10 of 31

Thread: Help me make my webcam working

Hybrid View

  1. #1
    Join Date
    Dec 2010
    Location
    Chisinau, Moldova
    Beans
    21
    Distro
    Ubuntu 11.04 Natty Narwhal

    Help me make my webcam working

    Hi guys,

    Help me make my webcam working on Ubuntu 11.10 (64-bit).

    The webcam: "Gear Head Quick 5.0 MP WebCam w/ 720P HD Video"
    It is not working both in Cheese and Skype. But it works in Windows.

    lsusb gives:
    Bus 002 Device 006: ID 0ac8:3420 Z-Star Microelectronics Corp. Venus USB2.0 Camera

    I think that the system sees it. When it is disconnected, Cheese gives me "No device found". When I connect the camera it's just the black screen in Cheese and all the menus are inactive.

    I'm not and advanced Linux user and I just don't know what to do.

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,840
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Help me make my webcam working

    Hi dumitru.

    Have you try the LD_PRELOAD trick? Read about it here.

    Hope it helps.
    Regards.

  3. #3
    Join Date
    Sep 2009
    Beans
    2,330

    Re: Help me make my webcam working

    open a terminal type dmesg click enter
    after it stops click close retry cheese

  4. #4
    Join Date
    Dec 2010
    Location
    Chisinau, Moldova
    Beans
    21
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Help me make my webcam working

    Quote Originally Posted by no2498 View Post
    open a terminal type dmesg click enter
    after it stops click close retry cheese
    I did this, nothing has changed.

  5. #5
    Join Date
    Sep 2009
    Beans
    2,330

    Re: Help me make my webcam working

    install guvcview
    rerun dmesg
    click close
    try it in guvcview

  6. #6
    Join Date
    Nov 2009
    Beans
    13

    Re: Help me make my webcam working

    When you start skype, right click the skype icon and choose options. pick video devices. Is your camera listed as a UVC device. If it is not, then you will need to find the correct driver.

  7. #7
    Join Date
    Dec 2010
    Location
    Chisinau, Moldova
    Beans
    21
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Help me make my webcam working

    Quote Originally Posted by no2498 View Post
    install guvcview
    rerun dmesg
    click close
    try it in guvcview
    Did everything. Guvcview detected my webcam "Devices: Venus USB2.0 Camera" but the screen is black, the same as with Cheese.
    I tried my webcam in Windows again and it works.

    PS: By the way, "guvcview" seems to be more user-friendly than "Cheese"

  8. #8
    Join Date
    Dec 2010
    Location
    Chisinau, Moldova
    Beans
    21
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Help me make my webcam working

    I tried to install "video4linux", but id didn't help as well. When it starts, it gives the following message:
    "Unable to get menu item for Exposure, Auto, index=0 Will use Unknown"
    "Unable to get menu item for Exposure, Auto, index=2 Will use Unknown"
    Last edited by dumitru; December 1st, 2011 at 06:31 PM.

  9. #9
    Join Date
    Dec 2010
    Location
    Chisinau, Moldova
    Beans
    21
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Help me make my webcam working

    Quote Originally Posted by papibe View Post
    Hi dumitru.

    Have you try the LD_PRELOAD trick? Read about it here.

    Hope it helps.
    Regards.

    Thank you, but I think the problem is how my system detects the webcam, not just Skype.
    I've inserted the line "alias skype='LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so skype' but nothing happened.
    Last edited by dumitru; December 1st, 2011 at 06:32 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •