Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Read and 'Write' HFS+ disk

  1. #1
    Join Date
    Oct 2011
    Beans
    78
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Arrow Read and 'Write' HFS+ disk

    I have a HFS+ external disk that I wish to use with Ubuntu.

    This is what I have done till now:

    Following the advice on
    Code:
    http://raamdev.com/2008/mounting-hfs-with-write-access-in-debian/
    I went for
    sudo apt-get install hfsplus hfsutils hfsprogs
    After which, I edited my fstab entry to include:

    8664920a-12b8-375e-98df-20100d87646e /media/katya hfs+ user ,rw,force 0 2
    Then, through Nautilus, I tried changing permissions for the external drive. I was unable to do that.

    I get the following error message:

    Sorry, could not change the permissions of "WD SmartWare": Error setting permissions: Read-only file system
    and

    The owner could not be changed. Sorry, could not change the owner of "katya": Error setting owner: Read-only file system
    'katya' is my external HFS+ drive's name.


    I understand that disabling 'journaling' in HFS+ is not a good idea as it is a useful function.

    I need to access the drive urgently.
    What's the solution?

  2. #2
    Join Date
    Oct 2008
    Beans
    323
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Read and 'Write' HFS+ disk

    i vaguelly remember having to disable journaling in HFS+ in order to access the drive for writing. I think thats the only way to do it but i let you google that yourself.

  3. #3
    Join Date
    Oct 2010
    Location
    London, UK
    Beans
    215
    Distro
    Ubuntu UNR

    Re: Read and 'Write' HFS+ disk

    Just a thought, but your fstab settings don't match mine:

    /dev/sda1 /mac hfsplus force,rw,exec,auto,users,uid=501,gid=100 0 1
    Gotta be honest I stole this setting from somewhere on the forums ages ago

    hope it helps!

    Edit: don't forget to restart after!
    Edit 2 - also just noticed you've got a space between user and the comma - if this is in your fstab, could also be a problem.
    Last edited by jjex22; November 30th, 2011 at 07:38 PM.

  4. #4
    Join Date
    Oct 2011
    Beans
    78
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Read and 'Write' HFS+ disk

    Quote Originally Posted by jjex22 View Post
    Just a thought, but your fstab settings don't match mine:



    Gotta be honest I stole this setting from somewhere on the forums ages ago

    hope it helps!

    Edit: don't forget to restart after!
    I entered your solution and tried to change user through nautilus. It did not work. Did you have a 'journaled' HFS+ drive by any chance?

    8664920a-12b8-375e-98df-20100d87646e /media/katya hfsplus force,rw,exec,auto,users,uid=501,gid=100 0 1
    Last edited by katya_sehgal; November 30th, 2011 at 07:40 PM. Reason: Additional Information

  5. #5
    Join Date
    Oct 2011
    Beans
    78
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Read and 'Write' HFS+ disk

    Quote Originally Posted by jjex22 View Post
    Just a thought, but your fstab settings don't match mine:



    Gotta be honest I stole this setting from somewhere on the forums ages ago

    hope it helps!

    Edit: don't forget to restart after!
    Restart the laptop or the drive?

  6. #6
    Join Date
    Oct 2011
    Beans
    78
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Read and 'Write' HFS+ disk

    Quote Originally Posted by cholericfun View Post
    i vaguelly remember having to disable journaling in HFS+ in order to access the drive for writing. I think thats the only way to do it but i let you google that yourself.
    I have also looked at solutions to disable journaling through Ubuntu and Windows. I have not found straightforward answers.

  7. #7
    Join Date
    Oct 2011
    Beans
    78
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Read and 'Write' HFS+ disk

    In the case anybody wants more information to solve this issue:

    Information about the external drive.

    I have 2 partitions. I have not made them. I had used this drive with a mac.

    /dev/sdb1 and /dev/sdb2

    /dev/sdb1 is fat32 (file system), boot(flag)

    /dev sdb2 is hfs+ (file system), and it's mount point is /media/katya
    This is the main partition, as in, it's size is 930.54 GB and my data goes in this partition.

    Using this info:

    8664920a-12b8-375e-98df-20100d87646e /media/katya hfsplus force,rw,exec,auto,users,uid=501,gid=100 0 1
    or

    8664920a-12b8-375e-98df-20100d87646e /media/katya hfs+ user ,rw,force 0 2
    Is there any error?
    Also note that I have installed the hfs programs using:

    sudo apt-get install hfsplus hfsutils hfsprogs
    Whether possible or not, kindly let me know.
    (If not, then what's the next best method)

  8. #8
    Join Date
    Oct 2010
    Location
    London, UK
    Beans
    215
    Distro
    Ubuntu UNR

    Re: Read and 'Write' HFS+ disk

    Hi there, it's definitely journalled - as is the mac way - it's on an internal partition though...

    But yes restart your PC - hopefully it'll pick it up at boot?

  9. #9
    Join Date
    Oct 2011
    Beans
    78
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Read and 'Write' HFS+ disk

    Quote Originally Posted by jjex22 View Post
    Hi there, it's definitely journalled - as is the mac way - it's on an internal partition though...

    But yes restart your PC - hopefully it'll pick it up at boot?
    At start up... serious error were found in disk drive...

    press i to ignore
    s to skip mount
    m for manual recovery


    I pressed "s" to skip mount



    Edit: I removed the usb and re-plugged it. Ubuntu is now reading the drive. For safety, I am deleting the fstab entry I had made.
    Last edited by katya_sehgal; November 30th, 2011 at 08:15 PM.

  10. #10
    Join Date
    Oct 2008
    Beans
    323
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Read and 'Write' HFS+ disk

    Quote Originally Posted by katya_sehgal View Post
    I have also looked at solutions to disable journaling through Ubuntu and Windows. I have not found straightforward answers.
    this is just very vague recollection of mine, i think it was an issue of switching off the journaling in OSX or never. Havent done any searches on recent developments though...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •